Arduino Forum

Products => Arduino Yún => Topic started by: dmackenziephoto on Sep 20, 2013, 05:05 pm

Title: arduino.local doesn't work
Post by: dmackenziephoto on Sep 20, 2013, 05:05 pm
I've got my Yun up and running, but I can't find it when I use arduino.local.  I have to supply the actual IP address.  I'm running this under Windows 7.  Is there something else I need to configure?

Thanks

David
Title: Re: arduino.local doesn't work
Post by: federicofissore on Sep 20, 2013, 05:09 pm
Is the IP address the default one (192.168.240.1) or something else?
Do you have an antivirus/firewall? If so, you need to be sure you have port 5353 UDP open (see this other thread http://forum.arduino.cc/index.php?topic=188101.msg1392211#msg1392211 )
Title: Re: arduino.local doesn't work
Post by: dmackenziephoto on Sep 20, 2013, 05:16 pm
I've configured the Yun to connect to my home network, so it's getting an IP address from the DHCP server.  I'm just trying to connect from a PC on the same network.

David
Title: Re: arduino.local doesn't work
Post by: federicofissore on Sep 20, 2013, 05:19 pm
Please double check your firewall/antivirus configuration. Take a look at the post mentioned above
Title: Re: arduino.local doesn't work
Post by: dmackenziephoto on Sep 20, 2013, 05:34 pm
I'll give that a try and see how it works out.  Thanks.
Title: Re: arduino.local doesn't work
Post by: wildpalms on Sep 20, 2013, 07:52 pm
The Windows PC needs some way of turning arduino.local into 192.168.xxx.xxx and like me you have no way of doing that automatically.

I just use the IP address although if the Yun has a fixed address then you can add the name and IP to a 'hosts' file the PC can use to look up.

Dave
Title: Re: arduino.local doesn't work
Post by: dmackenziephoto on Sep 20, 2013, 08:09 pm
Ah, thanks Dave.  I wondered if that was the case.  Thanks for confirming it.

David
Title: Re: arduino.local doesn't work
Post by: priority on Oct 04, 2013, 09:38 pm
Had the same problem, but really needed the dhcp server properly resolve the hostname as I intend to have multiple Yuns on my home network.   My home router is running DNSmasq which is set to respond to both dhcp and dns requests.

Turns out linino needs one more config setting to have the hostname be part of the dhcp request. Edit /etc/config/network and add the following under the "config interface 'lan'" section:
Code: [Select]
option hostname "arduino"
You can change the hostname to whatever you want, but make it match the name you have given your Yun in the "Yun Board Configuration" page (default is "arduino").

Reboot your Yun and it should now show up with a nice name in the list of dchp clients on your router.
Title: Re: arduino.local doesn't work
Post by: VideoLiam on Oct 05, 2013, 02:45 pm
Hi,

The arduino.local is not usually supported in a standard Windows install...

For those who might find host files difficult in windows, one piece of advice given to address the Local issue:-

@Federico Fissore stated:-
'I think it may be solved by installing Bonjour for windows by Apple. I'm pretty sure that's the right step to follow. Please follow it and let me know.
If it keeps non working, you could use the ip address shown in the IDE'

If that helps anyone...

Liam
Title: Re: arduino.local doesn't work
Post by: noblepepper on Oct 05, 2013, 03:19 pm
My Windows 7 box wouldn't find this either at first. I installed Bonjour Print Services from http://support.apple.com/kb/DL999 (http://support.apple.com/kb/DL999) and it works now.

Yes, I know installing a printing package to solve this makes no sense but it works for me. I did make sure to uncheck the two boxes about wanting information and automatic updates from Apple.
Title: Re: arduino.local doesn't work
Post by: noblepepper on Oct 16, 2013, 01:42 pm
Heads up-unchecking the tic boxes apparently doesn't stop all the propaganda about updates, probably just emails. A dialog box popped up a couple of times wanting to update some apple nonsense before I found you can use the settings menu to tell this package not to check for updates.
Title: Re: arduino.local doesn't work
Post by: mediamad on Oct 19, 2013, 05:02 pm
Quote

Turns out linino needs one more config setting to have the hostname be part of the dhcp request. Edit /etc/config/network and add the following under the "config interface 'lan'" section:
Code: [Select]
option hostname "arduino"
You can change the hostname to whatever you want, but make it match the name you have given your Yun in the "Yun Board Configuration" page (default is "arduino").

Reboot your Yun and it should now show up with a nice name in the list of dchp clients on your router.


Sorry for being such a noob but how do I get to /etc/config/network?  If I log in as root using the CLI to get to the linino I don't see any directories.  
Title: Re: arduino.local doesn't work
Post by: federicofissore on Oct 19, 2013, 06:26 pm
mediamad you don't need that. Just install Bonjour Print Services from Apple http://support.apple.com/kb/DL999
I know the name doesn't make sense, but they are enabling your Windows with Bonjour, that's the protocol the Yun use to broadcast its availability
Title: Re: arduino.local doesn't work
Post by: mediamad on Oct 20, 2013, 07:16 am

mediamad you don't need that. Just install Bonjour Print Services from Apple http://support.apple.com/kb/DL999
I know the name doesn't make sense, but they are enabling your Windows with Bonjour, that's the protocol the Yun use to broadcast its availability


I already have it installed on XP.  Still doesn't resolve my arduino name.
Title: Re: arduino.local doesn't work
Post by: federicofissore on Oct 20, 2013, 09:44 pm
mediamad, are you using windows firewall or some third party firewall like norton? the bonjour installer automatically creates rules for windows firewall and I guess you need to add them manually in case you use something else
Check out this post http://forum.arduino.cc//index.php?topic=188101.msg1392211#msg1392211
You need to open port 5353 UDP
Title: Re: arduino.local doesn't work
Post by: mediamad on Oct 21, 2013, 05:01 am
No firewall.  I can enter the IP address directly and all is well.  If I open Bonjour Browser I don't see the arduino listed under http interfaces.  So I guess the UDP broadcast  for some reason doesn't make to through my wifi router?  Guess I can try wireshark next.
Title: Re: arduino.local doesn't work
Post by: bramhalt on Oct 23, 2013, 03:32 pm
I found this and it works

Allow Logic Server TCP port

1.Note the TCP port used in Logic Server settings (default is 8080).
2.Open Start menu.
3.Open Control Panel.
4.Open Security Center.
5.Click Windows Firewall.
6.Click Exceptions tab.
7.Click Add Port.
8.Type the name "HTTP", enter Logic Server port number and select TCP.
9.Click OK.
10.Important: Activate the check box before HTTP in the list.
Title: Re: arduino.local doesn't work
Post by: mediamad on Nov 01, 2013, 06:51 am
Added hostname command to network config as priority suggested and it showed up in router and would ping but still wouldn't resolve in Firefox - so I tried IE and what do you know...