Arduino Forum

Forum 2005-2010 (read only) => Hardware => Development => Topic started by: greyskale on Dec 08, 2006, 02:38 am

Title: Arduino Mini schematic incorrect?
Post by: greyskale on Dec 08, 2006, 02:38 am
Perhaps I'm just imagining things, but I was looking at the Mini schematics last night and noticed that the chip is listed as an ATMEGA8 when it should be ATMEGA168 no? Also, the pictures of the board show all of 4 components total while the schematic shows 10. Just wondering regarding this because it's a little more unusual to have smt parts on both sides of the board.
I am working on a purpose specific Arduino board, so I want to make sure I can avoid including any unnecessary parts.
Title: Re: Arduino Mini schematic incorrect?
Post by: admin on Dec 08, 2006, 10:32 am
hi

a few notes

Atmega8 and 168 are pin compatible so it's all the same

the schematic is the bare minimum already but it's correct (it's the one used for production)

there are parts on the bottom side. it's quite common when you dont have that much space

making a custom smd board requires quite a bit of experience, wouldn't it be simpler to get a mini put your stuff on another board connected to it...


massimo
Title: Re: Arduino Mini schematic incorrect?
Post by: greyskale on Dec 08, 2006, 11:15 am
I'll be picking up a mini for dev work, but in the end I want a all in one board (it'll have more components to suit it's use).
I don't have any problem designing smt boards, but the software I use won't allow smt parts on the back of the board :(

thanks for the info though
Title: Re: Arduino Mini schematic incorrect?
Post by: admin on Dec 08, 2006, 12:43 pm
wow even eagle free version lets you do that
what software are u using?


BTW when you have made your board you should document it on the playground
Title: Re: Arduino Mini schematic incorrect?
Post by: greyskale on Dec 08, 2006, 08:11 pm
I'm using Osmand... I want to use Eagle, but I'm on a mac and I seem to have issues with the installer.

:edit: it won't let me install X11, telling me I already have a newer version installed (which I don't) so I can do anyting with it >:(
Title: Re: Arduino Mini schematic incorrect?
Post by: Daniel on Dec 08, 2006, 08:21 pm
try to get Eagle going, it is about twenty times better than Osmond. You need X11 to run it on a mac; I've installed Eagle on four macs with no problem...
Title: Re: Arduino Mini schematic incorrect?
Post by: greyskale on Dec 08, 2006, 08:24 pm
see above edit ^
Title: Re: Arduino Mini schematic incorrect?
Post by: greyskale on Dec 09, 2006, 02:20 am
Quote
try to get Eagle going, it is about twenty times better than Osmond. You need X11 to run it on a mac; I've installed Eagle on four macs with no problem...


do you have any advice regarding installation? when I try to install X11 I get the message: "You can not install X11 on this volume. Newer Software already exists on your computer"

This is untrue... I don't have X11 on my machine... hense the need for installation ;)
Title: Re: Arduino Mini schematic incorrect?
Post by: Daniel on Dec 09, 2006, 02:39 am
It could be a lot of different things causing that, and I'm no X11 expert... did you try trashing any preference file(s) for X11?

a quick google search comes up with this:
http://lists.apple.com/archives/x11-users/2006/Oct/msg00020.html

D
Title: Re: Arduino Mini schematic incorrect?
Post by: greyskale on Dec 09, 2006, 02:54 am
I think I know the issue now... I've been trying to install the version on apples site... this is an older version for 10.3. I'll try to use the installer on my 10.4 disks when I get home tonight and see if that works.
Title: Re: Arduino Mini schematic incorrect?
Post by: xSmurf on Dec 09, 2006, 08:26 am
You might also want to have a look at the installation receipt from X11 in /Library/Receipts/.
DesInstaller (http://macupdate.com/info.php/id/7511) is a nice little tool to deal with these (it also removes the associated files).

Also keep in mind that although you can start eagle from the Terminal.app (not xTerm) you need to have X11 started already for this to work!

If you still have problems, you could try installating Eagle from a package distribution (iirc Darwinports has it listed).

Hope this helps!