Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: HonicTheSedghog on Dec 21, 2014, 07:26 am

Title: Uno Cannot Connect to Network with Ethernet Shield
Post by: HonicTheSedghog on Dec 21, 2014, 07:26 am
I bought an Ethernet Shield for my Arduino from Radio Shack and I haven't been able to get any of the ethernet tutorials to work and I haven't found anyone on the web with the exact same symptoms that I have.
Below is some data of what I have and what I've tried:
Title: Re: Uno Cannot Connect to Network with Ethernet Shield
Post by: HonicTheSedghog on Dec 21, 2014, 11:32 pm
I have discovered more information that may be useful.

Without inserting the SD card, I added these two lines to the setup section for the Web Server tutorial (http://arduino.cc/en/Tutorial/WebServer):
pinMode(4, OUTPUT);
digitalWrite(4, HIGH);


The serial output that resulted from this change is:
server is at 175.45.199.175

When I tried to ping the address the serial console gave me this very strange, interesting response:
ping 175.45.199.175
PING 175.45.199.175 (175.45.199.175): 56 data bytes
36 bytes from 192.168.2.1: Destination Net Unreachable
Vr HL TOS   Len    ID Flg    off  TTL Pro   cks              Src                    Dst
 4   5   00 5400 de92   0 0000    3f  01 638f 192.168.2.2  175.45.199.175


This response is unlike any other response I usually get from ping, which usually says something like Request timeout for icmp_seq 0

Here are some conditions for the response: I'm wondering if I need to place a jumper between two pins. Help would be appreciated.