Arduino Forum

Forum 2005-2010 (read only) => International => Deutsch => Topic started by: fritz77 on Jan 21, 2011, 05:28 pm

Title: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: fritz77 on Jan 21, 2011, 05:28 pm
[size=12][size=14]Hallo Arduino-Forum,

[size=12]ich habe seit einiger Zeit vor den Arduino Mini zu betreiben,  

doch bekomme ihn einfach nicht zum laufen.

Ich habe das Forum und die englischen Threads natürlich alle schon durchgelesen und fleißig gesucht, aber

nicht das wirklich Abhilfe schaffende für meinen Arduino Mini gefunden.

Ich möchte beileibe nicht aufgeben, aber langsam verzweifle ich ein wenig an dem [ch8218]bockendem[ch8217] Mini

 (es ist ein Mini, kein Pro Mini)  [ch8211] [ch8218]...es muß doch irgendwie zu lösen sein![ch8217]

Nun noch etwas konkreter: Mein Aufbau entspricht dem auf: http://www.arduino.cc/en/Guide/ArduinoMini

gezeigten, ich habe auch gleich noch ein paar Fotos mitangehängt. Die Verbindungen habe ich mehrfach

geprüft und wiederholt für korrekt befinden können.

Ich habe die Version 04 des Arduino Mini.


Der Einfachheit halber habe ich zum Test jetzt immer das Example [ch8218]Blink[ch8217] genutzt. Mit der Programmierung

eines Arduino bin ich durch den [ch8218]Duemilanove[ch8217] im Allgemeinen vertraut, die USB-Verbindung, Version usw. [ch8218]haut[ch8217]...

Der gewählte COM-Port ist korrekt, sonst hätte ich eine andere Fehlermeldung erhalten.

Der USB-TTL-Adapter funktioniert und wird auch vom Rechner erkannt (den ersten mußten ich bereits wegen

Nichtfunktion reklamieren, dieser aber der mir jetzt vorliegt wird vom Rechner erkannt

[ch8222] ... und blinkert auch ein wenig beim [ch8218]anstöpseln[ch8217] [ch8220]  


Meine Fehlermeldung bleibt beständig unverändert:

avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

...da liegt wohl ein Kommunikationsproblem vor, aber wie ist es zu lösen ?


Ich habe stoisch die 10 Sekunden nach dem Drücken des Upload-Buttons das Reset durchgeführt. Dabei

nutzte ich die Vorgehensweise:  Reset-PIN auf +5V -----wechselt[ch8212]auf---> GND  ---->  zurück auf +5V.

(Dies habe ich für alle Arduino-Varianten, welche in der IDE (V.017) vorhanden sind [ch8218]durchprobiert[ch8217] , auch mehrfach.)

[Zusätzlich habe ich die ganze Prozedur nochmals für alle Arduino-Varianten nach dem Erscheinen der Meldung

[ch8222]Binary sketch size: 920 bytes (of a 14336 byte maximum)[ch8220]

(entsprechend also etwa 3 Sekunden nach Betätigen des Upload-Buttons) 'durchprobiert' ---> kein Ergebnis.]  

Die IDE will einfach nicht mit dem Mini reden... (!)

Was mache ich falsch ?

Ich bekomme es einfach nicht gelößt....

Wer kann helfen ?


beste Grüße


fritz77[/size]
[/size][/size]

(http://www.3d-fabber.de/ard-forum/706_2.jpg)

(http://www.3d-fabber.de/ard-forum/703_2.jpg)

Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: saw0 on Jan 21, 2011, 05:34 pm
Quote
Ich habe stoisch die 10 Sekunden nach dem Drücken des Upload-Buttons das Reset durchgeführt.


10 Sekunden?

Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: uwefed on Jan 21, 2011, 05:42 pm
Hallo fritz77

Das soll ein Arduino Mini Pro sein? Das auf den Fotos ist ein Arduino Mini komischerweise mit dem Logo von Sparkfun. Kontrolliere mal auf: http://arduino.cc/en/Main/Hardware

Laut dem Foto das Du angehängt hast hast Du Reset direkt auf +5V geschaltet (dunkelgelbes Kabel)

Wenn Du den Resetknopf drückst (der Arduino Mini Pro hat einen, der Arduini Mini nicht) machst Du einen Kurzschluß zwischen +5V und Masse.

Laß einfach das Kabel weg und drücke den Reset-taster KURZ, kurz nach dem Starten des Uploads oder verbinde den Reset-Ausgang des Interface mit dem Reset-Eingang des Arduino Mini Pro.

http://arduino.cc/en/uploads/Main/Arduino-Pro-Mini-schematic.pdf

Grüße Uwe

Edit: Hatte falsch gelesen; ist ein mini kein mini pro; richtige antwort weiter unten.
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: stundenblume on Jan 21, 2011, 06:06 pm
Code: [Select]
Das soll ein Arduino Mini Pro sein? Nein, er hat gesagt, dass es ein mini ist ;-)
http://arduino.cc/en/Main/ArduinoBoardMini
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Zuse on Jan 21, 2011, 06:22 pm
Hallo zusammen,

dieses kleine Schätzchen auf dem Foto entspricht exakt dem, den ich heute aus Fernost bekommen habe.
"Arduino Nano Mini Module 5V/16MHz for your bricks"

Habe die letzten 2 Stunden damit verbracht, die Pins zu prüfen und zuzuordnen, bis auf 3 Pins / Anschlüsse entspricht er meinem "großen" "Duemilanova ATMega 328/20".
Verbaut ist ein ATMega 168/20U, mit 16Mhz Quarz, +5V und auch +9V Anschluß (für die Versorgung mit einer Kompaktbatterie, nehme ich an), ohne USB-Drumherum und aller Wahrscheinlichkeit nach ohne irgendeinen Bootloader.

Meine nächste Aktion wird sein, ihn entsprechend dem Tutorial hier zu verschalten und zu testen, ob die Sache so funktioniert.
(Verwendung eines Arduinos zum Brennen des Bootladers auf einen "leeren" Arduino oder einen ATmega auf Steckbrett).

Gruß
Manfred
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: uwefed on Jan 21, 2011, 06:40 pm
@stundenblume
Hast Recht, hatte ich falsch gelesen. Bitte um Entschuldigung.

@fritz77
Bitte um Entschuldigung.
Wenn Du den Reset-Eingang fix auf +5V schaltest, wohin hast Du den Resettaster getan?

richtig: Reset-Eingang mit 10kOhm Widerstand auf +5V und Taster von Reset auf Masse.

@ManfredH

Quote
"Arduino Nano Mini Module 5V/16MHz for your bricks"

Das ist ein Widerspruch, oder nur eine Ungenauigkeit eines (illegalen) Nachbaus?

Arduino Nano ist ein kleiner Arduino mit USB Interface in DIP34 Größe also ein kompletter Arduino 2009
Ein Arduino Mini ist ein Arduino ohne USB-Interface ebenfalls in DIP24 Größe und mit dem ATmega168 und ohne Resettaster.

Wenn es ein Arduino sei soll dann muß der Boardloader auf dem Controller drauf sein, was ich stark annehme. Versuch doch einfach mal das blink-Sketch draufzuladen, dann siehst Du ob's funktioniert und darausfolgend ein Bootloader drauf ist.
Ansonsten negative Bewertung abgeben, weil es kein Arduino-Kompatibler Nachbau ist.

Oder ist es ein Arduino Stamp?  http://www.sparkfun.com/products/8164

Grüße Uwe
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Zuse on Jan 21, 2011, 07:09 pm
es ist zumindest ein Aufbau im DIP24 Format,
hier ist er:
http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItem&item=280602247335&ssPageName=STRK:MEWNX:IT#ht_3069wt_907
(ich hoffe, das klappt jetzt so mit dem Link)

Ich muß mich erst einmal einlesen, wie ich ihn über die RX/TX-Anschlüsse oder auf andere Art und Weise mit einem kleinen Testprogramm a la "Blink" versorge...

Vorschläge?

Gruß Manfred
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Zuse on Jan 21, 2011, 07:20 pm
Ergänzung:

ich habe gerade hier unter "Arduino - ArduinoBoard Mini" nachgesehen und in der Tat:
ich habe hier einen "Mini Rev.04", nur ohne die offiziellen Platinenaufdrucke.
Pin-Zuordnung stimmt völlig überein.
(hätte mir wirklich 2 Stunden mit dem Multimeter sparen können...)

Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: uwefed on Jan 21, 2011, 07:35 pm
Nicht ganz; laut Bilder haben die Chinensen einen Platz für einen Resettaster vorgesehen den der Mini nicht hat.

@ManfredH
Zur Programmierung:
a) über einen Arduino UNO oder 2009: Controller entfernen, TX, RX, 5V, Masse (GND) und Reset 1 zu 1 verbinden
b) mit einer USB-Interface-Platine TX mit RX und RXmit RX, 5V und Masse verbinden Reset mit Reset (falls vorhanden) oder DTR über 0,1µF Kondensator auf Reset.

Quote
(hätte mir wirklich 2 Stunden mit dem Multimeter sparen können...)
Nimms gelassen, Jetzt kennst Du die Platine ganz genau  ;)

Grüße Uwe  
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: fritz77 on Jan 21, 2011, 07:36 pm
Hallo Forum,

das geht ja wirklich richtig fix hier !

Herzlichen Dank zunächst einmal für die vielen Posts und Hinweise.

Ja, also es ist ein Mini wie ManfredH ihn beschreibt...


@Uwe: besten Dank für die rapiden Hinweise (..und wie Ihr schon selbst richtiggestellt habt: -es ist ein Mini  (Die Nano-Bezeichnung "Arduino Nano Mini Module 5V/16MHz for your bricks"(s.o.) ist natürlich irrig...)

- ich werde jetzt erst einmal die 10 Kilo vor den Reset setzen und mal einen Taster spendieren ist sicher zuverlässiger...

@MafredH:  ich habe die Beschaltung hier:

http://www.arduino.cc/en/Guide/ArduinoMini

zum ersten Probieren gewählt...  ... sollte doch eigentlich korrekt sein, oder ?

---> Bei mir dauert erst immer ein Weilchen, da ich noch andere "Baustellen" am Laufen habe...  <---



Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: uwefed on Jan 21, 2011, 07:41 pm
Quote
zum ersten Probieren gewählt...  ... sollte doch eigentlich korrekt sein, oder ?

Ich weiß nicht wieso viele glauben an Pin 13 könne man ein LED ohne Vorwiderstand anschließen.  :o :-? :-/
Bitte schalte dem LED einen 470 Ohm Widerstand in Reihe.
Ansonsten ja; zum ersten testen ist das OK.
Grüße Uwe
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: saw0 on Jan 21, 2011, 07:50 pm
Quote
Ich weiß nicht wieso viele glauben an Pin 13 könne man ein LED ohne Vorwiderstand anschließen.


Quote
Pin 13 has a 1 KB resistor on it, so you can connect an LED to it directly between it and ground. When using another pin, you will need an external resistor.
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: uwefed on Jan 21, 2011, 09:04 pm
Hallo apogee

Wo hast Du das gefunden? (das ist nicht böse gemeint sondern erstaunt).

In den Schaltbildern des Arduino 2009 und Arduino UNO finde ich diesen Widerstand nicht. Auch physisch auf meinen Arduino 2009 nicht.

Der Arduino Serial Version 1 und Version 2 hatten und der Arduino Single-Sided Serial haben einen Widerstand von 1kOhm zwischen Controller und PIN13 und kein LED.
Der Arduino NG (nuova generazione) hatte 2 Widerstände zu 470 Ohm in Serie und ein LED dazwischen auf Masse, meine Meinung muß das Probleme gegeben haben weil ein H pegel nur auf 1,6V kam und so eine Nutzung des Pins verbot.
Der Arduino Diecimila und der Arduino 2009 (Duemilanove) hat keinen Widerstand auf Pin 13 sondern ein LED mit einem Widerstand von 1kOhm auf Masse.
Der Arduino UNO hat keinen Widerstand auf Pin 13 sondern ein LED mit zwei Widerständen von 1kOhm paralell (=500Ohm) auf Masse.
Beide Versionen des Arduino Mega haben keinen Widerstand an Pin 13 und ein LEd mit 1kOhm auf Masse.

Der Arduino Mini hat einen 1KOhm Widerstand zwischen Controller und Pin 13.

[edit]Zusammefassend :
Die meisten aktuellen Modelle haben keinen Widerstand an pin 13.
[/edit]

Grüße Uwe



Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: sth77 on Jan 21, 2011, 09:10 pm
Zu finden hier: http://www.arduino.cc/en/Guide/ArduinoMini
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Realizer on Jan 21, 2011, 09:39 pm
Ich würde wirklich zuerst versuchen den Mini mit nem "großen" Arduino zu bespielen. Hat ja Uwefed schon geschrieben.  Damit kann man ziemlich sicher ausschließen ob der Konverter irgendwie nicht richtig funktioniert. @fritz77, probier das in jedem Fall gelegentlich mal aus. Dein erster Post klang wie ein Hilfeschrei ;)

Daher habe ich mir die Mühe gemacht mich mal mindestens ein wenig mit dem Mini einzulesen. Ich kann dir momentan auch nichts anderes sagen als das was bei arduino.cc und hier im Forum steht.

Und das mit dem Vorwiderstand von uwefed darfst du trotzdem sehr ernst nehmen. Wenn man weiß daß der Mini hier eine Ausnahme macht, sieht das anders aus ! Das war von uwefed rhetorisch gemeint. (Der Elektroniker denkt bei LED immer den Vorwiderstand mit) ;)
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Zuse on Jan 21, 2011, 10:42 pm
Uwe schrieb:
Zur Programmierung:
a) über einen Arduino UNO oder 2009: Controller entfernen, TX, RX, 5V, Masse (GND) und Reset 1 zu 1 verbinden


a) wirklich 1:1 verbinden?
ich hätte sponan RX mit TX und TX mit RX verbunden...

Manfred

PS: wie kann ich hier eigentlich zitieren?
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: saw0 on Jan 21, 2011, 10:47 pm
Quote
PS: wie kann ich hier eigentlich zitieren?


Der 8te Button von rechts, eine Seite mit einem blauen Pfeil

Text markieren den du zitieren willst, und dann draufklicken.
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Realizer on Jan 21, 2011, 10:50 pm
Quote
PS: wie kann ich hier eigentlich zitieren?

Wenn du einen Beitrag verfasst, dann kannst du da oben im Editor diese Sachen wählen...  flieg einfach mit der Maus darüber: "Insert Quote" oder "Insert Code" ... Die Formatierungen können auch nützlich sein ;) "Bold"

[edit] Ups, apogee, war ich später dran ... heute ist hier die Hölle los :)

Aber nun wieder schnell back to topic.

Quote
a) wirklich 1:1 verbinden?
ich hätte sponan RX mit TX und TX mit RX verbunden..

Nein, machs genau wie beschrieben.
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: uwefed on Jan 21, 2011, 11:30 pm
Hallo ManfredH

Quote
ich hätte sponan RX mit TX und TX mit RX verbunden...
Du ersetzt den Controller des Arduino 2009 mit dem Controller auf dem Arduino Mini; also TX mit TX und RX mit RX.


Wenn Du ein USB-Interface, ein XBee, ein Funkmodul, ein Bluetoothmodul ecc verwendest dann RX mit TX und TX mit RX.
In disem Fall bedeuten das bei TX Daten rauskommen und bei RX Daten reingehen sollen.

Ich verstehe Dich; das ist das leidige Problem bei der RS232 Schnittstelle. Da gibt es Daten-Sender-Geräte ( DTE zb PC) und Daten-Empfänger-Geräte ( zb ein Modem)  und bei Sendern ist TX auf pin 2 und bei Empfängern auf pin 3 (25-poliger Stecker). Deshalb hatte ich ofters Probleme daß eine RS232 nicht Funktionierte weil ich nie genau wußte ob es ein Sender oder Empfänger ist. Da half nur ein Zwischenstecker mit LEds an TX und RX. (Nachweinen alter Zeiten  :'().

Viele Grüße Uwe

Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: fritz77 on Jan 22, 2011, 01:51 am

Hallo nocheinmal allen,

zunächst möchte ich auch etwas Grundsätzliches sagen: Ich bin wirklich freudig überascht darüber, wie schön flüssig sich hier das Thema entwickelt !

Tolles Forum!    8-)   Gefällt mir...

Nun zur Sache:

Den Vorschlag zum (generellen) Vorwiderstand finde ich richtig und gut - schon aufdaß man sich das gar nicht erst falsch angewöhnt:

Quote
(Der Elektroniker denkt bei LED immer den Vorwiderstand mit)
 

- ganz richtig so. "Der Widerstand ist eben nicht zwecklos!"   ;)


Allerdings hat ich die Frage zum Vorwiderstand gar nicht aufgeworfen...  

(ehrlich gesagt hatte ich gleich gar keine Diode am Board 'hängen' (siehe auch die beiden Bilder im ersten Post), da mich zunächst einmal die

Meldung der IDE interessierte, es hatte ja noch 'nie' mit der Kommunikation zum 'Mini' funktioniert) Wenn es dann mal mit der Kommunikation ohne

Fehlermeldung klappt (was ich ja sehr hoffe...) dann bekommt das 'Blink' auch sein Hardware-Diödchen...  ((versprochen...))  (den Resttaster - mit 10 Kilo-R habe ich aber mitlerweile angestöpselt  ;) )


Und damit bin ich wieder beim ursprünglichen Problem:

Ich habe jetzt noch einige Versuche unternommen den 'Mini' mit dem USB-Konverter zum Laufen zu bekommen ---> wieder nichts...

(Zum Reset-Zeitpunkt habe ich verschiedenstes gelesen und einiges probiert --> helfen will scheinbar nichts ...)

Ist der Gedanke, das der Bootloader auf dem Teil fehlt vielleicht näher ins Auge zu fassen ?  

Wie auf:  http://www.arduino.cc/en/Guide/ArduinoMini  beschrieben hatte ich (vor Wochen) den 'Mini' auch schonmal am "nackten" µC-losen

Duemilanove, da tat sich aber auch nichts... (leider). Sogar einen baugleichen (exakt, gleiche Charge) 'Mini' hatte ich abgeschlossen.... ... auch nichts...

 (Bin mir allerdings nicht sicher, ob da noch ein COM-Port Problem war...)

Ich hatte da auch TX-TX, RX-RX wie hier schon richtig erläutert angechlossen. Und natürlich auch mal mit 'vertauschen' probiert nachdem es

nicht lief...  (aber das Ergebnis leider wie schon bekannt... funzt nich...)


Nebenher sollte der Betrieb am "nackten" 2009 auch das leidige Reset-Problem lösen (oder vielleicht doch nicht ? --> @Arduino-Typ in der IDE)

Ich werde das nun auf jeden Fall morgen (heute ?) nocheinmal versuchen und dann hier wieder berichten...  (Die Kiste muß doch zum

Laufen zu bringen sein...!)


Weiterhin bin ich jetzt auch mal sehr gespannt darauf, was Manfred mit seinem 'Mini' erreicht...   (und wo der 'Haken' ist...)



allerbesten Dank nocheinmal Euch allen für die schnelle und detailierte Beteiligung und konstruktive Hilfe...


Ahoi erst einmal


fritz77

Title: Re: Wer hilft? ArduinoMini Upl. Jetzt funzt es !
Post by: fritz77 on Jan 22, 2011, 12:28 pm

Hallo nocheinmal alle miteinander,

Wie ich heute morgen schon schrieb, wollte ich es mit dem "2009" nocheinmal versuchen und dabei

auf die 'Kleinigigkeiten' (wie geänderter COM-Port) usw. etwas mehr Acht geben...

Uwes und Realizers Vorschlag war das ja auch:

Quote
Ich würde wirklich zuerst versuchen den Mini mit nem "großen" Arduino zu bespielen. Hat ja Uwefed schon geschrieben.  Damit kann man ziemlich sicher ausschließen ob der Konverter irgendwie nicht richtig funktioniert. @fritz77, probier das in jedem Fall gelegentlich mal aus. Dein erster Post klang wie ein Hilfeschrei


Also habe ich den Duemilanove nocheinmal angestöpselt und siehe da:

'Neues Spiel - neues Glück' ... es funzt.

Zur Belohnung gab's auch ein Diödchen... (ohne meinen, aber mit elektrischen Widerstand :)  )


Hier nun nocheinmal die Konfiguration: Alles so wie oben von den Foren-Mitgliedern schon beschrieben: einfach  1:1


A.Duemilanove               A.Mini     (in meinem Falle und Bild die Farbe)
--------------------------------------------------------------------------------

+5V                   --->     +5V        ( Rot )  

GND                  --->      GND       ( Blau )  

TX                    --->       TX          ( Gelb )  

RX                   --->        RX          ( Weiss )  

Reset               --->        Reset      ( Orange / Dunkelgelb )  



(http://www.3d-fabber.de/ard-forum/ArdMini_001.jpg)


Der Upload von der IDE aus funktioniert regelrecht  mit Arduino Mini:

(http://www.3d-fabber.de/ard-forum/ArdMini_002.jpg)



So, damit ist die Pflicht erfüllt...  :-)

... und auch die Frage vom Teppich was nun mit dem Bootloader sei - es ist also einer darauf...

Nun 'fölge' noch die Kür mit dem FTDI-Konverter in der gezeigten Bauform

    (... wird es doch ein Problem mit dem Reset sein ?)


Soweit also zunächst einmal...


Ahoi


fritz77

Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Zuse on Jan 22, 2011, 01:33 pm
Hallo Fritz,
auch ich melde Vollzug!   :)

Nach mehreren vorgeblichen Fehlversuchen, das "Blink" Sketch als Test zu übertragen, blinkt die LED an Pin13 nun!
Deine orange Leitung zum RESET des Duemilanove war möglicherweise der Schlüssel... ich hatte zuvor die Reset-Leitung an PIN1 des leeren Sockels gesteckt...

Zwischenzeitliche Versuche, einen Bootloader zu schreiben - es klappte ja mit dem Blinken nicht und ich habe hier "nur" einen chinesischen Nachbau des offiziellen Mini, was mich vermuten ließ, dass hier ein Bootloader fehlt - waren ebenfalls vom Mißerfolg gekrönt...
aus welchen Gründen auch immer.

Aber das ist nun Schnee von gestern, auch mein Billig-Clone ist offensichtlich komplett und willens, zu funktionieren  :)

Auf zu höheren Aufgaben  ;D

Schönes, erfolgreiches Wochenende
Manfred
Title: Re: Wer hilft? ArduinoMini All fine.
Post by: fritz77 on Jan 22, 2011, 01:50 pm

Hallo Manfred,

na das freut mich ja für Dich ....

schön das nun alles funzoniert...

Bei mir im Übrigen, funktionierte der Orange-Draht an der IC-Fassung für den AVR...

... ich habe dann nur der Optik und schönen Ansicht wegen auf den - ja vorhandenen - Reste -Pin, nein, Reset-Pin geändert...

Na, wer weiß - war ja zielführend....

Ich bin Übrigens schon fleißig bei den 'höheren Aufgaben' --

ersteinmal LCD angepinnt (@mit wenigen Zeichenfehler im Vgl. zum 2009) und nun ein paar Diödchen mehr...


ob mit dem Ding auch SPI zu machen ist ? Es sollte doch ... ?


schaffensfrohe Grüße   ;)


fritz77

Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Zuse on Jan 22, 2011, 04:20 pm
Quote
ersteinmal LCD angepinnt (@mit wenigen Zeichenfehler im Vgl. zum 2009) und nun ein paar Diödchen mehr...


ob mit dem Ding auch SPI zu machen ist ? Es sollte doch ... ?


ein LCD angepinnt? mit wenigen Zeichenfehlern im Vergleich zum 2009?
mmh...
erkläre mal, habe jetzt keine Vorstellung...
Ich habe übrigens ein 16x4 LCD-Modul von Pollin (TC1604A-01) erfolgreich am "2009er" laufen.

Was mich mehr interessiert, ist das Problem von heute morgen, keinen Bootloader schreiben zu können.
Brauche ich zwar nicht, aber hätte doch funktionieren sollen, falls ich einen 168 / 328er ohne Bootloader erwischen sollte.

Gruß
Manfred
Title: Re: Wer hilft? ArduinoMini Upl. (nochmal mit Bildern)
Post by: Realizer on Jan 22, 2011, 08:55 pm
Zum Funktionieren des Mini, find ich gut.  :)
LCD daran, wäre ein schönes neues Thema.
Quote
Zur Belohnung gab's auch ein Diödchen... (ohne meinen, aber mit elektrischen Widerstand  :)  )

Ist tatsächlich in diesem Fall nicht nötig aber: Gut gemeint und vor allem Materialschonend :) (Langlebigkeit)

Warum es mit dem USBTeil nicht funktioniert, da würde ich versuchen mit einem Oszilloskop die Pegelwerte zu ermitteln. Oder ob überhaupt brauchbare Impulse rauskommen. Wo der Haken liegt, tappe ich im Dunklen.