Arduino Forum

Using Arduino => Microcontrollers => Topic started by: protomoose on Aug 03, 2015, 02:54 pm

Title: "RESET-EN" connections on Mega2560?
Post by: protomoose on Aug 03, 2015, 02:54 pm
The reference schematic for the Mega2560 seems a bit confused, around the area of the RESET-EN jumper. The symbol for the jumper is shorted out by a wire below it. Is this a mistake?

I would imagine that the RESET netname ought to reside to the right of the jumper, not beneath it on a short. That way, it would either be connected or not connected.

Just checking I'm not going too mad...
Title: Re: "RESET-EN" connections on Mega2560?
Post by: CrossRoads on Aug 03, 2015, 03:54 pm
Not a mistake.
Default configuration is the two pads are connected by a trace. Cut the trace if you don't want autoreset to occur.
Title: Re: "RESET-EN" connections on Mega2560?
Post by: protomoose on Aug 03, 2015, 04:15 pm
Many thanks.

So, slightly straying off topic, am I also correct in thinking that the ground option jumper for IC4 is normally shorted out, where it just connects UGND to GND? (Although the schematic is arranged a bit differently than above). And I wonder when cutting this would be appropriate?

Title: Re: "RESET-EN" connections on Mega2560?
Post by: CrossRoads on Aug 03, 2015, 04:46 pm
See section 20.3 of the '16U2 datasheet. It is not really clear to me why UGND is not connected to GND.
Perhaps there is an Atmel application note with more detail.
http://www.atmel.com/devices/atmega16u2.aspx?tab=documents (http://"http://www.atmel.com/devices/atmega16u2.aspx?tab=documents")