Arduino Forum

Using Arduino => Motors, Mechanics, Power and CNC => Topic started by: SIEVEPRIMESAXON on Aug 10, 2015, 06:00 am

Title: Servo! Help me!
Post by: SIEVEPRIMESAXON on Aug 10, 2015, 06:00 am
Hey guys!

I am struggling to make my servo work. The servo is connected to an external power source, and it is connected to pin 9. I am using the code from the example, "Sweep". The port and board choice are all right. I'm using an Arduino Uno. Please help me!! I have been stuck for hours!!!
Title: Re: Servo! Help me!
Post by: zoomkat on Aug 10, 2015, 06:11 am
Quote
The servo is connected to an external power source, and it is connected to pin 9.
Do you have the servo ground, arduino ground, and external power supply ground connected together?
Title: Re: Servo! Help me!
Post by: SIEVEPRIMESAXON on Aug 10, 2015, 06:39 am
Umm..... no. Let me try.
Title: Re: Servo! Help me!
Post by: SIEVEPRIMESAXON on Aug 10, 2015, 06:42 am
How do you do that?
Title: Re: Servo! Help me!
Post by: SIEVEPRIMESAXON on Aug 10, 2015, 07:26 am
All right! I got it to work! Thanks!
Title: Re: Servo! Help me!
Post by: MarkT on Aug 10, 2015, 11:18 am
Did you not try looking on Google for how to wire a servo?
Title: Re: Servo! Help me!
Post by: SIEVEPRIMESAXON on Aug 10, 2015, 04:12 pm
I did. However, some of the things that I read on Google were a bit misleading.
Title: Re: Servo! Help me!
Post by: eXXonWaldez on Aug 22, 2015, 07:13 pm
Always double check that you read on internet. Use at least two sources. That will help for time and safety.

Regards.