Arduino Forum

Forum 2005-2010 (read only) => International => Scandinavia => Topic started by: Danni_Hansen on Dec 03, 2010, 10:57 pm

Title: Fejl koder
Post by: Danni_Hansen on Dec 03, 2010, 10:57 pm
Hey..

Sidder med Arduino UNO, og noget tilbehør..
Og får denne fejlkode når jeg prøver at uploade det til min UNO (Som jeg har valgt at det var efter installation af main programmet til computeren.

Hvad betyder:

avrdude: stk500_getsync(): not in sync: resp=0x30
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

:)

På forhånd tak.
Mvh. Danni Hansen.
Title: Re: Fejl koder
Post by: bld on Dec 04, 2010, 11:08 am
Har du prøvet at søge på forummet efter det? Syntes jeg har set det en del gange
Title: Re: Fejl koder
Post by: Danni_Hansen on Dec 04, 2010, 11:03 pm
Hej.

Har vidst fået løst problemet sådan delvist.. Nu får jeg en anden fejlkode i stedet når jeg uploader til mit board, flg:
avrdude: ser_open(): can't set com-state for "\\.\COM12"
Title: Re: Fejl koder
Post by: tkj on Dec 05, 2010, 12:19 am
Hej Danni.
Jeg har fået samme fejlmeddelse en gang, kan især huske den fra dengang hvor jeg skulle lave noget automatiseret programmering af Arduinoen.
Grunden til at du får den fejlmeddelse er at Windows og AVRDude ikke er helt glad for hinanden når det drejer sig om COM porte over 10. Prøv derfor at gå ind i Enhedshåndtering og højreklik på COM12, for derefter at flytte den til en lavere COM port (<10)
Genstart Arduino IDE, vælg den nye COM port og prøv at Uploade igen - nu burde det virke.

Med Venlig Hilsen
Thomas Jespersen
Title: Re: Fejl koder
Post by: Danni_Hansen on Dec 05, 2010, 12:54 am
Hej Thomas.

Hmm, ændrede den til COM port 1, meeeen, den laver samme fejl endnu... :S
Title: Re: Fejl koder
Post by: Danni_Hansen on Dec 05, 2010, 02:31 am
Underligt, jeg kan godt lave et lyskryds der virker på arduino UNO, men, lige så snart jeg skal rode med Servo's, så virker den ikke som den skal.....

Forstår det ikke, det er altid Servo'erne der giver sidste nævnte fejl.
Title: Re: Fejl koder
Post by: tkj on Dec 05, 2010, 10:46 am
Hvilken PIN er Servoen koblet til?
Du skal være meget opmærksom på hvad du kobler til PIN 0 og 1, da det er disse to PINs der bliver brugt til programmeringen.
Hvis du altså har koblet noget til disse, så bliver du for det meste nød til at koble det fra før du kan programmere Arduinoen!

Thomas
Title: Re: Fejl koder
Post by: Danni_Hansen on Dec 05, 2010, 07:22 pm
Hej Thomas.

Har endeligt fået det til at virke, er dog lidt usikker på hvad der var galt.. :S

Tak :)