Arduino Forum

Forum 2005-2010 (read only) => Software => Interfacing => Topic started by: timvets on Sep 07, 2006, 11:07 pm

Title: arduino-PD:digital outs don't work?
Post by: timvets on Sep 07, 2006, 11:07 pm
I uploaded the firmware 'Pduino modified by dmorelli' to the arduino
then open pd patch 'arduino-help.pd'

all I can get to work is analog ins.

can't get a led to blink

the subpatch 'sendig digital outs' contains an abstraction or object named 'bytemask', wich i don't have...
could this be the problem?
if yes, what/where is [bytemask] ?

(I'm currently on windows, but planning to move to Linux)

thanks!
Tim

Title: Re: arduino-PD:digital outs don't work?
Post by: mellis on Sep 08, 2006, 09:38 am
I haven't used PD with Arduino, but I think there are two things that need to be set to use a digital output.  One is to set the pin as an output (as opposed to input), and the other is to set the pin high or low (on or off).  Also, I think there was some work on the PDuino stuff at Ars Electronica, but don't know if the new code is online yet.
Title: Re: arduino-PD:digital outs don't work?
Post by: timvets on Sep 08, 2006, 01:48 pm
the arduino-help patch contains toggles to set the digital ports to input or output, and there is a metro sending on/off to all ports set to output, but it doesn't work.

thanks,
Tim
Title: Re: arduino-PD:digital outs don't work?
Post by: armadillo on Oct 03, 2006, 01:18 am
tim i just had the same problem with the bytemask and debytemask objects.. i just dont understand why they are not included in the  pduino release since they are needed by the arduino-test.pd patch.... it took me half a day to digg them out of the pd-list:

http://lists.puredata.info/pipermail/pd-list/2006-06/039287.html

download those and put them in the same folder as the arduino-test.pd patch.. that should work, it did for me.

what im trying to do know is control a stepper motor from pd, any help or clue is appreciated, i will open a thread for it.

cheers,
/a