Arduino Forum

Products => Arduino GSM Shield => Topic started by: Leggit9 on Mar 02, 2016, 07:44 pm

Title: Sim900 powers down after network connection
Post by: Leggit9 on Mar 02, 2016, 07:44 pm
Hey guys. I bought Sim900 module like this:

(http://i01.i.aliimg.com/wsphoto/v0/2030816595_5/Free-Shipping-SIM900-GSM-GPRS-Function-Module-Adapter-Development-Boardfor-Raspberry-PI-with-GSM-Antenna-P0015839.jpg)

I  wanted to test it and a problem occured. When I turn on module, it automatically powers off after a few seconds. If I remove SIM card or detach antenna, module stays on. So, I assume it powers down after it connects to network. As a power source, I'm using AC adaptor with 5V and 2A output as recommended.

Did anyone have a problem like this and knows how to solve?
Title: Re: Sim900 powers down after network connection
Post by: dannable on Mar 02, 2016, 09:41 pm
The symptoms you describe are, as you suspect, indicative of a lack of power. You have set the power switch to 'ext' (or whatever it's marked!)?
Title: Re: Sim900 powers down after network connection
Post by: Leggit9 on Mar 03, 2016, 05:07 pm
The symptoms you describe are, as you suspect, indicative of a lack of power. You have set the power switch to 'ext' (or whatever it's marked!)?
There are two options to select: EXT or ERN. If I select EXT, module doesn't work at all. So I select ERN, but then my mentioned problem occurs.
Title: Re: Sim900 powers down after network connection
Post by: dannable on Mar 03, 2016, 08:33 pm
You have got the power supply plugged into the shield haven't you? In that case it should work when the switch is the the 'Ext' position.

On mine the other position is marked 'Xduino'.
Title: Re: Sim900 powers down after network connection
Post by: Leggit9 on Mar 04, 2016, 08:40 am
You have got the power supply plugged into the shield haven't you? In that case it should work when the switch is the the 'Ext' position.

On mine the other position is marked 'Xduino'.
Yes, power supply is plugged into the shield. Any other suggestions? Maybe I need 3 Amps or more power supply?
Title: Re: Sim900 powers down after network connection
Post by: dannable on Mar 04, 2016, 09:10 am
Well you said it didn't work at all when it was set to 'Ext', and if that is the case you need to investigate that. There should be some sign of life. What voltage range is recommended for the external supply?
Title: Re: Sim900 powers down after network connection
Post by: Leggit9 on Mar 06, 2016, 01:12 pm
Well you said it didn't work at all when it was set to 'Ext', and if that is the case you need to investigate that. There should be some sign of life. What voltage range is recommended for the external supply?
In my GSM shield description there is no information about voltage range. I bought it on Aliexpress.com, so description is very poor. On the other side of the shield, there is written 5V. On internet I found the same GSM shield and it says that range is 5V +- 0.2V.
Title: Re: Sim900 powers down after network connection
Post by: Leggit9 on Mar 07, 2016, 02:13 pm
The board I have has a little bit different switch:

(http://s30.postimg.org/5lp60xom9/Untitled.png)

This is the description:

100% brand new and high quality
The GPRS Shield is based on SIM900 module from SIMCOM and compatible with Arduino and its clones. The GPRS Shield provides you a way to communicate using the GSM cell phone network. The shield allows you to achieve SMS, MMS, GPRS and Audio via UART by sending AT commands (GSM 07.07 ,07.05 and SIMCOM enhanced AT Commands). The shield also has the 12 GPIOs, 2 PWMs and an ADC of the SIM900 module(They are all 2V8 logic) present onboard.
Features
Quad-Band 850 / 900/ 1800 / 1900 MHz - would work on GSM networks in all countries across the world.
GPRS multi-slot class 10/8
GPRS mobile station class B
Compliant to GSM phase 2/2+
Class 4 (2 W @ 850 / 900 MHz)
Class 1 (1 W @ 1800 / 1900MHz)
Control via AT commands - Standard Commands: GSM 07.07 & 07.05 | Enhanced Commands: SIMCOM AT Commands.
Short Message Service - so that you can send small amounts of data over the network (ASCII or raw hexadecimal).
Embedded TCP/UDP stack - allows you to upload data to a web server.
RTC supported.
Selectable serial port.
Speaker and Headphone jacks
Low power consumption - 1.5mA(sleep mode)
Industrial Temperature Range - -40°C to +85 °C
Size:8.5x5.7x2cm(approx)
Title: Re: Sim900 powers down after network connection
Post by: dannable on Mar 07, 2016, 02:32 pm
If you connect the power supply to the shield, with the power selection switch set to 'ext', does anything happen?
Title: Re: Sim900 powers down after network connection
Post by: Leggit9 on Mar 08, 2016, 11:43 am
If you connect the power supply to the shield, with the power selection switch set to 'ext', does anything happen?
Yes, it works on EXT. There is a very narrow gap between components where these letters are, so I got confused at first. Sorry. Now I see that it works on EXT, but the problem I mentioned in the first post remains.

(http://s12.postimg.org/co8bpgej1/PHOTO_20160308_123220.jpg)
Title: Re: Sim900 powers down after network connection
Post by: dannable on Mar 08, 2016, 08:39 pm
In that case I'm at a loss at what to suggest. It seems to definitely be a power issue, but if you are supplying the necessary voltage as per your previous post then I just don't know.
Title: Re: Sim900 powers down after network connection
Post by: xvlads on Mar 18, 2016, 10:32 am
Definitely, bad power supply.

Try 12V. There is a step-down voltage regulator on board.
I feed 12V DC to my board (exactly same as yours), the switch is downside position (away from the nearest board edge )
And the marking says EXTERN (not EXT/ERN) :)
You can provide either 6-12V external power via this connector, or plug 5V directly into board.
Do not forget to connect grounds if you use different power supplies to power Arduino and GSM

Title: Re: Sim900 powers down after network connection
Post by: Piqueremy on Oct 15, 2016, 06:14 pm
Hi,

Quote


Definitely, bad power supply.

Try 12V. There is a step-down voltage regulator on board.
I feed 12V DC to my board (exactly same as yours), the switch is downside position (away from the nearest board edge )
And the marking says EXTERN (not EXT/ERN) :)
You can provide either 6-12V external power via this connector, or plug 5V directly into board.
Do not forget to connect grounds if you use different power supplies to power Arduino and GSM


Unquote


Did this help? I have the same problem...
Title: Re: Sim900 powers down after network connection
Post by: Piqueremy on Oct 21, 2016, 12:58 pm
By accident I found the solution (at least in my case...).
Instead of a 12V battery (2200 mAh) connected to the UNO, I connected a 7.5V adapter to it. And everything worked fine, no more disconnection when sending SMS. So I used a DC-DC-step-down converter (ca. 1,50€) to supply my UNO with 9 V. Now everybody is happy: UNO,GSM.shield and myself...