Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: rich1812 on Mar 05, 2016, 11:59 pm

Title: Annoying avrdude: stk500_getsync error
Post by: rich1812 on Mar 05, 2016, 11:59 pm
Hi, I have google many times about this error. I haven't found any definitive answer about how to fix this stupid error permanently. So often, I can upload code smoothly for a long time, then out of the blue I get this error. I restarted the arduino, re-paired with the Mac, reboot the Mac.. Nothing works. What the hell causes this error? What exactly caused this problem? Is there a bug in the Arduino IDE? A bug in the firmware or what? Does anyone have a permanent solution? I use OS X buy the way.
Title: Re: Annoying avrdude: stk500_getsync error
Post by: ieee488 on Mar 06, 2016, 04:25 am
Try IDE 1.6.5
Try Linux

Title: Re: Annoying avrdude: stk500_getsync error
Post by: DrAzzy on Mar 06, 2016, 11:18 am
Since you have not included the full text of the error message, it's anyone's guess what the cause of the problem is. That error can indicate something else connected to the serial pins, or it could indicate improper board selection, a driver problem, or the wrong port selected, or damaged bootloader, or many other things.

Enable verbose uploads and post the output here.
Also, what board you're using?
What version of Mac OS?
What version of the IDE?
What were you doing when it stopped working?

Do you have anything else connected to pins 0 or 1? That will break uploads if you do.

What are you pairing with the mac? What does that have to do with Arduino?

@ieee488 - getsync error occurs during the upload process. AFAIK, the stuff they broke in 1.6.6/1.6.7 is related to compiling, not uploading.
Title: Re: Annoying avrdude: stk500_getsync error
Post by: maheshios on Mar 06, 2016, 01:17 pm
I am also getting same problem when i upload Blink sketch just changing delay time to 100, i have attached log below


I am working on OS X EI Captain 10.11.3

Arduino: 1.6.7 (Mac OS X), Board: "Arduino/Genuino Uno"

"/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/MyBlink.ino.elf" "/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/sketch/MyBlink.ino.cpp.o" "/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/core/core.a" "-L/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp" -lm
"/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0  "/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/MyBlink.ino.elf" "/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/MyBlink.ino.eep"
"/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avr-objcopy" -O ihex -R .eeprom  "/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/MyBlink.ino.elf" "/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/MyBlink.ino.hex"

Sketch uses 1,030 bytes (3%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/cu.usbmodem1421 -b115200 -D -Uflash:w:/var/folders/c1/7khh3jqn0jnbr273smbrgvkr0000gp/T/build5c439e588dd52b6f0bfedfe244b60838.tmp/MyBlink.ino.hex:i

avrdude: Version 6.0.1, compiled on Apr 14 2015 at 16:30:25
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2009 Joerg Wunsch

        System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
        User configuration file is "/Users/VINO/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port                    : /dev/cu.usbmodem1421
        Using Programmer              : arduino
        Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.
Title: Re: Annoying avrdude: stk500_getsync error
Post by: BoulderDay on Mar 06, 2016, 01:44 pm
Hi, I have google many times about this error. I haven't found any definitive answer about how to fix this stupid error permanently. So often, I can upload code smoothly for a long time, then out of the blue I get this error. I restarted the arduino, re-paired with the Mac, reboot the Mac.. Nothing works. What the hell causes this error? What exactly caused this problem? Is there a bug in the Arduino IDE? A bug in the firmware or what? Does anyone have a permanent solution? I use OS X buy the way.
I had a similar problem with an Ubuntu 14.04 laptop.  My Linux Mint Desktop connected fine, but my Ubuntu laptop gave the avrdude error.  I went through a bunch of online searching to find a solution.  No joy.  Finally I solved the problem   by 'sudo chmod 777 /dev/ttyACM0'  I know OSX  is BSD based.... could it be a simple permissions problem?
Title: Re: Annoying avrdude: stk500_getsync error
Post by: rich1812 on Mar 06, 2016, 02:24 pm
OK, here is the complete log of the failed upload. From what I read, this problem seems to be a wide spread problem cross all platforms. Mac, Linux and Windows. One can easily dismiss it on the user error, such as the incorrect port etc. But in my case, I use OS X 10.11.3 I know I use the correct port. The fact that I could upload successfully many times without issue, than out of the blue this error occurs, base of the above clues, tell me that there is something fundamentally wrong with the Arduino, perhaps the firmware? Perhaps the IDE? (I was using IDE 1.6.5, but I just upgraded to !.6.7 and still the same error!) That's what I intend to find out, get to the root of the problem and fix it once and for all.

Error log:
Arduino: 1.6.5 (Mac OS X), Board: "Arduino Nano, ATmega328"

Sketch uses 4,078 bytes (13%) of program storage space. Maximum is 30,720 bytes.
Global variables use 244 bytes (11%) of dynamic memory, leaving 1,804 bytes for local variables. Maximum is 2,048 bytes.
/Applications/Arduino.app/Contents/Java/hardware/tools/avr/bin/avrdude -C/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf -v -patmega328p -carduino -P/dev/cu.wchusbserial1d1320 -b57600 -D -Uflash:w:/var/folders/j3/ykps353n77q369zwjsxpf6sm0000gn/T/build2427596596682328549.tmp/Lucy-sideBalznceTest.cpp.hex:i

avrdude: Version 6.0.1, compiled on Apr 14 2015 at 16:30:25
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/dick/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.wchusbserial1d1320
         Using Programmer              : arduino
         Overriding Baud Rate          : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.