Arduino Forum

Using Arduino => Sensors => Topic started by: badweasel on Apr 19, 2016, 06:00 am

Title: Problem talking with Priority 1 RFID reader
Post by: badweasel on Apr 19, 2016, 06:00 am
I just got an RFID reader from Priority 1 Design in Melbourne.

I've already read over this post: http://forum.arduino.cc/index.php?topic=253703.0  However that is a different board than the one I bought.  I got this one:

http://www.priority1design.com.au/shopfront/index.php?main_page=product_info&cPath=1&products_id=37

Which says that it has a ttl serial port.  Data sheet is here: http://www.priority1design.com.au/rfidrw-e-ttl.pdf

My arduino is a nano V3.  I have 2 setups:  Development setup is plugged in to USB and powered by my mac.  Live setup is powered by a walwart with +5.4v on VCC and ground on one of the various GNDs.

See the attached photo.  I have the board's TX going to Arduino A2, and RX going to Arduino A3.  Using SoftwareSerial:

Code: [Select]
const int RF_RECEIVE_pin=2;
const int RF_TRANSMIT_pin=3;
int incomingByte = 0;

SoftwareSerial RFID(RF_RECEIVE_pin, RF_TRANSMIT_pin); // RX, TX


This setup worked fine on the cheapo RFID board I got from china. But with this board I'm not seeing anything coming back.

Am I doing this wrong?  Is it that the TTL serial on the board isn't compatible with the SoftwareSerial?


A second question has to do with power.  I don't want to blow the usb port on my mac.  So can I power the arduino via the wallwart and also have it attached to usb at the same time?  Otherwise how can I see console output to know if I'm communicating with the rfid board?  Because the board specs say it needs 5.5v and via USB it's only getting about 3.7v.

(https://forum.arduino.cc/index.php?action=dlattach;topic=394980.0;attach=163792)
Title: Re: Problem talking with Priority 1 RFID reader
Post by: badweasel on Apr 19, 2016, 06:40 am
I swapped and am using the digital pins instead of the analog pins on the arduino for the softwareSerial.  Still no love though.  No indication that it's communicating with the board.
Title: Re: Problem talking with Priority 1 RFID reader
Post by: badweasel on Apr 19, 2016, 07:48 am
Ok...

https://www.arduino.cc/en/Reference/softwareSerial

"Not all pins on the Leonardo and Micro support change interrupts, so only the following can be used for RX: 8, 9, 10, 11, 14 (MISO), 15 (SCK), 16 (MOSI)."

I'm using a nano.  I switched my pins to 8 and 9 and am now talking with the board.  Although still not reading RFID tags with it yet.  I will update here when I get it working.
Title: Re: Problem talking with Priority 1 RFID reader
Post by: badweasel on Apr 21, 2016, 09:02 am
I have it all working now.  The answer was that the nano or micro doesn't support change interrupts on some pins.  When I switched to pins 8 and 9 I was able to talk to the board and everything works.

Next though is another question which I'll ask in another thread.
Title: Re: Problem talking with Priority 1 RFID reader
Post by: clemenlg on Aug 14, 2018, 02:56 pm
Hi,
I'm trying to do the same as you, with this rfid reader/writer, with my nano, and I can't read RFID tags.
Can you put your code?
Regards
Title: Re: Problem talking with Priority 1 RFID reader
Post by: Hilkoking on Feb 14, 2019, 02:27 pm
Hey guys I have the same thing as in this post but I'm using a arduino uno i just can't read the tag tru the serial monitor and i don't know why not. So I am thinking or the sensor is failing or I am just pretty stupid. But to be sure I'm going for the (I'm pretty stupid) option first. And blame myself in the hope someone can help me pointing to the wright direction.

I have it connected to an uno board digital pin 2 and 3 (tried 7,8 10,11 and the norman TX and RX nothing helps. I put an  serial.println start RFID to test if there is an response and there is. So that should be good.
Here is my code

#include <SoftwareSerial.h>
SoftwareSerial RFID(2, 3); // RX and TX

int i;

void setup()
{
  RFID.begin(9600);    // start serial to RFID reader
  Serial.begin(9600);  // start serial to PC
}

void loop()
{
  if (RFID.available() > 0)
  {
     i = RFID.read();
     Serial.print(i, HEX); //Display the Serial Number in HEX
     Serial.print(" ");
  }
}

Any ideas where to look for?
Title: Re: Problem talking with Priority 1 RFID reader
Post by: wildbill on Feb 14, 2019, 02:50 pm
How is it wired up? How is it powered? Did you connect the grounds?
Title: Re: Problem talking with Priority 1 RFID reader
Post by: Hilkoking on Feb 15, 2019, 10:26 am
Hey thanks for your reaction. I wired it just the way it was in the picture this tread.
power to arduino 5v
ground to arduino ground
TX to digital 2 an rx to 3. I have 2 pictures
Title: Re: Problem talking with Priority 1 RFID reader
Post by: Hilkoking on Feb 19, 2019, 04:06 pm
Dous anybody had an idea? I tried different animal tags now with other setups measured if the board is getting power and the antenna is getting power too but still nothing to been seen on the serial monitor. On the pdf it said that the animal tags are default for reading but mabye I need to program the rfid board different first? And how do I do that? How do you talk to the board? I'm in need for some insight.
Title: Re: Problem talking with Priority 1 RFID reader
Post by: clemenlg on Jul 22, 2019, 09:24 am
Dous anybody had an idea? I tried different animal tags now with other setups measured if the board is getting power and the antenna is getting power too but still nothing to been seen on the serial monitor. On the pdf it said that the animal tags are default for reading but mabye I need to program the rfid board different first? And how do I do that? How do you talk to the board? I'm in need for some insight.
Hi, do you have any progress?