Arduino Forum

Products => MKR Boards => MKR1000 => Topic started by: thorathome on Apr 13, 2017, 03:19 am

Title: WiFi101 Cert Update error (from Firmware Updater) - Programmer not responding
Post by: thorathome on Apr 13, 2017, 03:19 am
Trying to update certs for SSL communications.
Have a Wifi101Shield (two actually)  Firmware is 19.4.4

I can easily upload and run programs on WiFi101s with Uno R2 or Mega 2560 no problem.


I want to update SSL Certificates, have been unable to use the
WiFi101 Firmware Updater in IDE 1.8.2 under Win10 Pro. 

I get "Programmer not responding" error from IDE when I tryu to update Certs.
Tried two different WiFi101 shields. 
Tried Uno R3 and Mega. 
Same issue. 

Any workarounds out there? 

(I can connect using WiFiClient, but not WiFiSSLClient in my script, even with the correct port numbers.)
 
All ideas welcome. 

Thanks.

Title: Re: WiFi101 Cert Update error (from Firmware Updater) - Programmer not responding
Post by: ballscrewbob on Apr 13, 2017, 04:03 am
You mention so many boards I wonder what you are ACTUALLY using ?

This section is MKR1000 specific,

There is also a 101 specific and a WiFi101 specific.

To update the certs you need to have the update sketch loaded in most cases but without knowing EXACTLY  what you really have I can only guess.


Title: Re: WiFi101 Cert Update error (from Firmware Updater) - Programmer not responding
Post by: ballscrewbob on Apr 13, 2017, 02:43 pm
Load the sketch from the wifi101 examples into the board called "FirmwareUpdater"

The board may (not always) now appear on a new com port that will be OK.

Select the WiFi101 Firmware Updater option and in there select the correct COM port and then TEST CONNECTION.

It should now work and you can add the certs you want from there.

It was mentioned that the latest firmware can only be uploaded with IDE 1.8.2 and that not all boards can accept the very latest dependin on board revisions.