Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: Capacea on Jan 26, 2011, 12:18 pm

Title: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: Capacea on Jan 26, 2011, 12:18 pm
Hi
This morning I have bought a Arduino MEGA 2560. I tried it on my PC that I work on and it kept blinking the led. Tried uploading a sketch... no result.
Tried installing the driver and windows shows up an error that says "Access is denied".
Tried the board on my laptop which runs Windows Xp and it works great.
What can I do to solve this problem?

Thanks
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: PaulS on Jan 26, 2011, 12:21 pm
Quote
Tried installing the driver and windows shows up an error that says "Access is denied".

Login in as administrator, then.
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: Capacea on Jan 26, 2011, 01:25 pm
I have tried to do that and I get the same result. Even tried to do this in safe mode.
I am the administrator of the computer. It has only one account.
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: PaulS on Jan 26, 2011, 01:37 pm
We'd need to know a bit more about exactly what you are doing. The post title specifically refers to the Arduino Mega 2560.inf file, but your post does not. Windows is not particularly helpful with many of its error messages.

"Access is denied" is a prime example. Access to what? What kind of access? Denied by who? Why?

Quote
Tried installing the driver and windows shows up an error

Can you describe exactly what you did? Screen shots would be nice.

I had no problems installing and using the software on Win 7, 64 bit, although I do not have a Mega (yet).
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: Capacea on Jan 26, 2011, 02:20 pm
Okay the things I have tried are:
-plug in Arduino mega 2560 and let windows solve the problem ... that did not work.
-plug in Arduino and try installing from device manager using .inf file and i get http://img143.imageshack.us/i/captureot.png/ (http://img143.imageshack.us/i/captureot.png/)
-try the same thing but in safe mode same error

Thanks
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: Capacea on Jan 26, 2011, 02:25 pm
I forgot to mention that when I tried installing in device manager, I was doing it manually, pointing the way to the .inf file.
Also tried doing it automatically but it was no good. 
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: Capacea on Jan 26, 2011, 02:45 pm
Thanks for the help I figured it out.
Found the solution here:
http://seoroot.com/blog/howto/access-denied-in-manual-driver-update-windows-7.html (http://seoroot.com/blog/howto/access-denied-in-manual-driver-update-windows-7.html)

Thanks
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: PaulS on Jan 26, 2011, 02:51 pm
I'm bookmarking that page for when my Mega arrives. Seems like a really dumb decision on Microsoft's part to decide that drivers will be encrypted. Who's key are they expecting to have been used?
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: ocozdemir on Jan 28, 2011, 02:47 am
I have the same Problem you have but in my case, I can't choose the option "encrypt contents to secure data" and I have no clue how to fix that.  FYI i have an arduino uno not an arduino mega. Could you help me on this problem.  I can't get my uno to communicate with my computer.

Thanks
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: Capacea on Jan 28, 2011, 09:43 am
If you go to Device Manager and plug in the Uno, what shows up? USB Serial Device or Unknown Device or Arduino Uno with exclamation mark?
If you have USB Serial Device, I got that for Windows XP with the duemilanove, you should install the above driver, this is not the case since it does not have the FTDI chip.
If you have unknown device, that is what happened with Mega on Windows 7, I had to install the USB to serial COM driver, and the it showed the Arduino Mega with exclamation mark and installed the Mega using the .inf file.

Hope this helps.
Good Luck 
Title: Re: Window 7 x64 unable to access Arduino MEGA 2560.inf
Post by: theassassinpig on Apr 11, 2014, 11:04 pm

If you go to Device Manager and plug in the Uno, what shows up? USB Serial Device or Unknown Device or Arduino Uno with exclamation mark?
If you have USB Serial Device, I got that for Windows XP with the duemilanove, you should install the above driver, this is not the case since it does not have the FTDI chip.
If you have unknown device, that is what happened with Mega on Windows 7, I had to install the USB to serial COM driver, and the it showed the Arduino Mega with exclamation mark and installed the Mega using the .inf file.

Hope this helps.
Good Luck 



My Encrypt button is greyed out