Arduino Forum

International => Deutsch => Topic started by: manu79 on Jan 26, 2011, 07:50 pm

Title: Halb OT: Elektronikfrage
Post by: manu79 on Jan 26, 2011, 07:50 pm
Heyhey,

mein erstes Arduinoprojekt ist fast fertig, aber ich habe ein kleines Elektronikproblem:
Eigentlich eine einfache Transistorschaltung, mit der ich zwei Servos an/abschalten will.
B = Digitalout vom Uno (Servos an oder aus)
C = +8V vom Akku
E = Servo

Natürlich alles mit Widerständen und auf Masse gelegt etc.

Problem:
Wenn ich am Kollektor einen Akku oder Batterien nehme, schwankt die Spannung am Emitter wie verrückt zwischen 1V und 4V - wenn ich jedoch ein Netzteil (verschiedene Spannungen zw. 5V und 9V probiert) nehme, ist sie stabil. Woher kommt das und wie kann ich das lösen?

P.S. Uno und Servos haben verschiedene Spannungsquellen, diese sind an Masse verbunden.

VG Manu.
Title: Re: Halb OT: Elektronikfrage
Post by: Realizer on Jan 26, 2011, 07:57 pm
@manu79, kannst du mal eine Skizze posten wie du das genau verschaltest hast ?
Ist es ein NPN oder PNP Transistor ?
Title: Re: Halb OT: Elektronikfrage
Post by: manu79 on Jan 26, 2011, 08:32 pm
Es ist ein NPN. Eben festgestellt: wenn Uno und Servos (Transistorschaltung) beide vom selben Akku versorgt werden, ist das Problem weg, wenn ich allerdings vor den Uno einen Spannungsregler schalte, damit er stabile 5V erhält, ist das Problem wieder da ???

Skizze kommt morgen, ich habe hier gerade keine Maus, nur so ein ätzendes Touchpad  :)
Title: Re: Halb OT: Elektronikfrage
Post by: Realizer on Jan 26, 2011, 08:56 pm

Skizze kommt morgen...
Ok, das ist gut. Alles Andere wäre Spekulation und Rätselraten. Wir kriegen das schon hin ! :)
Title: Re: Halb OT: Elektronikfrage
Post by: LC_Data on Jan 26, 2011, 11:55 pm
Denke ich auch... ich hab versucht es mir vorzustellen...
Geht zwar... eine Skizze wäre wirklich hilfreich...

Schau Dir mal das Konzept "Open Collector"  an...
d.h. Emitter auf Masse (Gnd),
den Uno an die Basis
und zum krönenden Abschluß den Servo mit seinem Minusanschluß an den Kollektor legen.
Was dann zum Abschluß noch fehlt ist die Versorgungsspannung für den Servo...
den Plus vom Servo an den Plus von der Vcc....
das wär´s eingentlich....
Title: Re: Halb OT: Elektronikfrage
Post by: manu79 on Jan 27, 2011, 08:43 am
So, hier die Skizze, Widerstände, LEDs und "Katzenfutter" habe ich nicht eingezeichnet:

Oberes Bild: Funktioniert, stabile Spannung am Servo wenn D12 auf 1 schaltet

Unteres Bild: Stark fluktuierende Spannung am Servo wenn D12 auf 1 schaltet


Wenn ich statt Spannungsregler den Uno mit 2. Spannungsquelle an Vcc verbinde (Massen verbunden) dasselbe in Grün, Spannung am Servo schwankt.

Wenn ich allerdings statt Akku (+8V) ein seperates Netzteil nehme und den Uno per USB mit Strom versorge funktioniert es wieder. Es muss irgendwas mit den Akkus zu tun haben, ich blick aber nicht was da los ist. Akkus wurden schon getauscht und geprüft, auch mit Batterien versucht.

Irgendwie fehlt der "Upload"-Button bei Attachments, deshalb hier als link: http://img19.imageshack.us/img19/3499/solarg.jpg

VG Manu

Title: Re: Halb OT: Elektronikfrage
Post by: manu79 on Jan 27, 2011, 08:58 am
P.S. Die Opencollector-Schaltung habe ich auch kurz probiert, ging aber garnicht, muss ich da einen PNP statt NPN nehmen?
Title: Re: Halb OT: Elektronikfrage
Post by: webmeister on Jan 27, 2011, 09:07 am
Quote
Die Opencollector-Schaltung habe ich auch kurz probiert, ging aber garnicht, muss ich da einen PNP statt NPN nehmen?

Ja, um +Spannung zu schalten, verwendet man einen PNP-Transistor.

+Spannung (8V) ist geschaltet, wenn D12 = LOW

Basiswiderstand für PNP nicht vergessen (gilt auch für NPN)
Title: Re: Halb OT: Elektronikfrage
Post by: manu79 on Jan 27, 2011, 10:37 am
Mein Vater vermutet Kopplungen und meinte, man müsste mal alles mit einem Oszi durchmessen. Habe mal überall noch Kondensatoren auf Masse drangehängt, ohne Erfolg. Falls alles nix hilft, werde ich mir ein Relais besorgen und damit schalten. Probiere nachher noch kurz die Opencollector-Lösung mit PNP ;)
Title: Re: Halb OT: Elektronikfrage
Post by: Realizer on Jan 27, 2011, 08:58 pm
Ich grüble gearde rum.

(http://www.abload.de/img/servoktkx.jpg)

Hier 2 NPN Transistoren, damit das Signal nicht invertiert wird. Die Freilaufdiode vorsichtshalber am Servo um Gegeninduktionen entgegenzuwirken.
Schaltung ist ungetestet und ins Blaue hineinkonstruiert. Ausprobieren :)


Title: Re: Halb OT: Elektronikfrage
Post by: uwefed on Jan 27, 2011, 11:48 pm
Hallo manu79
Damit ein NPN Transistor schaltet muß ein Strom von der Basis zum Emitter fließen. Die Basisspannung muß um 0,7V (Diodenstrecke) größer sein als die Emitterspannung.

Wenn Du den Kollector auf +8V hängst dann liegt am Emitter im nichtleitenden Zustand über den Servo ca Masse an. Sobald Du den Basiswiderstand auf 5V schaltest fließt ein Strom in die Basis und von Collektor zum Emitter, aber nur solange bis die Emittorspannung 4,3V ist ( 5V - 0,7V Basis-Emittorstrecke) dann sperrt der Transistor wieder.  
Da im Servo Kondensatoren und ein Motor ist, hat der Servo eine gewisse Verzögerung und der Strom steigt etwas langsam an.
Du hast einen wunderschönen Oszillator.

Darum muß ein NPN Transistor mit dem Emittor auf Masse.

Um einen Verbraucher auf + Versorgungspannung zu schalten braucht es 2 Transistoren und 2 Widerstände. Den ersten der den Spannungshub von 0-5V (arduinoausgang) auf 0 - +Vb (+8V) umsetzt und der zweite der die Last schaltet.

Das ist genau die Schaltung die Realizer gepostet hat, nur daß der Servo anstatt im Collektorstromkreis, im Emitterkreis des T2 ist.

Grüße Uwe

Title: Re: Halb OT: Elektronikfrage
Post by: Realizer on Jan 28, 2011, 05:19 am
Quote
Das ist genau die Schaltung die Realizer gepostet hat, nur daß der Servo anstatt im Collektorstromkreis, im Emitterkreis des T2 ist.


Habs mal bildlich festgehalten. Würde dies dann so aussehen ?

(http://www.abload.de/img/servo27ah4.jpg)

Ungetestet
Title: Re: Halb OT: Elektronikfrage
Post by: manu79 on Jan 28, 2011, 08:15 am
Ihr seid ja super, danke euch beiden. Es war tatsächlich so, dass ich am Servo zur eigenen Verwunderung nie viel mehr als 4V messen konnte. Jetzt weiß ich auch wieso.

Werde die Schaltung probieren, aber so sollte es nun ja auch klappen. :)
Title: Re: Halb OT: Elektronikfrage
Post by: uwefed on Jan 28, 2011, 10:47 pm
@manu79
Ganau so hab ichs gemeint.
@ Realizer  Danke Für die Illustration.
Wie zeichnest Du die Schaltpläne?
Ich bin immernoch bei Bleistift, Radiegummi und Papier ;)
Grüße Uwe

Title: Re: Halb OT: Elektronikfrage
Post by: Realizer on Jan 28, 2011, 11:03 pm
Ich benutze für die Schaltpläne Splan 6.0 (Demo) derzeit. Ich probiere verschiedene Software aus. Fritzing ist mir zu "seltsam" bzw habe mich noch nicht eingehend damit befasst. Bei Splan (Demo) ist es so, daß man die Daten nicht abspeichern kann. Daher besonn ich mich auf eine List ;) : Ich habe den Plan gezeichnet, das Raster ausgeschaltet und dann einen Screenshot gemacht. Der Rest: Bildbearbeitung.

Splan gefällt mir momentan am besten. Ca 40 Euro für die Vollversion. Ich denke die werde ich mir über kurz oder lang zulegen !

Zu dem Post: Weil wie gesagt die Schaltung in der Demoversion nicht abspeicherbar ist und der Thread noch nicht fertig war, habe ich mir abends gedacht:... Schalte den Computer nicht aus. Da kommt bestimmt noch ein Einwand von uwefed ;) . Daher habe ich den PC in den Suspendmodus gefahren und am nächsten Morgen deinen Einwand gelesen. Nun war ich in der Lage, die Schaltung (Splan war noch offen) zu modifizieren, einen Screenshot zu machen und hochzuladen.

Hach, was macht man nicht alles, mit wenig Geld, wenig Zeit ... aber viel Geduld :)
Title: Re: Halb OT: Elektronikfrage
Post by: uwefed on Jan 28, 2011, 11:10 pm
Bin ich schon so von Dir gefürchtet?

Danke für die Info.
Grüße Uwe
Title: Re: Halb OT: Elektronikfrage
Post by: Realizer on Jan 28, 2011, 11:32 pm

Bin ich schon so von Dir gefürchtet?


Huch, nein natürlich nicht. Ich bin froh daß du da bist. Irgendwie ergänzen wir uns immer.
Passt scho :)

aber nun wieder schnell back to topic ;) D.h. manu79 bringt uns hoffentlich neueste Erkenntnisse beim Versuch diese Schaltung umzusetzen !? ;)
Title: Re: Halb OT: Elektronikfrage
Post by: manu79 on Jan 31, 2011, 08:19 pm
:)

Leider muss ich es ein bissel aufschieben, da ich erstmal Teile ordern muss und auch grad viel Luft im Geldbeutel habe. Der Rest vom Projekt ist fertig (knappe 60 Arbeitsstunden?), mir fehlt aber auch noch ein 16Mhz-Quarz und paar andere Kleinigkeiten. Will sagen, es wird auf jedenfall umgesetzt, dauert aber noch kurz ;)
Title: Re: Halb OT: Elektronikfrage
Post by: uwefed on Feb 01, 2011, 12:43 am
Hallo manu79
Laß Dir Zeit.
Es gibt auch Treiber zB den UDN2981 der das gleiche wie die beiden Transistoren macht; falls Du mehrere Servos schalten mußt ist der eine alternative zu viele Transistoren.
http://www.datasheetcatalog.org/datasheet/allegromicrosystems/2981.pdf
Gute Arbeit
grüße Uwe