Arduino Forum

Community => Website and Forum => Topic started by: AlphaBeta on Feb 04, 2011, 01:42 am

Title: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: AlphaBeta on Feb 04, 2011, 01:42 am
I cannot upload a file to the playground. It redirects me to a page requiring password, but after the pass is entered, it redirects back.
Title: Re: PLAYGROUND BUG - cant upload file
Post by: prmpec on Feb 04, 2011, 11:27 am
Same problem for me. (If we are talking about Playground Wiki file attachment.)
Title: Re: PLAYGROUND BUG - cant upload file
Post by: BroHogan on Feb 04, 2011, 10:04 pm
Also same problem - use Attach tag in Playground, save, click on the link (with triangle), goes to page for password, does nor accept valid password.

I hope this can be fixed soon.
Title: Re: PLAYGROUND BUG - cant upload file
Post by: DojoDave on Feb 07, 2011, 07:27 am
Solved, at least it seems so. Please confirm. In the meanwhile I mark this as a [Solved] issue.

We just forgot to reactivate it after we upgraded the Playground's access to use the new identity server ... sometimes trying to be safe makes usability a disaster :-)

/d
Title: Re: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: AlphaBeta on Feb 07, 2011, 08:52 am
I got one step further. After I had chosen a file, and tried to click 'Upload' I was redirected to the 'Password required' page.
Title: Re: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: BroHogan on Feb 07, 2011, 04:53 pm
Not solved. Same symptoms as in Reply #2.
See attached screenshot. I get there and it won't accept my password.
Title: Re: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: DojoDave on Feb 09, 2011, 07:23 am
Hej you are right about it ... sorry, I made some tests in my local copy of Arduino, uploaded them, tried it there and it worked ... but I was obviously not looking at the right browser window. The issue is a little bigger than I thought in the first place. Both Cristian and I are looking into it.

/d
Title: Re: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: DojoDave on Feb 10, 2011, 09:36 am
not now it is fixed, Cristian made a rewrite of the class that commands the login and edit/upload rights for users in the playground. Even brought in the feature of including the editor's name to the page being written.

This bug is officially closed now.

/d
Title: Re: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: BroHogan on Feb 10, 2011, 05:09 pm
Quote
not it is fixed

Should read "now it is fixed". And I agree.  :)
It no longer goes to the log-on screen and just uploads the file.
Thanks David & Cristian.
Title: Re: [SOLVED] PLAYGROUND BUG - cant upload file
Post by: DojoDave on Feb 10, 2011, 05:32 pm
comment fixed :D