Arduino Forum

Products => Arduino Esplora => Topic started by: ardudee2 on Mar 09, 2018, 10:51 am

Title: Bug found - is it too late to fix?
Post by: ardudee2 on Mar 09, 2018, 10:51 am
The following program works fine for writeBlue or writeGreen, but fails for writeRed as soon as the tone function is called once. I tried to work around it by using writeRGB but the bug doesn't go away even with using that. The random delay code below just makes it easier to observe, and isn't related to the issue.

Code: [Select]
#include <Esplora.h>
void setup() {}
void loop() {
  while (1)
  { Esplora.writeBlue(random(200)); delay(500);
    Esplora.tone(random(100)); delay(500); };
}
Title: Re: Bug found - is it too late to fix?
Post by: pert on Mar 09, 2018, 11:05 am
Why do you think it might be "too late to fix"?
Title: Re: Bug found - is it too late to fix?
Post by: ardudee2 on Mar 09, 2018, 11:29 am
Because the Esplora is a discontinued product, I guess.
Title: Re: Bug found - is it too late to fix?
Post by: ardudee2 on Mar 10, 2018, 02:33 am
Why do you think it might be "too late to fix"?
Do the people who are responsible the Esplora library code read these forums? Or do I need to consider finding the library code myself and trying to fix it myself? Where would I look for it?
Title: Re: Bug found - is it too late to fix?
Post by: pert on Mar 10, 2018, 04:18 am
No, they usually don't read the forum. This is mostly a place for the Arduino community to talk and help each other.

It's certainly worth having a look at the library to see what you can do. I've never used an Esplora. I know that using Tone does interfere with PWM on certain pins.
Title: Re: Bug found - is it too late to fix?
Post by: ardudee2 on Mar 11, 2018, 10:47 pm
Thanks for the info. I'm not smart enough to even know where to look for the Esplora code, so I'll just have to leave it to smarter people to fix.
Title: Re: Bug found - is it too late to fix?
Post by: jlsogorb on Apr 25, 2018, 05:24 am
Maybe the site you are looking for is this one:
https://github.com/arduino-libraries/Esplora (https://github.com/arduino-libraries/Esplora)
Title: Re: Bug found - is it too late to fix?
Post by: pert on Apr 25, 2018, 06:07 am
Yes, that's it. If you want to find where the library is on your computer:
Title: Re: Bug found - is it too late to fix?
Post by: oqibidipo on Apr 25, 2018, 10:48 am
Because the Esplora is a discontinued product, I guess.
Are you sure?
https://store.arduino.cc/arduino-esplora (https://store.arduino.cc/arduino-esplora)