Arduino Forum

Topics => Home Automation and Networked Objects => Topic started by: yoman91 on Mar 30, 2018, 06:13 pm

Title: ESP8266 not responding
Post by: yoman91 on Mar 30, 2018, 06:13 pm
Hi all,

I've got a problem with this little ESP8266 module. I'm using this tool for flashing (made a jumper to pull down GPIO01):
It seems that I can flash it with arduino and with nodemcu firmware programmer as well. After flashing, I remove the jumper, and plug in again this programmer, but it looks like the esp8266 does not working. I tried many example projects via arduino with no luck. Led is not blinking, no communication on serial terminal. The wifi device itself netiher can be seen. I flashed back the original firmware with the help of this site: original fimware ( AT commands are not working. Has anybody faced this kind of issue?

Thanks in advance
Title: Re: ESP8266 not responding
Post by: ieee488 on Mar 30, 2018, 06:25 pm
Not sure the circuit of that programmer you bought.
If you can find the schematic, compare it to (

Title: Re: ESP8266 not responding
Post by: yoman91 on Mar 30, 2018, 11:24 pm
I will, thanks for the suggestion. But otherwise, after a successful flashing it should work if I switch gnd and vcc to a 3.3V power supply, correct me if I am wrong.
Title: Re: ESP8266 not responding
Post by: ieee488 on Mar 31, 2018, 01:28 am
When flashing I use a 3.3V power supply so I never switch.

I personally like the tutorial (
That's what I used.

I use a USB-TTL adapter and I built that circuit because I have the parts.
That programmer you bought should work, but they are new.

You may want to read ( The photos are too small.

Also read: (

Title: Re: ESP8266 not responding
Post by: yoman91 on Apr 01, 2018, 12:58 pm
I managed to debug the problem. Circuit was OK, programmer working. I noticed that at poweron the chip sends boot information on 74880 baud rate. I googled it and turned out that I used the wrong Flash mode setting. Setting it to DOUT flash mode solved the problem, ESP8266 is working.
Title: Re: ESP8266 not responding
Post by: AishwaryaKandadi on Mar 09, 2019, 09:01 am

Im Aishwarya i need help for esp8266 in the arduino atmega328p Programming declared PORTD but if i compile the same code with the espp8266(NODE MCU 1.0) its giving complier error

 how can i rectify this problem ,in place of PORTD register can i write any other one  for esp8266 board

Title: Re: ESP8266 interfacing with atmega328
Post by: IsukapatlaTaraUsha on Mar 23, 2019, 07:49 am
here is the code for interfacing esp8266 with ARDUINO UNO atmega328 to upload sensor data to THINGSPEAK API.

#include <SoftwareSerial.h>
#define RX 10
#define TX 11
String AP = "xxxxxxxxxxx";       // CHANGE ME
String PASS = "xxxxxxxxxxx"; // CHANGE ME
String API = "xxxxxxxxxxxxxxxx";   // CHANGE ME
String HOST = "";
String PORT = "80";
String field = "field1";
int countTrueCommand;
int countTimeCommand;
boolean found = false;
int valSensor = 1;
SoftwareSerial esp8266(RX,TX);
void setup() {
  sendCommand("AT+CWJAP=\""+ AP +"\",\""+ PASS +"\"",20,"OK");

  pinMode(trigPin, OUTPUT);
  pinMode(echoPin, INPUT);
void loop() {
 valSensor = getSensorData();
 String getData = "GET /update?api_key="+ API +"&"+ field +"="+String(valSensor);
 sendCommand("AT+CIPSTART=0,\"TCP\",\""+ HOST +"\","+ PORT,15,"OK");
 sendCommand("AT+CIPSEND=0," +String(getData.length()+4),4,">");
int getSensorData(){
  return random(1000); // Replace with your sensor program
void sendCommand(String command, int maxTime, char readReplay[]) {
  Serial.print(". at command => ");
  Serial.print(" ");
  while(countTimeCommand < (maxTime*1))
      found = true;
  if(found == true)
    countTimeCommand = 0;
  if(found == false)
    countTrueCommand = 0;
    countTimeCommand = 0;
  found = false;
 } (