Arduino Forum

Using Arduino => Audio => Topic started by: baum on Mar 06, 2011, 07:40 pm

Title: Amplifier
Post by: baum on Mar 06, 2011, 07:40 pm
So I build this circuit (http://www.afrotechmods.com/groovy/amplifier_tutorial/amplifier_tutorial.htm) (scroll to bottom of page).

I made the same circuit as shown, but I used an LM358 and 5V arduino supplies. It works (yay!) but there is an annoying overlay of a high-pitched tone. So if I speak into the mic, it is my voice + annoying tone. All my cap + resistor values are correct, I double checked. If it helps:the overlay tone is ~868Hz, according to my tuner.

Is it the op amp that I'm using? The power supply difference?

Thanks for any help!
Title: Re: Amplifier
Post by: RuggedCircuits on Mar 06, 2011, 07:45 pm
Well, you're getting away with a lot of stuff :)  The circuit is really designed to operate from split power supplies. By connecting the op-amp to +5V and 0V you are going to get a lot of distortion.

Try adding another 100k resistor from the '+' pin of the op-amp to its power supply (5V).

--
The Gadget Shield (http://ruggedcircuits.com/html/gadget_shield.html): accelerometer, RGB LED, IR transmit/receive, speaker, microphone, light sensor, potentiometer, pushbuttons
Title: Re: Amplifier
Post by: baum on Mar 06, 2011, 07:57 pm
Nope. :( Now there's a softer whine, and no audio from the mic. Guess I'll just stop being lazy and put together a +/-9V supply like I was supposed too. :)
Title: Re: Amplifier
Post by: Magician on Mar 06, 2011, 08:09 pm
It'd not works, link you posted shows OPA powering with +-9V.
Nothing wrong with a chip , it was design for:

"Single Supply Quad
Operational Amplifiers"
and they say:
"can operate at supply voltages as low as 3.0 V "


What is an error?
You have to change a circuitry when you powering single supply.
+input of the OPA has to be biased to half  of power voltage, one more resistor 100kOhm required
to be connected between +input and +5V
And capacitor in the negative feedback, would be helpful to prevent HF osculation.


Title: Re: Amplifier
Post by: baum on Mar 06, 2011, 08:11 pm
But the 100k resistor didn't work- It just made the output REALLY soft. I'll just do dual supply.

And where should I put the HF cap?
Title: Re: Amplifier
Post by: Magician on Mar 06, 2011, 08:23 pm
http://www.vellemanusa.com/downloads/0/minikits/manuals/manual_mk136.pdf
http://www.vellemanusa.com/us/enu/product/view/?id=351278

Cheers.
Title: Re: Amplifier
Post by: baum on Mar 06, 2011, 08:36 pm
I'll try that... Thanks.

(The circuit mentions an "8E2" resistor, is this 8x10^2, or 800?
Title: Re: Amplifier
Post by: Magician on Mar 06, 2011, 08:44 pm
It's 8.2 Ohm, my opinion, it's not necessary, as IC 5532 has overdrive (shorting output) protection.
For LM324 , the same:
• Short Circuited Protected Outputs

Title: Re: Amplifier
Post by: baum on Mar 06, 2011, 11:07 pm
OK. Now I built my split power supply, and it works! But, if I am not grounded, there is this annoying low buzz. When I am grounded (touching long wire, metal table, any large metal object, it is crystal clear. Any ideas?

Thanks for all the help so far! How I can spy of people!
Title: Re: Amplifier
Post by: baum on Mar 06, 2011, 11:07 pm
*now

Sorry.