Arduino Forum

Using Arduino => Audio => Topic started by: Solaya on Jun 20, 2018, 10:05 am

Title: humming noise – DFPlayer + Amplifier Pam8403
Post by: Solaya on Jun 20, 2018, 10:05 am
Hi everyone,
I hope you can help me with the problem of a humming noise when I connect an
Arduino Uno + DFPlayer mini + the amplifier Pam8403.
I tried already many things that I found in this and other forums. I would really appreciate your help!!

my assembly:
circuit 1 + code (http://www.electronics-lab.com/project/mp3-player-using-arduino-dfplayer-mini/): everything worked
circuit 2 (see attachment or http://www.belajarduino.com/2016/10/arduinop.html): humming noise appears on the speakers connected to the amplifier

listen here: https://www.dropbox.com/s/prym2896btk0f1r/180622_0031.wav?dl=0

(instead of RX & TX of the Arduino I used pin 10 & 11, because I could not upload the code with RX and TX connected - any solution for that? that's why I also didn't use )

what I tried:
1) connecting the amplifier or DFPlayer module to another power supply as recommended in many forums - no change
2) being careful about separating the wires of the amplifier from the wires of the DFPlayer - no change
3) using coaxial cable to connect the amplifier or the player to the power pins - the player didn't even work
4) putting the diode 1N4004 between VCC and 5V and 1N4148 between RX and 11
5) the setup as described here: http://markus-wobisch.blogspot.com/2016/09/arduino-sounds-dfplayer.html  - no change, still humming
6) I tried it with different arduinos, amplifiers, DFPlayer modules, cables - no change

Do you have any other idea? that would be amazing !! I really need this because I plan an sound art installation and I'm already behind schedule. 
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Grumpy_Mike on Jun 20, 2018, 10:48 am
Capacitor across the supply pins of the amplifier, about 470uF.
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Solaya on Jun 21, 2018, 12:06 am
Thanks a lot!
I tried that as described here: https://www.easyandworkproject.xyz/2016/07/how-to-add-capacitor-to-amplifier-board.html
and it didn't work. still humming.

But on that website it's also written that the pam8403 would need a capacitor with 1000-2200 uf. could that be right? I have to buy that piece first, but I will try it tomorrow and update then.
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Grumpy_Mike on Jun 21, 2018, 12:26 am
Quote
But on that website it's also written that the pam8403 would need a capacitor with 1000-2200 uf. could that be right?
Yes it could.
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Solaya on Jun 21, 2018, 09:59 pm
dammit. no, it doesn't help. still humming. any other idea? I am quite desperate already
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Grumpy_Mike on Jun 21, 2018, 10:36 pm
Quote
listen here: https://www.dropbox.com/s/prym2896btk0f1r/180622_0031.wav?dl=0
What makes you think this noise is a hum? A hum is a 50 to 120 HZ sound derived from the mains.
It sounds more like EM interference from other parts of the system. Is the clicking synchronised with anything like flashing LEDs or commands to the player?

Things you can try:-
1) Star wiring on the power rails. That is the power and ground connected only at one point not chained.
2) Reduce the impedance of the audio inputs, by putting a resistor to ground on each input.
3) Add some more aggressive decoupling like a Pi filter shown on the last circuit of this link.
http://www.thebox.myzen.co.uk/Tutorial/De-coupling.html (http://www.thebox.myzen.co.uk/Tutorial/De-coupling.html)

However, mixing digital circuits and analogue ones is not easy, it is not like building Lego blocks. A lot depends on physical layout. Can you post some actual photographs of your system. 

 
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Solaya on Jun 22, 2018, 09:05 am
here is a photo of my circuit, can u see it well enough?

about your hints, I will try that after work. which resistors would you recommend then? 1k?


and thanks a lot for staying with me!!
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: Grumpy_Mike on Jun 22, 2018, 10:01 am
Quote
which resistors would you recommend then? 1k?
It is a compromise, the lower the resistance the lower the picked up noise but also the lower the volume. You are after the best signal to noise ratio.

As expected the wiring is a mess. Get rid of the Solderless bread board and replace it with strip board and tidy the wiring. The wires should be as short as possible and signal wires should be routined away from the digital wires.
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: patduino on Jun 28, 2018, 05:27 pm
I'd start by trying it out with a regular 4ohm speaker and see if you still have that hum to help troubleshoot your problem.

The DFPlayer has a pair of speaker outputs.  It looks like you may have tried to connect to them on the board (blue/green wires), but they aren't aligned with the wires that go off camera on the protoboard.

Pat.
Title: Re: humming noise – DFPlayer + Amplifier Pam8403
Post by: miguelssm on Jan 22, 2019, 12:06 am
Hi everyone,
I hope you can help me with the problem of a humming noise when I connect an
Arduino Uno + DFPlayer mini + the amplifier Pam8403.
I tried already many things that I found in this and other forums. I would really appreciate your help!!

my assembly:
circuit 1 + code (http://www.electronics-lab.com/project/mp3-player-using-arduino-dfplayer-mini/): everything worked
circuit 2 (see attachment or http://www.belajarduino.com/2016/10/arduinop.html): humming noise appears on the speakers connected to the amplifier

listen here: https://www.dropbox.com/s/prym2896btk0f1r/180622_0031.wav?dl=0

(instead of RX & TX of the Arduino I used pin 10 & 11, because I could not upload the code with RX and TX connected - any solution for that? that's why I also didn't use )

what I tried:
1) connecting the amplifier or DFPlayer module to another power supply as recommended in many forums - no change
2) being careful about separating the wires of the amplifier from the wires of the DFPlayer - no change
3) using coaxial cable to connect the amplifier or the player to the power pins - the player didn't even work
4) putting the diode 1N4004 between VCC and 5V and 1N4148 between RX and 11
5) the setup as described here: http://markus-wobisch.blogspot.com/2016/09/arduino-sounds-dfplayer.html  - no change, still humming
6) I tried it with different arduinos, amplifiers, DFPlayer modules, cables - no change

Do you have any other idea? that would be amazing !! I really need this because I plan an sound art installation and I'm already behind schedule. 

Have you tried to put two 1kohm resistors between Arduino's TX/RX and DFPlayer RX/TX pins? This has worked for me.
Good luck!!

Miguel SSM
Spain