Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: forkliftcat on Jul 29, 2018, 01:25 pm

Title: Tools don't show up in arduino IDE 1.8.5 [SOLVED]
Post by: forkliftcat on Jul 29, 2018, 01:25 pm
Dear arduino wiese ones,

I tried to install the EspEsceptionDecoder https://github.com/me-no-dev/EspExceptionDecoder as a tool but whatever I do, it doesn't show up in the tool menu of the arduino IDE 1.8.5

System: Windows 10
Arduino IDE version: 1.8.5

What I tried:

Unpacking to:
C:\Users\#Username#\Documents\Arduino\tools\ (this is my sketsch folder)
Full path looking like:
C:\Users\#Username#\Documents\Arduino\tools\EspExceptionDecoder\src

I also tried to rename "src" to "tool"


I also unpacked it to
C:\Program Files (x86)\Arduino\tools

(the WiFi101 tool is there and it's the only tol that shows correctly on the menu)


I tried several other tools in case it's an issue of the EspExceptionDecoder, but it doesn't seem to be. Whatever tool I try to install, it doesn't show...

Any ideas?



Title: Re: Tools don't show up in arduino IDE 1.8.5
Post by: spycatcher2k on Jul 29, 2018, 01:33 pm
Read and follow the instructions on the git page - it works for me!
Title: Re: Tools don't show up in arduino IDE 1.8.5
Post by: spycatcher2k on Jul 29, 2018, 01:34 pm
Quote
Make sure you use one of the supported versions of Arduino IDE and have ESP8266/ESP32 core installed.
    Download the tool archive from releases page.
    In your Arduino sketchbook directory, create tools directory if it doesn't exist yet.
    Unpack the tool into tools directory (the path will look like <home_dir>/Arduino/tools/EspExceptionDecoder/tool/EspExceptionDecoder.jar).
    Restart Arduino IDE.
Title: Re: Tools don't show up in arduino IDE 1.8.5
Post by: forkliftcat on Jul 29, 2018, 01:38 pm
Thank you for the fast reply. I think I did all that. I also restarted the IDE and also my complete system several times.
So you can confirm it works with IDE 1.8.5?
Do you see where I overlooked/not followed the instructions? 
Title: Re: Tools don't show up in arduino IDE 1.8.5
Post by: forkliftcat on Jul 29, 2018, 02:02 pm
The only trouble I see is that the instruction talks about getting a .jar file out of the extraction:

<home_dir>/Arduino/tools/EspExceptionDecoder/tool/EspExceptionDecoder.jar

But when I extract it I get a .java

<home_dir>/Arduino/tools/EspExceptionDecoder/src/EspExceptionDecoder.java

I'm willing to learn where I go wrong and I sure wouldn't ask if the solution was obvious to me.
Title: Re: Tools don't show up in arduino IDE 1.8.5
Post by: spycatcher2k on Jul 29, 2018, 03:03 pm
Quote
Download the tool archive from releases page.
Did you follow this instruction?

It gives you the file you need!
Title: Re: Tools don't show up in arduino IDE 1.8.5
Post by: forkliftcat on Jul 29, 2018, 03:12 pm
*Epic facepalm*
Thank you so much, that solved it! Clear case of problem was between computer and chair.
Title: Re: Tools don't show up in arduino IDE 1.8.5 [SOLVED]
Post by: spycatcher2k on Jul 29, 2018, 03:27 pm
Glad you got it working :)
Title: Re: Tools don't show up in arduino IDE 1.8.5 [SOLVED]
Post by: Vitalicus on Apr 25, 2019, 02:22 am
where to download jar ?