Arduino Forum

International => Nederlands => Topic started by: henk77 on Oct 09, 2018, 01:54 pm

Title: project 1 - wat doe ik mis?
Post by: henk77 on Oct 09, 2018, 01:54 pm
Hey

Ik ben totaal nieuw in Arduino en ben ook nog maar net gestart.  Bij mijn eerste project heb ik al een probleem dat ik maar niet kan oplossen.

De code hieronder zou een led afwisselend 4 sec. moeten laten oplichten.  led 1 - 4 seconden aan, dan 4 seconden uit - dan Led 2 4sec aan - led 2 4sec. uit en dat uiteraard in een loop. (zie code)

Dit is mijn resultaat:
Led1  4sec. aan - led2 4sec. aan (beide leds branden) - Led1 4sec. uit Led 2 blijft 4sec.aan - en zo verder.
Volgens mijn interpretatie zouden de 2 LED's nooit tegelijkertijd mogen oplichten?  Klopt dit?

(hopelijk beschrijf ik het hier goed!)

Kortom wat is er mis, of interpreteer ik mijn project niet goed?

Alvast bedankt
 
 void setup() {
//initialiseren van D10 en D11 als uitgangen;
  pinMode(10, OUTPUT);
  pinMode(11, OUTPUT);
 
 }
// de loop wordt continu herhaald.
void loop() {
  digitalWrite(10, HIGH);  //zet de led op pin 10 aan
  delay(4000);              //wacht 4 seconde
  digitalWrite(10, LOW);     //zet de led op pin 10 uit
  delay(4000);              //wacht 4 seconde
  digitalWrite(11,HIGH);    //zet de led op pin 11 aan
  delay(4000);              //wacht 4 seconde
  digitalWrite(11, LOW);     //zet de led op pin 11 uit
  delay(4000);              //wacht 4 seconde

}


Title: Re: project 1 - wat doe ik mis?
Post by: nicoverduin on Oct 09, 2018, 02:32 pm
Zit de min aansluiting wel op gnd?
Title: Re: project 1 - wat doe ik mis?
Post by: MAS3 on Oct 10, 2018, 01:48 am


Indien niet, krijg je een geinig effect.
Maar daarvoor moet je wel ook de LEDs andersom plaatsen (anders brandt er helemaal niets).

Aan jouw bovenstaande foto, kun je zien dat het eigenlijk helemaal niet zo gemakkelijk is een duidelijke foto te  maken.
Want Nico's vraag is aan de hand van die foto erg lastig te beantwoorden.
De draden zitten daar in de weg, en de bijschriften op de print zijn niet zichtbaar.
En ik kan aan die LEDs niet zien of ze linksom of rechtsom zijn aangesloten.

Dus, voer de controle die Nico voorstelt maar eens uit.
Title: Re: project 1 - wat doe ik mis?
Post by: nicoverduin on Oct 10, 2018, 09:11 am
Hij heeft zo te zien de MIN aan de 5V hangen. E dat gaat niet werken. Dus de LEDs zullen ook wel verkeerd om erin geprikt zijn. Als een pin LOW gaat aanloopt er omgekeerd een stroom door de LEDs. Waarom die andere continu blijft branden is mij nog niet duidelijk. Maar mogelijk heeft de TS eerst nog wat zitten prutsen hiervoor en daarmee een poort de vernieling in geholpen.
Laat hem eerst maar eens alles aansluiten hoe het moet. Dan kijken we verder.