Arduino Forum

Using Arduino => Networking, Protocols, and Devices => Topic started by: Java_SE_Binary on Jan 16, 2019, 02:09 am

Title: Arduino Zero ESP8266 AT Command troubles
Post by: Java_SE_Binary on Jan 16, 2019, 02:09 am
I've just gotten my ESP8266 all set up with my Arduino Zero, all the wires hooked up and whatnot, and according to what I've read in tutorials around the web is that I should be able to just enter AT commands into the Serial Monitor and have them ported to the ESP8266 module, with no code loaded on the Arduino. My serial monitor is set to 115200 for the baud rate, and Both NL and CR is set as well. My issue is, this isn't happening. I've tried switching the RX and TX lines back and forth, to no avail. I'm unsure what might be going on. The status LED does not flash at all, and there is no response in the Serial Monitor.
Title: Re: Arduino Zero ESP8266 AT Command troubles
Post by: pert on Jan 16, 2019, 04:14 am
That information is only correct for boards without native USB, such as Uno, Nano, Mega. The Zero has native USB so that won't work.

You need to run a sketch on the Zero that will bridge communication between Serial (the communication with Serial Monitor via the USB cable) and Serial1 (the communication with the ESP8266. You will find such a sketch at File > Examples > 04.Communication > SerialPassthrough. You only need to change the baudrate settings in that sketch to 115200 instead of 9600:
Code: [Select]
  Serial.begin(115200);
  Serial1.begin(115200);


You need to connect the Zero's pin 0 (RX) to the TX pin on the ESP8266. You need to connect the Zero's pin 1 (TX) to the RX pin on the ESP8266. The reason for the RX-TX, TX-RX connections is that TX stands for "transmit" and RX stands for "receive".
Title: Re: Arduino Zero ESP8266 AT Command troubles
Post by: Java_SE_Binary on Jan 16, 2019, 05:42 am
That was exactly what I was looking for, thank you.

Got it all set up and it works like a charm!
Title: Re: Arduino Zero ESP8266 AT Command troubles
Post by: pert on Jan 16, 2019, 08:46 am
You're welcome. I'm glad to hear it's working now. Enjoy!
Per