Arduino Forum

Using Arduino => Audio => Topic started by: RDF_MIDI on Mar 22, 2019, 03:40 pm

Title: MIDI output/power issue
Post by: RDF_MIDI on Mar 22, 2019, 03:40 pm
I recently built a MIDI controller, which is sorta like a keyboard played with your feet, using an Arduino Uno.

When I power the Uno through USB (like when I'm sending the sketch to it) from my computer, everything works exactly as it should. All of the note and function keys put out the correct values to the MIDI jack when read in MIDI-OX.

When I try to power it *ANY* other way, all I get is a constant stream of random data at the MIDI jack.

I've tried everything from 5V to 12V switching power supplies going into the Uno's power connector. I've even tried a MB102 breadboard power supply going into the USB connector on the Uno. Always the same result - a constant stream of gibberish.

Any recommendations?
Title: Re: MIDI output/power issue
Post by: Grumpy_Mike on Mar 22, 2019, 05:45 pm
Quote
When I try to power it *ANY* other way, all I get is a constant stream of random data at the MIDI jack.
This means either your power supply is wrong or you are not wiring it correctly. But as you have not supplied any detail of what you have done it is hard to say what you have done wrong.
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 22, 2019, 06:42 pm
I'm at work right now, but I can post schematics later today.
Title: Re: MIDI output/power issue
Post by: Grumpy_Mike on Mar 22, 2019, 09:46 pm
OK in your own time.
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 22, 2019, 11:26 pm
Here are the schematics. Do you need the sketch as well?
Title: Re: MIDI output/power issue
Post by: MarkT on Mar 22, 2019, 11:37 pm
Ironically the only part of the circuit not in the schematic is the midi output jack, just some
written descriptions - although it sounds plausible, only pins 5 and 4 are mentioned, 2 (GND)
is not mentioned.

Best to draw the midi output circuit to be absolutely certain.

It strikes me you don't have an isolated MIDI input circuit on the machine running MIDI-OX?
If that's so and there is no ground connection, that would explain it.

MIDI requires an opto-isolated input circuit to be reliable as designed, using a com port and some windows
utility is not proper MIDI.
Title: Re: MIDI output/power issue
Post by: Grumpy_Mike on Mar 23, 2019, 08:08 am
Quote
It strikes me you don't have an isolated MIDI input circuit on the machine running MIDI-OX?
If that's so and there is no ground connection, that would explain it.
Yes I quite agree with that conclusion.

By using the computer's power through the USB port you automatically get a ground connection.
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 23, 2019, 02:43 pm
Yes, the MIDI is shown as grounded. On the power pins for the Uno, the one labeled as pin 7.

But here it is drawn out.

Yes, I'm using an isolated MIDI adapter going to my computer's USB port.
Title: Re: MIDI output/power issue
Post by: Grumpy_Mike on Mar 23, 2019, 06:12 pm
Can you please read reply #1 again.
You are not showing us what you have done to power the system when it goes wrong. Schematic and photograph of an unsuccessful attempt at powering would help.

There is no need to connect ground to your MIDI connector.

Is it correct you connect pin 2 to the MIDI output?
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 23, 2019, 07:44 pm
In this image, power comes from my computer via USB to the onboard USB port on the Uno.

MIDI data goes out pin 2, through a 220 ohm resistor, to pin 5 of the MIDI jack, through a USB/MIDI adapter, and into my computer, which is running MIDI-OX.

In this configuration, all MIDI data is read correctly.
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 23, 2019, 07:56 pm
In this image, power comes from a 9VDC switching power supply to the power jack on the Uno. There is nothing plugged into the USB port on the Uno.

MIDI data follows the same path. It goes out pin 2, through a 220 ohm resistor, to pin 5 of the MIDI jack, through a USB/MIDI adapter, and into my computer, which is running MIDI-OX.

In this configuration, there is a steady stream of random MIDI data going out of the MIDI jack.

I've tried using a 5VDC and a 12VDC adapter with the same result.
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 23, 2019, 08:04 pm
In this image, power comes from a 9VDC switching power supply, to a breadboard power supply with a built-in 5V regulator, through a USB cable to the USB connector on the Uno.

MIDI data follows the same path. It goes out pin 2, through a 220 ohm resistor, to pin 5 of the MIDI jack, through a USB/MIDI adapter, and into my computer, which is running MIDI-OX.

In this configuration, there is a steady stream of random MIDI data going out of the MIDI jack.
Title: Re: MIDI output/power issue
Post by: RDF_MIDI on Mar 26, 2019, 04:30 pm
Suggestions? Recommendations? Ideas?