Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: camilozk on Apr 08, 2019, 08:40 pm

Title: error on chinese clone (wavgat)
Post by: camilozk on Apr 08, 2019, 08:40 pm
Hi!

I get the following error when trying to program a chinese board:

--
--
--
Warning: platform.txt from core 'Arduino AVR Boards' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.
In file included from C:\Users\leo\Documents\Arduino\libraries\Conceptinetics\Conceptinetics.cpp:28:0:

C:\Program Files (x86)\Arduino\hardware\WAV\avr\variants\lgt8fx8p/pins_arduino.h:34:14: error: 'uint8_t' does not name a type

 static const uint8_t DAC0 = 4;

              ^

exit status 1
Error compiling for board WAVGAT UNO R3.
--
--
--
The board is a wavgat arduino uno

The code follows:

Code: [Select]
#include <Conceptinetics.h>

#define DMX_MASTER_CHANNELS   1

#define RXEN_PIN              2

DMX_Master  dmx_master  (DMX_MASTER_CHANNELS, RXEN_PIN);

int fogValue = 0;

void setup() {             
  dmx_master.enable (); 
  dmx_master.setChannelRange (1,25,127);
}


void loop() {
  int pote = analogRead(A0);

  fogValue = map(pote, 0, 1023, 0, 255);
 
  dmx_master.setChannelValue (1, fogValue); 
 
}


I dont really understand what does this mean. any help?

thanks!
Title: Re: error on chinese clone (wavgat)
Post by: DrAzzy on Apr 08, 2019, 09:11 pm
The WAVGAT "clones" use a different processor (an almost-clone of the '328p by some chinese semiconductor company) and need a special core from wavgat, and even with it there are problems.

Avoid that brand like the plague.
Title: Re: error on chinese clone (wavgat)
Post by: camilozk on Apr 09, 2019, 11:11 am
Thank you for the information. I will in the future. For now, I would really appreciate a solution!
Title: Re: error on chinese clone (wavgat)
Post by: camilozk on Apr 09, 2019, 03:59 pm
Problem was sorted out by replacing uint8_t with char