Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: Corgi12345 on Apr 28, 2019, 04:53 pm

Title: Can't upload the program to Arduino UNO
Post by: Corgi12345 on Apr 28, 2019, 04:53 pm
I'm currently doing my homework about line tracking car. However I got a problem when I uploaded the program to it. I'm having 2 UNO and one is finished uploading while the other can't. It has the same program and the message from IDE is "Problem uploading to board". Can someone explain and show me how to fix it?
Title: Re: Can't upload the program to Arduino UNO
Post by: Corgi12345 on Apr 29, 2019, 03:31 am
Never mind. I found the way to solve it. Thanks for reading this
Title: Re: Can't upload the program to Arduino UNO
Post by: jpom on Apr 29, 2019, 11:07 am
Please tell us the solution.
Title: Re: Can't upload the program to Arduino UNO
Post by: Corgi12345 on Apr 30, 2019, 03:55 pm
Nothing is serious. Just my mistake when i forgot to check the port before uploading the program
Title: Re: Can't upload the program to Arduino UNO
Post by: pert on Apr 30, 2019, 05:27 pm
Thanks for taking the time to share the solution Corgi12345. That may well help someone else who has the same problem and finds this thread while searching for information.
Title: Re: Can't upload the program to Arduino UNO
Post by: mbromham on May 01, 2019, 02:24 pm
When I try to upload I get a Can't Open Device: Access Denied error. If I look under Tools:Port I see multiple instances of the Uno (see attached). I've tried Remove Device from Devices and Printers, uninstall from Device Manager and everything else I can think of. Only thing that seems to work is a reboot which is a major pain as I have other things running (PVR) that I don't want to interrupt. Issue was on COM10, now has switched to COM6.
Title: Re: Can't upload the program to Arduino UNO
Post by: mbromham on May 01, 2019, 02:35 pm
Sorry, previous image doesn't show device. Seems I get a new instance every time I plug/unplug the device. See attached. Win10-64, Bitdefender AV, Arduino 1-8-9.
Title: Re: Can't upload the program to Arduino UNO
Post by: Corgi12345 on May 01, 2019, 02:40 pm
How about try to close your IDE and then turn it on again. I haven't met that problem before
 
Title: Re: Can't upload the program to Arduino UNO
Post by: mbromham on May 01, 2019, 02:51 pm
Tried that, tried restarting with board attached, without board attached, run then attach, run detach/re-attach, etc. Just get more instances, see attached, they're breeding like rabbits!
Title: Re: Can't upload the program to Arduino UNO
Post by: mbromham on May 01, 2019, 03:05 pm
New instance every time I unplug/plug. See image, getting to be a joke :-) If I close IDE and restart they're all still there.
Title: Re: Can't upload the program to Arduino UNO
Post by: ballscrewbob on May 02, 2019, 04:03 am
@mbromham

There can be a few causes for that type of behaviour.

As a test only clear all your temporary files and caches (I use CCLEANER)
Restart your computer and ensure your AV is OFF completely !

Plug the board into a USB 2.0 port and check which port if gives out.
Start the IDE and upload a simple sketch.
Unplug the board from the computer and check the com port went away.
Plug the board back in and see if it changed again.
If it did then you ruled out your AV as a cause.

You should then start to check and see if any other software is causing the issue as some alternate IDE's and similar can also cause such issues.
You can use the same steps as above but ensure you turn off/disable the software you think may be a problem  via task manager or similar.

If it continues you may also need to reset the COM stack.
if you are using windows then this link provides a few methods of doing that. (https://www.google.com/search?q=reset+unused+com+ports&rlz=1C1NHXL_enCA761CA762&oq=reset+unused+com&aqs=chrome.1.69i57j0.6305j0j8&sourceid=chrome&ie=UTF-8).



 
Title: Re: Can't upload the program to Arduino UNO
Post by: pert on May 02, 2019, 11:02 am
I have this problem regularly with my MKR boards, never my Uno and other AVR boards yet. It has something to do with trying to upload with the Serial Monitor open (which should be fine). I've found that I can fix it by exiting all Arduino IDE windows, unplugging the board, then starting the Arduino IDE again. I don't know if the same will fix your issue with the Uno.
Title: Re: Can't upload the program to Arduino UNO
Post by: pert on May 04, 2019, 09:36 am
When I try to upload I get a Can't Open Device: Access Denied error. If I look under Tools:Port I see multiple instances of the Uno (see attached). I've tried Remove Device from Devices and Printers, uninstall from Device Manager and everything else I can think of. Only thing that seems to work is a reboot which is a major pain as I have other things running (PVR) that I don't want to interrupt. Issue was on COM10, now has switched to COM6.
Here we have a dedicated thread for the duplicate ports issue:
https://forum.arduino.cc/index.php?topic=613070 (https://forum.arduino.cc/index.php?topic=613070)
let's centralize discussion of the issue to that thread. You might want to open the link above and click the "Receive Emails" button in order to get notifications of any progress we make on investigating and fixing this issue.