Arduino Forum

International => Deutsch => Topic started by: EGS on May 21, 2019, 09:57 pm

Title: Problem Serieller Monitor/Plotter
Post by: EGS on May 21, 2019, 09:57 pm
Hallo liebe Gemeinde,
nachdem ich heute ein Update für die IDE installiert habe, wirft sie mir folgende Fehlermeldung, wenn ich den Seriellen Monitor oder Plotter öffne:

Exception in thread "EventThread /dev/ttyUSB0" java.lang.NoSuchMethodError: java.nio.ByteBuffer.flip()Ljava/nio/ByteBuffer;
   at processing.app.Serial.serialEvent(Serial.java:185)
   at jssc.SerialPort$LinuxEventThread.run(SerialPort.java:1299)

Uploads usw scheinen zu funktionieren.

System: Archlinux, Arduino v1.8.9-3

Habe die IDE auch schon neu installiert, Daten zusätzlich gelöscht -> selbes Ergebnis. Downgrade kann ich leider nicht mehr machen, weil das alte Paket nicht mehr da ist...

Danke im Voraus
Title: Re: Problem Serieller Monitor/Plotter
Post by: gregorss on May 22, 2019, 12:30 am
Danke im Voraus
Wofür? Du stellst ja nicht einmal eine Frage.

Statt des seriellen Monitors in der IDE kannst Du auch ein stinknormales Terminalprogramm benutzen. Ich verwende z. B. immer wieder minicom. Vorteil ist, dass minicom im Gegensatz zum seriellen Monitor der Arduino-IDE auch ANSI-Steuersequenzen versteht.

Gruß

Gregor

PS: Siehe hier (http://html.szaktilla.de/weekender/8.html) ganz oben.
Title: Re: Problem Serieller Monitor/Plotter
Post by: MicroBahner on May 22, 2019, 10:08 am
Downgrade kann ich leider nicht mehr machen, weil das alte Paket nicht mehr da ist...
Die alten Versionen (https://www.arduino.cc/en/Main/OldSoftwareReleases#previous) kannst Du doch auch noch herunterladen.
Title: Re: Problem Serieller Monitor/Plotter
Post by: EGS on May 22, 2019, 11:11 am
Die alte Version gibts aber nur am Paketmanager vorbei