Arduino Forum

Using Arduino => LEDs and Multiplexing => Topic started by: Saryk on May 27, 2019, 09:39 pm

Title: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Saryk on May 27, 2019, 09:39 pm
Good day all,

I have a NeoPixel RGBW 30 led strip (2836 model says the packaging), I've followed the tutorial on the website and a youtube tutorial on setting it up but it doesn't turn on after uploading the code.

I'm using the strandtest from the Adafruit Neopixel library, and I've connected the circuits like this :

(https://i.imgur.com/Lr5fjsR.jpg)
Arduino board is Genuino MKR1000, from there black wire is ground and red is digital pin 2.
Pin is set to 2 in code, and led count to 5 for testing purposes.
The battery is a 9V battery.
I also added a 1kOHM resistor on the way of the red wire going from board to data input on the strip.
The battery's - and the board's ground are connected via the strip.

I'm probably missing something, can any one of you give me a hand ? Should I do something with the other end of the strip ?

Thanks :)
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Paul__B on May 27, 2019, 11:44 pm
The battery is a 9V battery.
What battery?

What are you using as a 5 V power supply to power the 30 LED strip?  Once you have that, you can use it to power the Arduino as well.
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Grumpy_Mike on May 28, 2019, 04:48 am
Quote from:-
https://www.arduino.cc/en/Guide/MKR1000 (https://www.arduino.cc/en/Guide/MKR1000)
Quote
The microcontroller on the MKR1000 runs at 3.3V, which means that you must never apply more than 3.3V to its Digital and Analog pins. Care must be taken when connecting sensors and actuators to assure that this limit of 3.3V is never exceeded. Connecting higher voltage signals, like the 5V commonly used with the other Arduino boards, will damage the MKR1000.
So that means the signal output will also be 3V3 which is not enough to reliably drive a WS2812 powered at 5V.
You need something to boost the signal to 5V, I normally use something like this:-
(https://forum.arduino.cc/index.php?action=dlattach;topic=618329.0;attach=310183)

I do this for using the 3V3 raspberry Pi but it will also work for the MKR1000.

By the way you can find out how to post images here by reading
How to use this forum (http://forum.arduino.cc/index.php/topic,148850.0.html)
And
image guide (http://forum.arduino.cc/index.php?topic=364156.0)
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Paul__B on May 28, 2019, 01:17 pm
You need something to boost the signal to 5V, I normally use something like this:-
(https://forum.arduino.cc/index.php?action=dlattach;topic=618329.0;attach=310183)
Which is a rather odd thing to suggest because the specs of a 74LS14 (http://www.ti.com/lit/ds/symlink/sn54ls14-sp.pdf) give it a typical VOH barely better than the output of the 3.3 V logic device!  Obsolete TTL or LSTTL logic does not "boost the signal to 5V" at all!  :smiley-eek:

The correct level converter is a 74HCT14.
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Grumpy_Mike on May 28, 2019, 02:18 pm
Quote
Which is a rather odd thing to suggest because the specs of a 74LS14 give it a typical VOH barely better than the output of the 3.3 V logic device!
Rubbish, of course it boost the signal, what makes you say that?
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Saryk on May 28, 2019, 02:26 pm
What battery?

What are you using as a 5 V power supply to power the 30 LED strip?  Once you have that, you can use it to power the Arduino as well.
The battery is on the picture, on the right. I use it to directly power the LED strip. Arduino is plugged in via micro USB to my computer for now.


By the way you can find out how to post images here by reading
How to use this forum (http://forum.arduino.cc/index.php/topic,148850.0.html)
And
image guide (http://forum.arduino.cc/index.php?topic=364156.0)
I did use the auto img tags and provided the link to the image, but it didn't show so I edited to add the link directly.
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Grumpy_Mike on May 28, 2019, 08:25 pm
Quote
I did use the auto img tags and provided the link to the image, but it didn't show
It didn't show because you put the wrong url in the link. Photo hosting web sites say the image is at a certain url but they lie, what these are is the url to the page that contains the image, not the url of the image itself. That is why you need to post your image as an attachment. Then copy the link to that attachment and paste it in the picture icon when you modify your post.
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Paul__B on May 29, 2019, 12:53 am
I did use the auto img tags and provided the link to the image, but it didn't show so I edited to add the link directly.
That part you got correct - it is neither necessary nor particularly appropriate to use the "attachment" function in the forum here.  What is important is that you find the link to the image and not the Web page containing the image.

The battery is on the picture, on the right. I use it to directly power the LED strip. Arduino is plugged in via micro USB to my computer for now.
Before your image was visible today in the thread itself I would have overlooked it.  This now looks very bad indeed!

What voltage is specified for that strip?  You need to give the actual Web link to its details.  If it is supposed to operate at 5 V, then 9 V will destroy all or part of it.  On the other hand, a "PP3" battery as illustrated is not capable of powering a LED strip anyway, so taken together it is difficult to figure what has happened.

Rubbish, of course it boost the signal, what makes you say that?
I read the datasheet (http://www.ti.com/lit/ds/symlink/sn54ls14-sp.pdf).  :smiley-eek:
Title: Re: NeoPixel RGBW 30 led strip : need help setting it up
Post by: Grumpy_Mike on May 29, 2019, 04:48 am
Quote
I read the datasheet.
So do I and those conditions are not what I run the chip at:-
Quote
VCC = MIN, VI = 0.5 V, IOH = -0.4 mA, SNx4LS14