Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: rallytec on Nov 19, 2019, 10:59 pm

Title: Compiling problem
Post by: rallytec on Nov 19, 2019, 10:59 pm
Hi after updating to 1.8.10 version I cannot compile anything and get these error messages:

Arduino: 1.8.10 (Windows XP), Board: "Arduino/Genuino Uno"

panic: Failed to find GetFileInformationByHandleEx procedure in kernel32.dll: The specified procedure could not be found.

goroutine 1 [running]:
syscall.(*LazyProc).mustFind(0x11c419e0)
   /home/jenkins/go1.12.5/src/syscall/dll_windows.go:311 +0x42
syscall.(*LazyProc).Addr(0x11c419e0, 0xdda500)
   /home/jenkins/go1.12.5/src/syscall/dll_windows.go:318 +0x21
internal/syscall/windows.GetFileInformationByHandleEx(0x780, 0x9, 0x11c71a04, 0x8, 0x3, 0x11c1f348)
   /home/jenkins/go1.12.5/src/internal/syscall/windows/zsyscall_windows.go:353 +0x27
os.newFileStatFromGetFileInformationByHandle(0x11c3d580, 0x3c, 0x780, 0x0, 0x11c3d580, 0x3c)
   /home/jenkins/go1.12.5/src/os/types_windows.go:52 +0x135
os.(*File).Stat(0x11c3eed8, 0x984490, 0x11c3eed8, 0x0, 0x11c3eed8)
   /home/jenkins/go1.12.5/src/os/stat_windows.go:55 +0x133
io/ioutil.ReadFile(0x11c3d580, 0x3c, 0x0, 0x0, 0x0, 0x0, 0x0)
   /home/jenkins/go1.12.5/src/io/ioutil/ioutil.go:62 +0xac
github.com/arduino/go-paths-helper.(*Path).ReadFile(...)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/go-paths-helper/paths.go:407
github.com/arduino/arduino-cli/arduino/cores/packageindex.LoadIndex(0x11c3eed0, 0xa29e60, 0x11c4de00, 0x0)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/arduino/cores/packageindex/index.go:205 +0x2f
github.com/arduino/arduino-cli/arduino/cores/packagemanager.(*PackageManager).LoadPackageIndexFromFile(0x11cf8c40, 0x11c3eed0, 0x0, 0x0, 0x11c3eed0)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/arduino/cores/packagemanager/package_manager.go:202 +0x25
github.com/arduino/arduino-cli/arduino/cores/packagemanager.(*PackageManager).loadPlatforms(0x11cf8c40, 0x11c835f0, 0x11c3ee10, 0x7, 0x11c48ac8)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/arduino/cores/packagemanager/loader.go:186 +0xf4d
github.com/arduino/arduino-cli/arduino/cores/packagemanager.(*PackageManager).LoadHardwareFromDirectory(0x11cf8c40, 0x11c3ebf8, 0xdda500, 0x703815)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/arduino/cores/packagemanager/loader.go:116 +0x43f
github.com/arduino/arduino-cli/arduino/cores/packagemanager.(*PackageManager).LoadHardwareFromDirectories(0x11cf8c40, 0x11c46a70, 0x3, 0x4, 0x1, 0x1)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/arduino/cores/packagemanager/loader.go:52 +0x4f
github.com/arduino/arduino-cli/legacy/builder.(*HardwareLoader).Run(0xdebc68, 0x11cd65a0, 0xdebc68, 0x0)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/hardware_loader.go:43 +0xe4
github.com/arduino/arduino-cli/legacy/builder.(*ContainerSetupHardwareToolsLibsSketchAndProps).Run(0xdebc68, 0x11cd65a0, 0xdebc68, 0xdda500)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/container_setup.go:60 +0x266
github.com/arduino/arduino-cli/legacy/builder.runCommands(0x11cd65a0, 0x11c71f0c, 0x2, 0x2, 0xffffff01, 0x0, 0x4)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/builder.go:210 +0xbd
github.com/arduino/arduino-cli/legacy/builder.(*ParseHardwareAndDumpBuildProperties).Run(0x11c71f40, 0x11cd65a0, 0xdebbb4, 0x11c3ec90)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/builder.go:198 +0xbc
github.com/arduino/arduino-cli/legacy/builder.RunParseHardwareAndDumpBuildProperties(...)
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-cli/legacy/builder/builder.go:231
main.main()
   /home/jenkins/workspace/arduino-builder-all-cross-cli-inception/src/github.com/arduino/arduino-builder/main.go:388 +0x772
C:\Program Files\Arduino\arduino-builder returned 2

Error compiling for board Arduino/Genuino Uno.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

Tried to return to older 1.8.09 version but problem remains.
Any help idea ??? Thanks in advance

Makis Iosifidis
Title: Re: Compiling problem
Post by: ballscrewbob on Nov 19, 2019, 11:23 pm
Please roll back to 1.8.9 as there are some issues with 1.8.10 and XP.

Additional clean up instructions attached

Bob.

Title: Re: Compiling problem
Post by: rallytec on Nov 20, 2019, 12:21 am
Problem solved after unistalling 1.8.10 version and manually cleaned all Registry Keys  and values regarding Arduino and installing 1.8.9 version again
 Thank you very much  dear Ballsqrewbob fr fast responce


Makis
Title: Re: Compiling problem
Post by: ballscrewbob on Nov 20, 2019, 02:48 am
Glad you are running again.

Bob.

Title: Re: Compiling problem
Post by: rallytec on Nov 20, 2019, 06:58 pm
 Thank you Ballscrewbob ;D  ;D  ;D