Arduino Forum

Using Arduino => Motors, Mechanics, Power and CNC => Topic started by: yoshinoi on Sep 12, 2020, 10:17 am

Title: DC motor not spinning
Post by: yoshinoi on Sep 12, 2020, 10:17 am
Hello all,

I am making a self-parking car. There are two motors in the hardware. However, the left motor didn't spin when the right motor was spinning (they were supposed to work together). I tested the DC motors separately and they worked well. I don't know where do they conflict with the other part of code in this program.

There may have some problems in connection, but the signs of the speed of two motors are opposite when they are moving in the same direction.

Thanks.
Title: Re: DC motor not spinning
Post by: groundFungus on Sep 12, 2020, 10:35 am
More members will see your code if you post your code as described in the forum guidelines.
Title: Re: DC motor not spinning
Post by: jremington on Sep 12, 2020, 10:06 pm
Please read and follow the directions in the "How to use the forum" post.
Title: Re: DC motor not spinning
Post by: TomGeorge on Sep 16, 2020, 01:42 pm
Hi,
Welcome to the forum.

Please read the post at the start of any forum , entitled "How to use this Forum".
OR
http://forum.arduino.cc/index.php/topic,148850.0.html (http://forum.arduino.cc/index.php/topic,148850.0.html).
Then look down to item #7 about how to post your code.
It will be formatted in a scrolling window that makes it easier to read.

Can you please post a copy of your circuit, in CAD or a picture of a hand drawn circuit in jpg, png?

Have you written some simple code that just makes the motors run?

Thanks.. Tom... :)