Arduino Forum

International => Español => Hardware => Topic started by: Metaconta on Jun 16, 2015, 02:07 pm

Title: Controlando motor universal con triac
Post by: Metaconta on Jun 16, 2015, 02:07 pm
Hola:

(http://2.bp.blogspot.com/-nP4KkYwFFIA/VX7Z5Rj7I_I/AAAAAAAAA1Q/tzYnnvHq5zE/s1600/P1390926.JPG)

Hice un circuito con triac que controlo la velocidad del motor con un potenciómetro. El motor se comporta en el arranque al empezar lento y coge velocidad hasta la máxima que le indiques. En la lavadora no se nota el arranque lento, sino a una velocidad constante todo el rato gracias al tacómetro.

Pongo un vídeo de ejemplo que subí estos días.
https://www.youtube.com/watch?v=FGuZcHj6kHU (https://www.youtube.com/watch?v=FGuZcHj6kHU)

Coloqué el motor en la lavadora y decidí probarlo con mucha ropa pero sin agua.
(http://www.subeimagenes.com/img/beko-1351270.jpg)

He probado el motor con ropa de mi lavadora Beko, tiene ropa en su interior, mucha, si nagua. El motor como que le cuesta arrancar si lo dejo en baja potencia, si le pongo un poco más de vlocidad, empeiza lento, acaba aumentando de velocidad poco a poco y con fuerza. Está claro que de esa manera no es una manera adecuada.

Mi lavadora en modo normal, trabaja desde que arranca y se acabe el ciclo a una velocidad constante, por ejemplo, se pega diez minuto haciendo este ciclo, y tiene 3 de 10 minuto cada uno.

Empieza con velocidad normal a lavar durante 15 segundos.
Se detiene durante dos segundos.
Cambia de sentido y lava 15 segundos.
Se detiene 2 seg.
Lava cambiando el sentido de giro otra vez durante 15 seg.
Así en un total de 10 minutos.


Lo que he conseguido y de forma manual, es cuando pasa 15 segundos, como siempre, le cuesta arrancar, va cogiendo velocidad, desconecto el motor de la toma corriente y tarda en pararse unos 6 segundos.

La ropa puede lavar de esa manera, pero no me gusta, está como el motor forzado y no es forma.

He hecho prueba adrede, de arrancar mucho a velocidad rápida, quito el cable cuando pase dos o tres segundos, lo vuelvo a enchufar, así al estilo PWM con mis manos, me he dado cuanta que casi mantengo la velocidad de inicio como la final de los 15 seg, activos, así que...

...a probar el microcontrolador que haga ese tipo de secuencias. Hago notas de como se comporta incluyendo vídeos para estudiarlo mejor y lo programo al estilo PWM. Eso si, no tiene el mismo resultado sin ropa, sin agua que con agua y ropa, la velocidad del motor varía, ya que no uso el tacómetro.

Esto del tacómetro es muy importante. Habrá que averiguar como controlo el tacómetro de pasar señal alterna al microcontrolador, aún así, intentaré controlar el motor dependiento de la ropa que tenga y el peso calculando un promedio, el arranque tiene que ser fuerte, justo antes de que coja inercia y más velocidad, lo pongo a baja pontencia, esto con un microcontrolador se hace de forma rápida, como dije, al estilo PWM.

Les pongo un vídeo a lo que me refiero.
https://www.youtube.com/watch?v=6Q79p7HgAIg (https://www.youtube.com/watch?v=6Q79p7HgAIg)

¿Alguna experiencia o opinión respecto a ello?

Saludos.
Title: Re: Controlando motor universal con triac
Post by: spv on Oct 01, 2019, 03:32 pm
Hola:

¿Conseguiste hacerlo funcionar? Yo estoy con algo parecido, controlando la velocidad con un Arduino. El problema lo tengo con el circuito. Con una bombilla funciona perfectamente la regulación, pero con el motor da bastantes tirones. Coloqué un filtro a la entrada, pero me lo quema.
¿Puedes enseñarme como has hecho el circuito?
Un saludo y gracias.
Title: Re: Controlando motor universal con triac
Post by: tauro0221 on Oct 01, 2019, 07:44 pm
Hi,
El problema es que el motor AC no va arrancar con voltaje bajo tiene que iniciarmente aplicarle el voltaje  normal y despues que arranque controla la velocidad bajandole/controlando el voltaje.  Acuerdate tambien que la velocidad depende de la carga que tiene el motor. Trata de inicialmente aplicarle el voltaje maximo y una vez que arrangue entonces controla la velocidad.
Title: Re: Controlando motor universal con triac
Post by: surbyte on Oct 02, 2019, 01:15 am
No revivan hilos de mas de 120 dias.
Este es del 2015 y al autor no le interesó su seguimiento.

Hilo cerrado.
A los dos lean las normas del foro y no continuen hilos abandonados.