Arduino Forum

Arduino Certified Products => Windows Virtual Shields for Arduino => Topic started by: dctsystems on Jan 02, 2016, 01:56 pm

Title: Anyone got this working?
Post by: dctsystems on Jan 02, 2016, 01:56 pm
I don't use Windows much, but this looked like it might be useful. Has anyone been able to do much with this, as so far its virtually never worked for me.

The Arduino side seems straight forwards. I was able to verify that its sending JSON at 115200 baud over either USB or Bluetooth (I tried both). However when I ran the Virtual Shields app it almost always hung trying to connect (for both USB and BT). It worked about twice over USB but most of the time the app just locks up. Over BT the OS/HW indicates that there's a good connection/pairing but the app locks up.

I used the version of the app downloaded from the Windows Store, as I'm not set up to build the windows app from source, and I figured that the store version  is "official", so should be good.

Anyone got any experience with this? Am I doing something dumb?

thanks

Ian
Title: Re: Anyone got this working?
Post by: wesee on Mar 10, 2016, 07:19 am
it works for me.  i tried over bluetooth.
Title: Re: Anyone got this working?
Post by: SHOLI on Feb 02, 2017, 05:11 pm
what kind of bluetooth module can be used for this purpose?
I mean there cheap ones & costly ones too, the ones mentioned in example are of sparkfun which are quite costly,
can u give some suggestions or info ?
Title: Re: Anyone got this working?
Post by: Raynold453 on Jan 29, 2018, 01:28 pm
Yeah, its working as well.