Arduino Forum

Using Arduino => Microcontrollers => Topic started by: Oyazici on Jan 19, 2018, 02:56 pm

Title: AVRDude usbtiny receieve and send
Post by: Oyazici on Jan 19, 2018, 02:56 pm
Hi Ardumates,

 

I'm using tinyavr programmer ( TinyAvr (https://www.ebay.com/p/5v-Micro-USB-Tiny-AVR-ISP-Attiny44-USBtinyISP-Programmer-for-Arduino-Bootloader/545359301?iid=311566698886) ) for a while but today when i try to upload my code to attiny45 with avrdude i got these messages as you can see at the pictures. I know i can still upload my codes but code timing between chips is really important to me. Is any of you encounter such a problem like this or know how to fix it?

 

Best Regards from Ardumate,

(http://www.avrfreaks.net/sites/default/files/avrdude_error_1.PNG)

(http://www.avrfreaks.net/sites/default/files/avrdude_error_2.PNG)
Title: Re: AVRDude usbtiny receieve and send
Post by: ron_sutherland on Jan 19, 2018, 10:20 pm
My guess is a problem with libusb, I was not able to get avrdude to work with my libusb based ISP tools when I had Atmel Studio installed, and I suspect other USB drivers can cause problems as well. I don't have these problems on Linux, all the ISP tools I have worked fine there. I guess it is just that I can not put Atmel Studio on Linux.

I use the ArduinoISP sketch (that is in examples) for most things now. I load it into an Uno and then use that as the ISP tool. It works when both Atmel Studio and Arduino IDE are installed. At this time I am doing most of my work with the AVR toolchain from Linux, and the Uno with the ArduinoISP sketch is still my goto ISP tool.
Title: Re: AVRDude usbtiny receieve and send
Post by: Oyazici on Jan 22, 2018, 06:52 am
Thank you ron,
Whenever i use libusb at another computer, it worked as it should be and i'm not getting this kinda error all the time.
Title: Re: AVRDude usbtiny receieve and send
Post by: Oyazici on Jan 22, 2018, 03:27 pm
"It's getting worse". Progress increase %1 for every 1.4 sec. It took 2 min to upload code.
Title: Re: AVRDude usbtiny receieve and send
Post by: Oyazici on Jan 23, 2018, 10:18 am
It works perfect now by adding -B1 to avrdude command line