Arduino Forum

International => Deutsch => Topic started by: BullSimons on Jun 15, 2018, 05:34 am

Title: 7" TFT Shield - Jumper settings
Post by: BullSimons on Jun 15, 2018, 05:34 am
Hallo zusammen,

ich wurde letzte Woche gesainsmarted wie man so schön sagt. Auf meinem Adapter shield waren diverse Jumper schon verlötet (immer die Auswahl zwischen 3,3V und 5V). Durch Hektik und weil ich die Rückseite nicht angeschaut hatte nam das Drama seinen Lauf...

Welcher Jumper müssen geschlossen sein?
LCD Vcc
J1 = 5V
J2 = 3,3V

LCD LEDA+ (Beleuchtung)
J3 = 5V
J4 = 3,3V
J5 = PWM

SPI FLASH
J6

SD Card
J9

Signal Input
J7 = 5V
J8 = 3V


Meiner Meinung nach:
J3 oder J5
Beleuchtung 5V oder PWM (ich möchte dimmen - also zumindest später PWM)

J6 und J9 sind offen (ich nutze weder Flash noch SD

Arduino läuft mit 5V Logik also auch noch J7

Vcc muss ich noch in die Unterlagen schauen.

Zusätzlich werde ich noch vor dem Anschluss des TFT an den Pins messen welche Spannung auch anliegt.

Viele Grüße Oliver
Title: Re: 7" TFT Shield - Jumper settings
Post by: HotSystems on Jun 15, 2018, 07:54 am
Ich versteh dein Problem nicht.
Zu jedem Produkt gibt es ein Datenblatt.
Das solltest du lesen.
Wenn es keins gibt, ist es da falsche Produkt oder der falsche Lieferant.
Title: Re: 7" TFT Shield - Jumper settings
Post by: BullSimons on Jun 15, 2018, 08:13 am
Das Datenblatt habe ich gelesen, sonst hätte ich nicht schreiben können wie die Belegung der Jumper aussehen sollte.

Ich wollte eigentlich nur die Belegung von einer zweiten Quelle verifizieren lassen - mehr nicht.
Title: Re: 7" TFT Shield - Jumper settings
Post by: HotSystems on Jun 15, 2018, 08:16 am
Das Datenblatt habe ich gelesen, sonst hätte ich nicht schreiben können wie die Belegung der Jumper aussehen sollte.

Ich wollte eigentlich nur die Belegung von einer zweiten Quelle verifizieren lassen - mehr nicht.
Beides hast du nicht geschrieben. Also warum unvollständige Angaben ?
Title: Re: 7" TFT Shield - Jumper settings
Post by: uwefed on Jun 15, 2018, 08:26 am
Wenn das Datenblatt das richtige ist dann brauchst Du keine 2. Quelle.
Was sagt der Lieferant? Welche Informationen gibt der bezüglich des Produktes?
Ohne genaue Angabe des Produkts gebe ich Dir sicher keine Vorschläge wie Du die Jumper setzen sollst weil ich es einfach nicht weiß.
Grüße Uwe
Title: Re: 7" TFT Shield - Jumper settings
Post by: BullSimons on Jun 15, 2018, 08:55 am
Da ist wohl heute morgen was suboptimal gelaufen und die PDF ginge verloren.
Sorry mein Fehler - war aber noch vor dem ersten Kaffee...

Die zweite Meinung wäre mir wichtig, da die Lieferzeiten für die Displays doch recht lange sind oder sehr teuer und ich möchte voran kommen und nicht nur Schrott produzieren ;)


Edit:
der Händler sagt gar nichts dazu. Der Hersteller schreibt quasi nur -> steck es zusammen und schalte es ein.
Title: Re: 7" TFT Shield - Jumper settings
Post by: uwefed on Jun 15, 2018, 10:58 am
Bitte Link zum Angebot, das Du gekauft hast.
Title: Re: 7" TFT Shield - Jumper settings
Post by: BullSimons on Jun 18, 2018, 04:31 pm
Sorry hat etwas gedauert - ein Wasserschaden benötigt aktuell etwas Aufmerksamkeit...


Link für Displayquelle (https://www.ebay.de/itm/SainSmart-7-7-Inch-TFT-LCD-Shield-TFT-LCD-Shield-For-Arduino-Mega2560-R3-DE/221452143308?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2060353.m2749.l2649)



das wäre der Link.

Aktuell habe ich mal getestet -> Arduino Mega mit meiner Platine (Adapter für Spannungsversorgung etc.) und kleinem 4" Display -> tut. Der Arduino ist also iO und die Platine ebenso (ist ja auch nichts drauf außer die Rausführung der 5V Versorgung.


Von meiner Logik her muss ich doch bei der Adapterplatine bei Logik den Jumper auf 5V setzen? Der Arduino arbeitet mit 5V Pegel und der Adapter setzt das dann auf 3,3V runter (passend für das Display).

Title: Re: 7" TFT Shield - Jumper settings
Post by: BullSimons on Jun 19, 2018, 10:31 pm
Nach einer Anleitung habe ich die Beleuchtung von 5V auf 3,3V geändert.

Alles was ich kurz geschafft habe waren seltsame Streifen, aber nichts was zum Beispiel passt (Beispiel aus der Lib).

Mit meinem CLPD TFT hatte ich 0 Probleme, das jetzige hat den SSD1963 und da klappt überhaupt nichts :(

Ich werde mir wieder nach einem CLPD  schauen und die lange Lieferzeit in Kauf nehmen...

Für weitere Lösungsvorschläge bin ich   aber dankbar.