Arduino Forum

International => Italiano => Generale => Topic started by: EnricoMatzeu on Jun 16, 2018, 04:31 pm

Title: errore nella compilazione
Post by: EnricoMatzeu on Jun 16, 2018, 04:31 pm
salve a tutti sono Enrico, sono nuovo nel mondo di arduino e vorrei risolvere il mio problema
utilizzo un Mega 2560, il programma non l'ho scritto io ma un mio amico, quando me l'ha inviato io ho cercato di compilarlo e inserirlo nel mio Arduino ma non riesco a compilare in quanto appare questo errore:
"no matching function for call to 'VarSpeedServo::write(int&, int)' "
Title: Re: errore nella compilazione
Post by: gpb01 on Jun 16, 2018, 05:10 pm
Buongiorno,
essendo il tuo primo post, nel rispetto del regolamento della sezione Italiana del forum (… punto 13, primo capoverso), ti chiedo cortesemente di presentarti IN QUESTO THREAD (http://forum.arduino.cc/index.php?topic=113640.0) (spiegando bene quali conoscenze hai di elettronica e di programmazione ... possibilmente evitando di scrivere solo una riga di saluto) e di leggere con MOLTA attenzione il su citato REGOLAMENTO (http://forum.arduino.cc/index.php?topic=149082.0) ... Grazie. :)

Guglielmo

P.S.: Qui una serie di link utili, NON necessariamente inerenti alla tua domanda:
- serie di schede by xxxPighi per i collegamenti elettronici vari: ABC - Arduino Basic Connections (http://forum.arduino.cc/index.php?topic=146152.0)
- pinout delle varie schede by xxxPighi: Pinout (http://forum.arduino.cc/index.php?topic=151646.0)
- link generali utili: Link Utili (http://forum.arduino.cc/index.php?topic=126861.0)

Title: Re: errore nella compilazione
Post by: Silente on Jun 16, 2018, 05:38 pm
Senza il programma si sa poco
Title: Re: errore nella compilazione
Post by: docdoc on Jun 18, 2018, 09:50 am
Eh, ma forse già gli basterebbe saper tradurre il messaggio per capire cosa e dove cercare, ma se poi il programma l'ha fatto l'amico direi che dovrebbe chiedere (quantomeno) all'amico...