Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: m_veidemanis on Oct 11, 2018, 12:36 pm

Title: My Windows not work with arduino
Post by: m_veidemanis on Oct 11, 2018, 12:36 pm
At Uno board conect Windows 7 encountered problem  :
Arduino might be malicios software (Code 52) and cant install board.Help pls.
Title: Re: My Windows not work with arduino
Post by: pert on Oct 11, 2018, 12:50 pm
m_veidemanis's picture (which is completely unrelated to the topic):
(http://forum.arduino.cc/index.php?action=dlattach;topic=572958.0;attach=277447)

Did you get the software from the official download page?:
http://www.arduino.cc/en/Main/Software (http://www.arduino.cc/en/Main/Software)
Title: Re: My Windows not work with arduino
Post by: ballscrewbob on Oct 11, 2018, 12:53 pm
Not sure what the picture has to do with your issue ?

Anyway down to your real issue.

If you downloaded the IDE from this site it should not be an issue with your antivirus / antimalware.

You should tell us which software is giving you that error but I suspect its a driver problem.

Are you using a REAL arduino or a clone ?
If it is a clone you may need a driver CH340/341 (http://www.wch.cn/download/CH341SER_EXE.html) or CP2102 (https://www.silabs.com/products/interface/usb-bridges/classic-usb-bridges/device.cp2102)

There are some sites out there that offer drivers but may offer nefarious things instead always make sure you get the OFFICIAL drivers for hardware.



Title: Re: My Windows not work with arduino
Post by: m_veidemanis on Oct 11, 2018, 01:08 pm
Yes, downloaded from original site, no error messages received in process. It works on wife's Mac (but I need it on my PC).
Title: Re: My Windows not work with arduino
Post by: ballscrewbob on Oct 11, 2018, 01:11 pm
CLONE or REAL Arduino ?  PS. we dont care which it is as we dont judge LOL

Title: Re: My Windows not work with arduino
Post by: m_veidemanis on Oct 11, 2018, 01:14 pm
Sorry, uploaded the wrong picture. The right one included now.
Title: Re: My Windows not work with arduino
Post by: ballscrewbob on Oct 11, 2018, 01:20 pm
Ok I see what you have there now.

(http://forum.arduino.cc/index.php?action=dlattach;topic=572958.0;attach=277449)

Two choices to get past that.

1. Turn off "Driver enforcement" (you can google that easy enough)

2. Try running the driver install as Administrator.  (Google "RUN AS ADMINISTRATOR")

One of those options should get you past the issue but if you use option one remember to turn driver enforcement back on afterwards.

If sounds like your install of windows was done nicely and with security in mind.

Title: Re: My Windows not work with arduino
Post by: pert on Oct 11, 2018, 01:20 pm
m_veidemanis's picture
(http://forum.arduino.cc/index.php?action=dlattach;topic=572958.0;attach=277449)
So the problem is the driver signature. That seems strange because I'd expect the official Arduino Uno driver to be signed and not cause this problem.
Title: Re: My Windows not work with arduino
Post by: ballscrewbob on Oct 11, 2018, 01:26 pm
Hi Per.

Some windows installations can still cause that error.
Not seen too often with a "stock" windows install but if it was done properly (by my standards LOL) for a relatively new computer user I tend to save myself call outs by adding a few extra tweaks.

Some OEM's, colleges, companies also lock things down a little too.



Title: Re: My Windows not work with arduino
Post by: m_veidemanis on Oct 11, 2018, 01:50 pm
Tnx ballscrewbob.Solved.Working fine.
Title: Re: My Windows not work with arduino
Post by: ballscrewbob on Oct 11, 2018, 01:54 pm
Nice to get an easy one before the caffeine kicks in.
Thanks.