Arduino Forum

Using Arduino => Interfacing w/ Software on the Computer => Topic started by: rhezner on Apr 07, 2019, 11:18 pm

Title: Problem with uploading firmware to cr-10 melzi board using arduino IDE.
Post by: rhezner on Apr 07, 2019, 11:18 pm
Hey guys, I've been trying to upload modified firmware to my cr-10 melzi board, and I've been having issues.  The bootloader is already installed, so until I get the firmware uploaded my printer is basically a brick.

Here is the error message that I've been getting:

Code: [Select]
avrdude: ser_open(): can't set com-state for "\\.\COM4"

Things I've tried:

- Changing the baud rate (I assume 115200 is standard for cr-10)
- Changing between usb 3.0/2.0
- Changing the drivers, I've tried the drivers from crealities webite
- Using different settings in the arduino software
- Using a different computer altogether (my laptop has no other usb devices, so that's not the issue)

Thanks for any help!
Title: Re: Problem with uploading firmware to cr-10 melzi board using arduino IDE.
Post by: ieee488 on Apr 07, 2019, 11:30 pm
If your board is on COM4
and
If the driver is installed properly

Title: Re: Problem with uploading firmware to cr-10 melzi board using arduino IDE.
Post by: pert on Apr 08, 2019, 03:12 am
Make sure you have selected the port of your melzi board from the Tools > Port menu.

Sometimes the port will be labeled with the board name in the menu. Other times it will not. If you don't know which port is your melzi board, you can find it like this: