Arduino Forum

Using Arduino => Installation & Troubleshooting => Topic started by: dototi on Apr 17, 2019, 03:59 am

Title: problem uploading to board error
Post by: dototi on Apr 17, 2019, 03:59 am
(http://cfile208.uf.daum.net/image/9930D43D5CB67E7F153949)


o/s : windows7

board : arduino uno ( atmega328p-pu )
sparkfun electronics : learn diy ~ kit box

sketch file : examples -> basics -> blink


(http://cfile213.uf.daum.net/image/99FA49335CB68580198B8B)


(http://cfile209.uf.daum.net/image/998E50335CB685801CBF72)


" can't open device  ~ com4 ~ " messsage  means, I thought windows7 driver,
so I tried applied FTDI, CH341, ATMEGA328P DRIVER, CDM,  but I can't fix up.
SO, I don't know, How to fix it.
What is the cause?
Title: Re: problem uploading to board error
Post by: dototi on Apr 17, 2019, 08:17 am
I am trying another.  arduino 1.0.6 version

but, another error messag is 
" serial port 'com4' is already in use message.  Quit any other programs you use. "
(FTDI driver)
hmm.
Title: Re: problem uploading to board error
Post by: pert on Apr 17, 2019, 08:20 am
Try restarting your computer.
Title: Re: problem uploading to board error
Post by: dototi on Apr 17, 2019, 10:56 am
I have already tried many times. on / off
Title: Re: problem uploading to board error
Post by: pert on Apr 17, 2019, 11:01 am
Please do this:
Title: Re: problem uploading to board error
Post by: dototi on Apr 17, 2019, 12:56 pm
Code: [Select]
  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.
Arduino: 1.0.6 (Windows 7), Board: "Arduino Uno"
Binary sketch size: 1,082 bytes (of a 32,256 byte maximum)

processing.app.SerialException: Serial port 'COM4' already in use. Try quiting any programs that may be using it.

at processing.app.Serial.<init>(Serial.java:171)

at processing.app.Serial.<init>(Serial.java:77)

at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:77)

at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:175)

at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)

at processing.app.Sketch.upload(Sketch.java:1666)

at processing.app.Sketch.exportApplet(Sketch.java:1622)

at processing.app.Sketch.exportApplet(Sketch.java:1594)

at processing.app.Editor$DefaultExportHandler.run(Editor.java:2382)

at java.lang.Thread.run(Thread.java:619)

processing.app.debug.RunnerException: Serial port 'COM4' already in use. Try quiting any programs that may be using it.

at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:101)

at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:175)

at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)

at processing.app.Sketch.upload(Sketch.java:1666)

at processing.app.Sketch.exportApplet(Sketch.java:1622)

at processing.app.Sketch.exportApplet(Sketch.java:1594)

at processing.app.Editor$DefaultExportHandler.run(Editor.java:2382)

at java.lang.Thread.run(Thread.java:619)
Title: Re: problem uploading to board error
Post by: pert on Apr 18, 2019, 02:19 am
There must be some other program on your computer that is opening COM4. COM ports can only be opened by one program at a time.