Arduino Forum

International => Italiano => Generale => Topic started by: passodellupo on Apr 20, 2019, 11:45 pm

Title: istallazione driver (risolto)
Post by: passodellupo on Apr 20, 2019, 11:45 pm
Salve a tutti.
Da due giorni impazzisco per istallare la Elegoo uno R3 sul mio pc che monta Windows 7 pro.
Istallata l'ide di Arduino e collegata la scheda al pc non viene rilevata correttamente tanto che in Strumenti/porta non compare nulla di selezionabile.
In gestione periferiche  c'è la voce "arduino uno com 4" identificata da un triangolo giallo. ho seguito tutte le indicazioni per istallare manualmente i driver ma l'errore è sempre quello "errore 52, il driver non è firmato digitalmente".
dove trovo i driver corretti per questa scheda? Nel sito del produttore ho scaricato il pacchetto con i driver ma si comportano allo stesso modo.
Che faccio?
Title: Re: istallazione driver
Post by: uwefed on Apr 21, 2019, 12:19 am
Probabilmente la scheda non monta un ATmega16U2 come adattatore USB ma un CH340. Devi scaricarti e installare il driver per il CH340.
Ciao Uwe
Title: Re: istallazione driver
Post by: passodellupo on Apr 21, 2019, 02:00 pm
Probabilmente la scheda non monta un ATmega16U2 come adattatore USB ma un CH340. Devi scaricarti e installare il driver per il CH340.
Ciao Uwe
Grazie della risposta Uwe, ma no, esaminando la scheda ha proprio un ATmel MEGA 16U2.

Altri che possono aiutarmi?
Title: Re: istallazione driver
Post by: uwefed on Apr 21, 2019, 11:27 pm
Il driver per il ATmega16U2 é incluso nel pacchetto IDE.

Ma quella scheda ha giá funzionato una volta su quel PC o su un altro PC? Hai un altro Arduino o clone che funziona?
Potrebbe anche essere che quella scheda sia semplicemente rotta e risolvi chiedendo sostituzione al venditore.

Ciao Uwe
Title: Re: istallazione driver
Post by: passodellupo on Apr 22, 2019, 08:11 am
Il driver per il ATmega16U2 é incluso nel pacchetto IDE.

Ma quella scheda ha giá funzionato una volta su quel PC o su un altro PC? Hai un altro Arduino o clone che funziona?
Potrebbe anche essere che quella scheda sia semplicemente rotta e risolvi chiedendo sostituzione al venditore.

Ciao Uwe
No ad entrambe le domande. La scheda è nuova, appena arrivata, non ho altre schede né altri PC. Collegata si accende il led verde di alimentazione e lampeggia quello arancione.
Ho provato a mandare una mail al produttore ma ancora non risponde (forse per le festività).
Provando ad aggiornare il driver con quello scaricato da questo sito o con quello scaricato dal sito del produttore che è più vecchio, continua a darmi il messaggio che il driver non è firmato digitalmente (errore 52).
Temo in un problema di Windows 7.
Ciao
passodellupo
Title: Re: istallazione driver
Post by: Patrick_M on Apr 22, 2019, 10:10 am
prova a disinstallare il driver e poi a ricollegare l'arduino, con win7 e elegoo 1 r3 non ho mai avuto problemi...

Quote
Collegata si accende il led verde di alimentazione e lampeggia quello arancione
questo è normale, è il solito programma blink che lavora :)
Title: Re: istallazione driver
Post by: passodellupo on Apr 22, 2019, 04:01 pm
Aggiornamento: Ho provato la scheda su un altro PC con win10. Funziona tutto perfettamente.
Il problema dev'essere del mio PC.. o del Sistema Operativo
Title: Re: istallazione driver
Post by: Datman on Apr 22, 2019, 06:54 pm
Devi disattivare in windows 7 la richiesta della firma digitale per l'installazione dei driver. Leggi, ad esempio, qui:
https://www.chimerarevo.com/guide/windows/disattivare-firma-driver-windows-224435/
Title: Re: istallazione driver
Post by: uwefed on Apr 22, 2019, 10:08 pm
Stai usando l' ultima versione del IDE? o una versione pristorica?

Ciao Uwe
Title: Re: istallazione driver
Post by: passodellupo on Apr 22, 2019, 11:57 pm
Ho risolto finalmente.
Ho aggiornato tutti i driver con Driver booster 6 e ancora nessuna novità. Poi ho aggiornato windows 7 con l'ultimo SP disponibile. Da qui il problema è scomparso, Arduino comunica bene con il pc e ho eseguito con successo uno sketch di prova (ho modificato il blink). Funziona.
Per la cronaca, non tengo attiva la funzione degli aggiornamenti automatici perchè il pc  è vecchio e con tutti gli aggiornamenti non si trascina più.

Un grazie sentito a tutti quelli che si sono prodigati per darmi suggerimenti.

passodellupo