Go Down

Topic: ARDUINO DUE compiling issue in ATMEL STUDIO 7 (Read 553 times) previous topic - next topic

rafeeq

I am trying to use ATMEL STUDIO 7 for ARDUINO DUE.
It was not easy job to link arduino DUE package system in Atmel Studio however I could link all library and compiling was almost successful, finally have some error which I could not clear.
Its related to linker file ( i think, not 100% sure).
Attached screenshot.

error is "Erro cannot open linker script file flash_without_bootloader.ld: No such file or directory"

I could not find this file in linker script folder, rather another file "Flash.id"  , so tried renaming command but not helped,

Any one here have clue on this ?

my linker script is
 <-mthumb -Wl,-Map="$(OutputFileName).map" --specs=nano.specs --specs=nosys.specs -Wl,--start-group -lm  -Wl,--end-group -L"..\linker_scripts\linker_scripts\gcc"  -Wl,--gc-sections -mcpu=cortex-m3 -Tflash_without_bootloader.ld -Wl,--cref -Os -Wl,--check-sections -Wl,--unresolved-symbols=report-all -Wl,--warn-common -Wl,--warn-section-align>

attached screenshot of linker and files in liner script folder.
I already noted the file name difference, but renaming also not helpde. :-(

I tried renaming from  "Tflash_without_bootloader.ld" to "Tflash.ld" but it make more errors



rafeeq

Hello,
Thanks for reply.
I already gone through that blog, he explain well about flashing/programming and not much about library and compiling.
I have problem in linking and compiling, I think now stuck in linking, and upto some extend i cleared library linking.
The error i think its related to linker and  "*.lk"  file.
 
Any one had same problem and cleared compiling and linking please help.

Go Up