Go Down

Topic: avrdude: usbdev_open(): did not find any USB device "usb" bug (Read 109350 times) previous topic - next topic


switching between Programming modes bug, what happens:

if you have a sketch open for arduino i.e. ArduinoISP or TinyISP and have it set to AVRISP MKII then switch to another sketch that had Arduino as ISP set (for programing attiny for example), it will show Arduino as ISP chosen, but will cause error:

avrdude: usbdev_open(): did not find any USB device "usb"

fix: switch to any other prorgrammer, then back to arduino as ISP and error goes away.

it makes it look like arduino as ISP is chosen, but it really isn't somehow.
for(i = 0, i < 820480075, i++){ Design(); Code(); delay(1000); } // hellowoo.com


I have exactly the error you describe trying to program an ATTINY 85 using the ArduinoISP.

It has been driving me nuts!

(Uno rev 3, Arduino  1.0.3, Win XP)

Too tired to try it now, I hope it works tomorrow!
"Nothing is foolproof to a sufficiently talented fool"


It worked, selecting "Arduino as ISP" an toggling back and forth a couple of times got it working.

I managed to upload "Blink", and even though it reports:
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85
avrdude: please define PAGEL and BS2 signals in the configuration file for part ATtiny85

it is working as it should.

"Nothing is foolproof to a sufficiently talented fool"


Thanks hilukasz - I'd not seen this before, but your post saved a lot of my hair tonight I think.  It's not often I am doing both ATmega and ATtiny work simultaneously, but I am here and your explanation certainly makes sense based on my experience in the past hour.

Cheers ! Geoff
"There is no problem so bad you can't make it worse" - retired astronaut Chris Hadfield



The solution in this post does not work for me. I am having the same problem but with different conditions:

I am trying to program a ATTINY25 with my UNO, using  http://code.google.com/p/arduino-tiny/

Uploading  ArduinoISP sketch was ok. Then programmed the Attiny25 with modified blink sketch...

All was apparently well, but led does not blink, and Arduino IDE shows both messages:

             Upload finished. (actually says "Carga terminada." because is in spanish)
             avrdude: usbdev_open(): did not find any USB device "usb"

Can anybody help me please?

Thanks in advance.



May 24, 2013, 03:42 pm Last Edit: May 24, 2013, 03:54 pm by virtual1 Reason: 1
Sometimes you have to do some more zigzagging to get it to work again.  I use ardweenys a LOT here for their low cost, and I find this problem somewhat frequently when I'm in a hurry.  After I hit upload, I tend to turn on the serial monitor. (which always turns off and closes when you upload??)  When the upload finishes, it reboots the ardweeny.  But when you turn on the serial monitor, it reboots it AGAIN.  If these reboots happen too close to each other, (turn on the serial monitor within 1 sec of the upload finishing because you are impatient) it often causes the serial port driver to jam up and you get this message when you try to upload.

Sometimes trying again fixes it.  Sometimes quitting the IDE and relaunching fixes it.  Sometimes it just plain gets STUBBORN and you have to get more drastic.  I was just rebooting my computer, and that always worked, but I've found a faster way.  Open your serial select and note which one is checked.  Quit the IDE.  Unplug your serial adapter.  Relaunch the IDE.  Select a serial.  Your serial interface will not be listed, nothing will be checked.  Select something else. (may need to select something very different, mine is a /dev/cu, so I select a /dev/ty) and try to upload.  It will fail.  Quit the IDE.  plug back in your adapter.  Relaunch IDE.  Re-select your serial adapter.  Should work now.

(If not, you are probably going to have to reboot your computer to reset the serial driver)

And to avoid the problem, avoid rebooting your arduino over serial WHILE it is already in the process of rebooting.
(this could also be caused by hitting upload a second time while an upload is in progress, I haven't tested it that heavily)


I was having similar problems. I am running Arduino IDE 1.6.x. and I am trying to program to an ATTINY 85

The problem was fixed once I selected:

Tools > Board > ATTINY
Tools > Programmer > Arduino as ISP
Tools > Processor > ATTINY 85

Cross my fingers the problem doesn't come back ;)


Hi, I have a similar problem when I try to burn bootloader it says:

avrdude: usbdev_open(): did not find any USB device "usb"

but when I try to upload sketch using programmer it uploads without any problem.

Can anybody help me please?

Thanks in advance.


Nice guys~ fix my problem please.

I have the same problem with Mega 2560.
tested with three different computers, and 5 boards, and always getting same error words; avrdude: usbdev_open(): did not find any USB device "usb"

I'm almost burned out to find solution to dissolve this error for days.

- - - -

so I have tried AVR studio to burn bootloader to 2560, and 16u2 because sketch can't upload. unfortunately AVR studio with Arduino IDE can't be successful to compile sketch file.

kindly show me how to do....


I have the same problem

avrdude: usbdev_open(): did not find any USB device "usb"

But it's because I programmed Python to use the AutoHotKeys to open and upload a program into the Arduino Uno.

Any suggestions?

Thank you so much!


If you have Atmel Studio installed, the driver for the programmer may have updated to one that does not work with Arduino. Go to Windows device manager properties and find the AVRISP mkII. Right click it for properties and click the Driver tab. Click the Roll Back Driver button to revert back to the older driver. In my case this reinstalled the libusb-win32 device. This fixed my "did not find issue"


This really was the issue with my Uno (post of dougJack). I have installed Atmel Studio and somehow that have broken my AVRISP mkII drivers.

However, my solution was to follow this guide to flash the bootloader via Atmel Studio: https://startingelectronics.org/tutorials/arduino/arduino-uno-burning-bootloader-avr-studio/


This is a REALLY old bug. I first reported this back in 2011.
Regardless what many people have said including the main avrdude developer, this
is an issue created by avrdude and can and should be solved in avrdude.
I even came up with the avrdude patch to fix it. (it is only a couple of lines of code)

It can be fixed in avrdude or worked around in the IDE, but after pushing on and lobbying both sides for many years, I have not been able to get either side to either fix it or work around it.

Here is more reading about it:

The ultimate irony is that the issue only shows up for Atmel made products like AVR dragon, and AVRISP MKII

--- bill

Go Up