Go Down

Topic: Yun '-fhonour-copts' error (Read 674 times) previous topic - next topic

sscirrus

Jan 28, 2017, 10:23 pm Last Edit: Jan 29, 2017, 07:03 pm by sscirrus
I've been trying to install `cryptography` on Yun for two days. Here's what's happening:

Version: OpenWRTYun Attitude Adjustment 1 / LuCI 0.11 Branch (0.11+svn10537)


Try to install cryptography with `pip install cryptography`.

Error:

Code: [Select]
Complete output from command python setup.py egg_info:
cc1: error: unrecognized command line option '-fhonour-copts'
cc1: error: unrecognized command line option '-fhonour-copts'
cc1: error: unrecognized command line option '-fhonour-copts'
cc1: error: unrecognized command line option '-fhonour-copts'
    
No working compiler found, or bogus compiler options
passed to the compiler from Python's distutils module.
See the error messages above.
(If they are about -mno-fused-madd and you are on OS/X 10.8,
see http://stackoverflow.com/questions/22313407/ .)
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-cXpswC/cffi/


Attempted fixes:

Code: [Select]
pip install --upgrade setuptools     Success
pip install ez_setup                 Success
easy_install cryptography            Error (same as before)
opkg install cryptography            Error (unknown package)


Tried installing Yun GCC:

Code: [Select]
opkg install binutils
opkg install make
opkg -t /root install yun-gcc

Also tried:
cd /root
wget  http://downloads.arduino.cc/openwrtyun/1/packages/yun-gcc_4.6.2-2_ar71xx.ipk
opkg install /root/yun-gcc_4.6.2-2_ar71xx.ipk


Both approaches failed to avoid the error.

I then tried the OpenWRT-SDK for Yun:
http://forum.arduino.cc/index.php?topic=327674.msg2262343#msg2262343
http://forum.arduino.cc/index.php?topic=309246.msg2148560#msg2148560

Code: [Select]
cd /usr/lib/python2.7/
wget https://www.dropbox.com/s/n6pafjual1dfcmg/evdev.tar.gz?dl=0 -O evdev.tar.gz --no-check-certificate
tar -zxvf evdev.tar.gz
rm evdev.tar.gz


I tried Python bindings for the Linux subsystem:
http://forum.arduino.cc/index.php?topic=305926.msg2148554#msg2148554

Code: [Select]
mkdir -p ~/evdev
cd ~/evdev
git clone https://github.com/gvalkov/python-evdev.git
cd ~/evdev/python-evdev
mkdir -p ~/evdev/python-evdev/build/tmp
mkdir -p ~/evdev/python-evdev/build/lib
source ~/setup.sh

-ash: source: can't open '/root/setup.sh'


I've tried everything I could find but I'm still not able to make this work. What am I missing?
Thank you very much.

Go Up