Go Down

Topic: Problems once I have the Yum up and running. Wi-fi connections (Read 3586 times) previous topic - next topic

VideoLiam

Hi,

I am afraid I can see this new Yun being a huge head bang for a lot of people, who are not complete experts at wi-fi networks.

For the record I an using a widows 7 laptop, a window XP main system, and samsung tablet and a Linksys WRT54GS router. My router is configed to be the DNS server and hands out IP address in the range 192.168.1.100, upwards until 120. I am using standard windows firewall and the firewall option is active in my router. I also used Mac address 'permit only' listing as well as WEP security. Whilst I am sure this is not the be set up in the world, it works.

OK. I got my nice shiny YUN out of the box, and using my laptop logged on to the YUN client. I loaded the new 1.5.4 IDE on to the laptop and up loaded a blink sketch to the YUN and all was cool and I was smuggly happy.

I then used the laptop to configer the YUN to see my home network and after all the MAC address restrictions solved, it appears as an active Mac address in my wirless client mac list. However I notice it has not got a IP address listed next to it. This is the same as my Samsung tablet, which uses my Wi-fi. But my laptop is fully listed, IP address and all.

OK alls well. If I try to use the arduino.local command (this was a new one on me) in ANY browser, I get no responce from the YUN. I might not be using the syntax correctly, but then a google is not much help here.

If I make an educated guess at the ip address 192.168.1.102 I get lucky and I can access the YUN on my laptop, and desk top though the network. But here is the rub, my laptop IDE now things EVERY board I select is conected to 192.168.240.1, even a Uno.... I find the arduino. local command fails on all machines so now I can guess the ip address and access the YUN but the IDE is 'jammed' so I can not upload to it, and hence its all a bit useless... Also the IP address 192.168.1.102 is likley to change depending of which device I start first the, YUN, the laptop or tablet. So I need something more predictable.

I have tried reading the comments about port 5656 but I don't have a dregree is mind reading, so the comments like 'Oh, just open port 5656' mean little when this could apply to the router, or the indivdual firewall, as each menu system is different, with different lables and different discriptions. This makes things a bit tricky for someone who is 'mostly capable' at computers, and not Master Jedi. If I am having these problems, then I think this is going to be a very popular subject in the weeks to come.

I would be greatful if anyone can point out to me any mistakes I am making, as I am surely getting there, all be it with difficulty. and I I sure I will not be alone.. Even if it is possble to point me to were to learn as this is the kind of suject matter google is really bad for researching. I get thousands of rubbish trash articles and adverts and nothing sensible. Sometimes a good book is useful, but trying to find one is like google giving a decent answer to a proper question.

Thanks

Liam



federicofissore

Hi Liam, thanks for reporting your experience

You said you were successful uploading the blink: did you upload it using via wifi or via COM port?

You also said your IDE is jammed and thinks an arduino uno is on port 192... etc? Did you see this after having actually plugged in an uno? If so, once you plugged it in, have you selected both board and port from the tools menu?

VideoLiam

Hi,

Thanks for the responce..

OK, interesting point.

I was first able to upload to the YUN a blink sketch, as soon as I and used my laptop to directly connect to my YUN on it own client wi-fi. IE, I seached for wireless networks on my Laptop, after turning on the YUN, Seeing the YUN wi-fi I connected to it, and it was then I uploaded the first test sketch successfully, as it could see the 'port' 192.168.240.1 for the YUN.

since the first upload and after changing the YUN to my home network when using the IDE the port option was always grayed out. Even if I selected an UNO, (without connecting it to the USB port). Now that I have connected the Uno the port option has started to fuction again.. and I have loaded a new blink sketch to an UNO from the Laptop using 1.5.4 IDE.

Now... heres something VERY interesting, becasue I thought you might ask... I then reselected the YUN on my Laptop, and then tried to select the port option again.... and there were two choices, the COM choice and the YUN with the IP address that MY DHPC server had given it, and it uploaded!

There seems to an issue with the refreash of the board and port selection of the IDE, as it has been holding on the the old YUN ip address until using and UNO and then re-selecting the YUN, causing the re-freash.... were I had been expecting it to freash afer a boot up or two, and hence wouldn't have chosen an incorrect IP address and when I left it select, of course it wouldn't upload.

Still can not get the local command to work... what is the correct systax, may I ask?

federicofissore

#3
Sep 23, 2013, 11:26 pm Last Edit: Sep 23, 2013, 11:30 pm by Federico Fissore Reason: 1
I'm super happy things are now working.
Regarding the round trip on selecting board/port, I think it's just a timing issue: when the yun starts up, it may take a while to notify the computers on your network about its new IP address. I.E.: maybe just waiting a couple of seconds more and the yun would have appeared in the port menu

Regarding the arduino.local syntax: it's correct. The only thing that may not work is the lack of propert bonjour/zeroconf support on windows.

May I ask you to google for "Bonjour windows download" and install Bonjour print services by Apple?
I'm not giving you a direct link because, depending on your windows version, apple web site may show a different version of their software

Once installed, you should be able to access arduino.local (or myarduino.local if you changed the name from arduino to myarduino)

Keep us posted!

megayachtengineer

i know how you feel i have had nothing but problems out of the box and still cant sort it

VideoLiam

Hi Frederico,

OK I've done some more tests and it looks like it takes a good 2min for the 'my' system find the YUN on the wi-fi network, and incase things are 'sticky' in the system a selection away from troublesome option and giving it a few minutes and selecting back and giving it a few minutes might help other people. (Possbilly a force re-scan a future option?)

The 'arduino.local' thing is therefore a second negative and thus unrelated. Might be worth making a bigger issue of it being limited under windows, after all I like lynix, when I can play with my PI But regratably there is a huge percentage of us out therethat are stuck with having to use windows as we don't have the time to learn Mac, Windoz, Lynix and belive it or not DOS is still out there..... I can have to work 5 different operating systems, (95, Dos, XP, 7 and Mac in a day) so please pity us a bit... I can not be an expert in them all...

But thanks for your help and hope this has given others a pointer or two.

Now to have a proper play....

Liam

PS. megayachengineer.- I had a few false starts... One trick I did find was hold down the wlan reset button for 5 sec resets the wi-fi login back to YUN default, and holding it in for 30sec completelty resets the whole wi-fi back to default. That can sometimes help if you find yourself getting stuck..

megayachtengineer

Yeah i think i have worn the darn thing out resetting it?1 i think im there but just getting frustrated with learning the stuff on nthe uno with wi-fi and then getting this bridge business which for some reason my sketches dont like??

federicofissore

@VideoLiam just to put this straight: we are not expecting anybody to be expert at anything. Arduino is all about learning. AND we don't want to force people changing their operating systems. It's just that when we tried the thing on both a windows 7 and a windows 8, it just worked: now I suppose those test PCs were not clean installations

Going back to the problem with your browser not resolving arduino.local, I think it may be solved by installing Bonjour for windows by Apple. I'm pretty sure that's the right step to follow. Please follow it and let me know.
If it keeps non working, you could use the ip address shown in the IDE

Go Up