Go Down

Topic: Problems with USB driver (Read 2263 times) previous topic - next topic

Leonzio

Hello,
starting today with my brand new Yun (although I'm pretty savvy with Arduinos...)   ;)
Running it on Win7 64bit and IDE 1.5.4r2.

I'm facing some problem when the Yun is connected to a USB 3.0 port on my Lenovo laptop. The device is seen on the USB bus but the driver cannot be found and so I get this error:
"The drivers for this device are not installed. (Code 28)"
Instead if the Yun is connected to a different USB port of the same laptop (2.0 in this case) then it works perfectly and it's seen by Windows as a HID keyboard + HID mouse and as Arduino Yun Serial port (COM48). And of course the Yun is 100% working (tried some Temboo samples).

I tried to reinstall the IDE and the USB drivers but I still face the same issue: it seems like the laptop could not find a proper driver when the Yun is connected to the laptop's USB 3.0 bus.

Anyone has faced the same issue or have an idea on how to solve that? I can work with the USB 2.0 port of course... but I think it might be useful to solve the issue in case this might affect other users with USB 3.0 only sockets.

Thanks
Andrea

Encryptic

I have also encountered similar issues as well. On a Windows 7 (64-bit) and IDE 1.5.4r2 Windows would not recognize the drivers for the Yun, yielding an error code -28 on my system.

When plugged into the internal USB 2.0 ports on my laptop, I have found that I am unable to install drivers. The port which I attempted to use is on a hub which shares my USB-based mouse. When switched to a different port, installation was immediately successful.

Also, I cannot say for certain, but I believe the USB port that I attempted to use the Yun with has also been used in the past with the Leonardo. I am not sure if this is related, but this may be helpful information for anyone else troubleshooting these issues.

Leonzio

Hi Encryptic,
in my case the USB 3.0 port has been used successfully with various Arduinos (Uno, Mega 2560, Mega ADK) and IDE 1.0.5. It does not work with Yun drivers (same error 28 as you).
Instead I don't think I've ever used with other Arduinos the USB 2.0 port which now works fine with the Yun.

Andrea

Go Up