Go Down

Topic: Wi-Fi won't transmit any data on Arduino Yun (Read 9961 times) previous topic - next topic

zcapozzi

Ok, done.  I've attached the log outputs.


lucad79

well in the logs I can't see any messages about the connection to the wifi network... it seems that something went wrong with the configuration.

Now that you can access to the Yun's webinterface, could you check if you can configure the wifi connection (your SSID is shown in the combobox and so on...)?
www.lucadentella.it

zcapozzi

Yes, I've been able to configure the Yun to use my home Wi-Fi.  It goes into restart mode, asks me to connect my computer to the home network, and then it completes successfully.  There is a link that says something like "I can be found here".  It's the link for arduino.local.  When I try to go there, it can't be found.  That's happened probably 7 times.

lucad79

it seems the Yun can't connect to your wifi... which kind of security are you using? WPA?
www.lucadentella.it

zcapozzi

Yes, but it's the same router, same everything, and the Yun was able to connect before Saturday.  Is it possible that something could have knocked the Wi-Fi capabilities out?  Not on the router side, but on the chip itself.  Is there a way to test this?

federicofissore

What if you open a terminal on your computer and type
Code: [Select]

ping arduino.local

Does it work? If yes, then it's a known browser issue: basically your browser has cached the OLD association IP<->arduino.local. When you configured the yun, the IP changed but the browser is not asking for it. Best thing is to change name of the yun, myyun or something

zcapozzi


lucad79

what is very strange in your dmesg is that it's missing the wlan0 part... for example from my Yun:

Code: [Select]
[   51.690000] cfg80211: Calling CRDA for country: IT
[   51.690000] cfg80211: Regulatory domain changed to country: IT
[   51.690000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[   51.700000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   51.700000] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   51.700000] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[   51.710000] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[   55.530000] wlan0: authenticate with aa:bb:cc:dd:aa:bb:cc:dd
[   55.580000] wlan0: send auth to aa:bb:cc:dd:aa:bb:cc:dd (try 1/3)
[   55.700000] wlan0: send auth to aa:bb:cc:dd:aa:bb:cc:dd (try 2/3)
[   55.700000] wlan0: authenticated
[   55.730000] wlan0: associate with aa:bb:cc:dd:aa:bb:cc:dd (try 1/3)
[   55.730000] wlan0: RX AssocResp from aa:bb:cc:dd:aa:bb:cc:dd (capab=0x411 status=0 aid=5)
[   55.730000] wlan0: associated


Try enter the following command in SSH: cat /etc/config/wireless
You should read the configuration of your wireless network (ssid, key...)... let us know!
www.lucadentella.it

zcapozzi

#23
Nov 13, 2013, 03:25 am Last Edit: Nov 13, 2013, 03:42 am by zcapozzi Reason: 1
I've attached the /etc/config/wireless output...

I was surprised to see that the wifi-iface listed LAN as the option for network.  That doesn't make sense, shouldn't it be a WAN connection.  Anyway, I've attached the output.  Interested in the group's thoughts.

Update: I connected my laptop via the Arduino-xxxx network, reconfigured the wireless and rechecked this log file.  Now the SSID for my router does show up as a wireless connection, but if I unplug the ethernet cable from the Arduino, I lose the SSH connection but the Arduino-xxxx shows up again on my connections panel.

lucad79

Hi

in your config:

Quote
config wifi-iface
   option device 'radio0'
   option network 'lan'
   option mode 'ap'
   option encryption 'none'
   option ssid 'Arduino Yun-90A2DAF202C1'


this is the default configuration for Arduino (AP = access point mode)...
It seems Yun doesn't save your configuration?  :smiley-eek-blue:

Try this:
- connect Yun to your network using a cable
- configure the WIFI connection using the web interface and let Yun reboot at the end, keep the cable connected
- connect to Yun via SSH (after the reboot) and check the content of the configuration file
www.lucadentella.it

federicofissore

zcapozzi, you yun is in access point mode, hence it's NOT connected to internet. That explains why your curl command is not working properly.
I suggest to follow the guide and configure it. If you get stuck at some point, the yun will reboot itself and get back to access point mode. The yun webpanel with then output the error log in a text area below the homepage. Please attach that log to the forum

zcapozzi

I did connect to ethernet after seeing this.  I posted an update to my last post...

"Update: I connected my laptop via the Arduino-xxxx network, reconfigured the wireless and rechecked this log file.  Now the SSID for my router does show up as a wireless connection, but if I unplug the ethernet cable from the Arduino, I lose the SSH connection but the Arduino-xxxx shows up again on my connections panel."

I didn't save down the log file, but my SSID was there.  Do you need to have the log file as well?

federicofissore

Yes. Please, look for it at the bottom of the homepage of yun webpanel

zcapozzi

Here is the log file.  Some may note that I've already attached this once earlier in the thread.

federicofissore

I saw that one but it's not useful: it's a clean one.
I've asked for the output displayed in the webpanel homepage AFTER the yun resets itself. That one contains some useful messages printed by the wifi driver before rebooting and going back to access point mode

Go Up