Go Down

Topic: How to compile Arduino 1.5.6-r2 for the Arduino Due? (Read 906 times) previous topic - next topic

Sondre

Apr 19, 2014, 05:53 pm Last Edit: Apr 19, 2014, 05:58 pm by Sondre Reason: 1
I followed these guides (http://forum.arduino.cc/index.php?topic=135403.0) to compile and upload programs for the Due inside of Eclipse. The guide worked very well for Arduino 1.5.1, but not for 1.5.6-r2. I have set the preprocessor variables that the compiler was complaining about, and everything compiles. However, when uploaded to the Due, it doesn't work. Nothing happens, and the Due has to be erased and reset using the buttons to make it listen on the USB again.

The reason why I want the latest Arduino library, is because I need among others the LiquidCrystal library.

Has anybody here managed to compile using Eclipse to generate the makefiles?

msteam

see my reply here:
http://forum.arduino.cc/index.php?topic=135403.msg1738519#msg1738519

Go Up