Go Down

Topic: LCD keypad shield (dfrobot) doesn't work (Read 10301 times) previous topic - next topic


bperrybap, in mine the USB connector is close but don't touch the shield board. So, I believe that in this case, it don't touch it too. Even if it touches the board, in that place there is nothing that can be a problem (see the picture where is show the shield up side down).




No, the USB conector doesn't touch with the shield board. Well.. even if pins looks like are fine, I'll try to solder some pins.

Thanks!  :)


I can confirm that this SKU 118059 shield has the problem (haven't had trouble because of that, but that beside) that is addressed here.

The constructor that fits it is:
Code: [Select]
LiquidCrystal lcd(8, 9, 4, 5, 6, 7);
So that is correct in your code.

The USB connector doesn't touch those pins, it's about 3 mm (0.12 ") inwards from those pins on the shield.

I have written a review (along with 76 others) about this product, part of what is in it:
Quote from: me

Unit was DOA, with a non working display. After ordering and receiving a new display, fixing it was easy. There's no data available (haven't foud one yet) so had to follow the traces to find out how to set it up, which is an easy job. Display updates a bit slow compared to some other one i tried.

So here's the setup for the display part: LiquidCrystal lcd(8, 9, 4, 5, 6, 7); Reading the keys on analog(0) returns (usb powered): Select : 723 Left :482 Up : 133 Down : 308 Right : 0 The value "Down" will probably always be 0 but the other ones can vary because of external influences like load of the power supply and temperature. so you would have to test for a range covering mentioned values.

Indeed, check for bad contacts, if you have any soldering skills, just redo the pins from display to shield, and shield to Arduino headers.
Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html


I have purchased the same board and yes the same problem occurred. I found out that though it shows program upload successfully but the program was not loaded because i have selected the wrong board as default. so please check the board in tools menu. upload twice and you will be successful


 For those having trouble with this display like I did, the first thing you should try is adjust the blue potentiometer for contrast. Initially, my screen was just lit up, no characters or anything on it. I thought it wasn't displaying anything.
 I had spent a few hours trying different codes, and was even about to do some hardware modifications, but fortunately I tried the contrast adjustment first, and after about 15 seconds of turning the potentiometer, I started seeing the characters and I was really excited.

 I know I'm a little late on this thread, but I hope that I will save someone all the trouble I had to go through until I realized what was the problem.

Go Up