Go Down

Topic: Please upgrade your Yún - latest is 1.5.3 (Read 123216 times) previous topic - next topic


May 24, 2016, 09:19 am Last Edit: Jun 01, 2016, 04:49 am by impressiver
Heads up: The latest version is 1.6.2.

Make sure to pay close attention to the upgrade guide, or you could end up with a brick:

If you have a Yún with an older firmware: (1.5.3) before proceed you need to to upgrade the bootloader following the bootloader update procedure. If you don't upgrade the bootloader first, your Yún will become unusable.
Before you begin, know that following the official upgrade process is done at your peril (even though every Yun shipped prior to this update requires a firmware upgrade):

WARNING: Following this guide will VOID the WARRANTY of your Yún
Hopefully some more information will come out soon from the Arduino folks to clear things up a bit.

Update: I've seen a few reports of failed updates, mostly due to not upgrading the firmware. Use the steps in this post as a guide.


I was able to get into the Lininino Web, but I did the upgrade recommended, OpenWrt-Yun image, and when it was done the YUN WIFI signal disappeared. I don't see it now on any of my devices, I wonder what I did wrong and how can I restore it. Anybody could help with this issue?  Thanks.


Jul 29, 2016, 02:39 am Last Edit: Jul 30, 2016, 03:06 am by Wile
Anyone has taken a look here : https://forum.arduino.cc/index.php?topic=406295.0 ?

There's a SFTP problem...


The described firmware version in that thread seems to be 1.6.2.

I had some trouble with that one too, see my latest post here for a solution that worked for me:



Nov 26, 2016, 05:52 pm Last Edit: Nov 26, 2016, 06:33 pm by fweens
Hi there!

I need your help...

I've tried to upgrade my Yun to the latest version and it didn't work... So I tried the following (as said here https://www.arduino.cc/en/Tutorial/YunUBootReflash):

setenv serverip;
setenv ipaddr;
tftp 0x80060000 openwrt-ar71xx-generic-linino-u-boot.bin;
erase 0x9f000000 +0x40000;
cp.b $fileaddr 0x9f000000 $filesize;
erase 0x9f040000 +0x10000

tftp 0x80060000 openwrt-ar71xx-generic-yun-16M-kernel.bin;
erase 0x9fEa0000 +0x140000;
cp.b $fileaddr 0x9fea0000 $filesize;

tftp 0x80060000 openwrt-ar71xx-generic-yun-rootfs-squashfs.bin;

erase 0x9f050000 +0xE50000;
cp.b $fileaddr 0x9f050000 $filesize;

bootm 0x9fea0000

The last command returned:
ar7240> bootm 0x9fea0000

## Booting image at 9fea0000 ...
Bad Header Checksum

## Booting image at 9fea0000 ...
Bad Header Checksum

In fact when you download the base images zip file, it contains the openwrt-ar71xx-generic-yun-16M-kernel.bin kernel file but not the openwrt-ar71xx-generic-yun-rootfs-squashfs.bin...

May be it's the explanation ? But don't know how to fix it...




Can you tell me how to check if my yun must be upgraded?
Where can I see the current version.



Hi, I subscribe to Renaudp Question:

How to check if my Yun must be upgraded?

The posts in this topic and the Upgrade procedure on Arduino site are really confusing for me:

1. impressiver in post #45 is saying: Heads up: The latest version is 1.6.2. and he makes a link to 1.5.3 on Arduino site. So what is the version to upgrade to??

2. in post #4 is saying: "If files does not exists, then you running Linino." The response I get is: "No such file or directory"
    I didn't start Linino and I don't know how to get to OpenWRT to find out what is in my Yun.

Can anybody help us to clarify this?


Why does https://www.arduino.cc/en/Main/Software show a Yun Image for 1.5.3 which according to their change page (https://github.com/arduino/openwrt-yun) was last updated in 2014?

I thought OpenWRT was supported better and updated more frequently than Linino but Linino's latest version is from 2015.

Is OpenWRT Yun still supported?


I'm trying to update to Python 3 on Yun, which doesn't seem to be supported, but I strongly need Python 3 for a few reasons to do with my project.

Are we getting a new OpenWRT distribution any time soon?


Downloading http://download.linino.org/linino_distro/lininoIO/latest/packages/Packages.gz.
Updated list of available packages in /var/opkg-lists/attitude_adjustment.
Downloading http://download.linino.org/linino_distro/lininoIO/latest/packages/Packages.sig.
Signature check failed.
Remove wrong Signature file.
Collected errors:
 * opkg_verify_file: Unable to get data from file /etc/opkg/trusted.gpg: No such file or directory


I was happily using 2 Yúns until purchasing 2 more newer units with the badly working osjs web interface.  I upgraded to 1.5.3 encountering more issues.  After a long journey with installing several images I finally located the 1.4.1 image that was the same on my older units.  You can get the 1.4.1 image to downgrade via this link:


The uboot flash method never seems to work for me.  Instead the sysupgrade command via USB drive always worked.  You can do this from a sketch console or ssh.

[insert USB drive with the .bin file in the root dir]

cd /mnt/sda1
sysupgrade -n -v openwrt-ar71xx-generic-yun-16M-squashfs-sysupgrade.bin

[reboots after flashing, connect via WiFi, then login using password "arduino"]

Check for the golden version 1.4.1:

cat /etc/openwrt_release

Yún happy again!  :)


I was happily using 2 Yúns until purchasing 2 more newer units with the badly working osjs web interface.  I upgraded to 1.5.3 encountering more issues. 
Agreed. The Linino Arduino OS 2.0.1 is hideous. Who wants a Windows-looking Desktop env, instead of a clean adaptive interface like 1.4 and 1.5x. Not sure what they were thinking or smoking at arduino.org

I had the same issue but I flashed 1.5.3 (everything: uboot,kernel,owrt-yun) from here http://arduino.cc/download_handler.php?f=/openwrtyun/1/YunImage_v1.5.3.zip

I wrote about this here: https://forum.arduino.cc/index.php?topic=504425.0

Strangely, the bin posted here: https://arduino.cc/download_handler.php?f=/openwrtyun/1/YunSysupgradeImage_v1.5.3.zip is 16MB in size whereas the one from YunImage_v1.5.3.zip is 7.9MB so I decided to "upgrade" from smaller 1.5.3 to the larger 1.5.3 and the bridge stopped working. Everything else seems fine but the bridge is not starting when the AVR call Bridge.start() . I tried running run-bridge manually but it blocks the shell.

So I think I will reflash the smaller 1.5.3 and see if it fixes the bridge. What a pain in the butt all these problems and confusion between Yun, Yun Shield and the demented arduino.org stuff with OSJS. Honest to G~d I was going to walk away from Arduino altogether if Arduino OS 2.0.1 was the "future" of this product. Who wants all this bloated crap in this thin architecture.

The reason we all love Arduino IMHO is precisely because of KISS and very simple, elegant clean and hackable toolchain. Once you start adding these layers of crap like OSJS etc. it completely looses the spirit of Arduino. Again IMHO, not sure what the developers were thinking.


Oct 19, 2017, 01:26 am Last Edit: Oct 19, 2017, 05:35 am by WhidbeyBill
Salute to Johnchen16.
The USB upgrade worked just fine on the .ORG boards. Yours was among the first that actually made sense and worked first time. (WhidbeyBill) :)  :)  :)

I also initially had the logon problem in Chrome that was described by another BClaes
so clear the cache, reenter ipaddress. Happy Yun Days are back.

root@arduino:/# cd /mnt/sda1
root@arduino:/mnt/sda1# sysupgrade -n -v openwrt-ar71xx-generic-yun-16M-squashfs-sysupgrade.bin

<message in serial terminal window>

Sending TERM to remaining processes ... uhttpd dbus-daemon dnsmasq avahi-daemon thd ntpd uSDaemon sleep syslogd klogd hotplug2 ubusd netifd
Sending KILL to remaining processes ... uhttpd
Switching to ramdisk...
Performing system upgrade...
Unlocking firmware ...

Writing from <stdin> to firmware ...  [ ....]   
Upgrade completed
Rebooting system...


Earlier I managed to get my old pair of Yun's upgraded to 1.6.2 which I think corresponds to https://github.com/arduino/openwrt-yun-1505 for the source so I am having a go at rebuilding it however the .config didn't seem to match the binaries I found earlier (generic board rather than Arduino Yun for a start) ... can anyone confirm the git repo I found is the latest ?

Is there anywhere else that we can find the configs for the arduino supplied binaries ?

Thx ...


Dec 19, 2017, 02:40 am Last Edit: Dec 19, 2017, 05:47 am by WhidbeyBill
I'll begin by saying I have six Yuns, five working exceptionally well. Just one is stubborn ( I call it BYun ) and has been troublesome for two years but i keep trying to save it. First, although all of the others can use generic uSD cards, this solitary Yun is finicky and will only happen to mount ''one' of my Samsung EVO cards. I speed tested it and its better than the generic Sandisks by 50% writing. Only a bit faster reading. I can mount any old a USB flash just fine. I bought some more Samsung uSD's to try, but no luck.
I actually replaced the USB controller chip ALCOR 6350 (thinking that might help), but still only this one Samsung, out of 8 uSD's,  works, I have these two other Samsungs it won't mount either. Bizarre. O'Scoping the uSD data stream doesn't give me a clue but then my 'scope won't do a capture, either. 
I can do a firmware upgrade via uSD or USB flash on this Yun and at one time I could opkg update without issue - either in LUCi web panel or SSH. But all of a sudden I am getting consistent "Remove wrong signature file" message, regardless of the method. Today I used the same uSD SYSupgrade flash chip to refresh another Yun, and I can do all the other opkg installs on it just fine so its not a file corruption..
The last SYSUPGRADE 1.5.3 flash I did on BYun from the LUCi Web Panel and although the process went smoothly, I am still left with a brick trying to install any other software. I know I have uploaded sketches on this Yun probably hundreds of times in my learning process.
I should also mention that I earlier this year had this BYun fella fully upgraded on a USB expansion, by hacking the expansion sketch to sdb  but I'd wanted it to be like all the others in the network so I went to the trouble of changing the chip thinking it would solve the SD card problem. I don't have any exceptional software to post since this doesn't involve a sketch, per se.
So any clues about the signature problem from the OPENWRT experts? I do have the serial log of three separate flash exercises
Thank You.

Go Up