Go Down

Topic: Freshnew Duemilanove not working - Help? (Read 9506 times) previous topic - next topic


I bought a fresh new Arduino Duemilanove a couple weeks ago and still could not get it working.
Aparently, the board seems fine, undamaged, and when I plug it on the PC, the PWR led goes on normally, although, the windows does not seem to recognize the board.
I read the getting started guide, and tried to get it work on two different PC's with no success at all, wich, on the first hand I had a windows XP 32bits that requires the driver as soon as I plug the board.
I then downloaded the 0022 software and followed the guide with no success, read the forums and initially I tried to define the search folder as the 'FTDI USB Drivers', then the hole 'drivers' folder.
Then I tried the older 0021 software, doing the same scans for the driver, and nothing.
Then I found on the forums an executable 'CDM20802_Setup.exe' driver installer for win XP 32bits. Tried it and nothing.
The PC wont recognize the board, and nothing is shown on the device manager wheni plug it.

I then moved on to a Dell Inspiron 14 Notebook, with windows 7 64bits.
When i plug the Arduino the leds go on normally, but the windows never recognize a new plug-n-play device, nor the lack of a driver, nor nothing.
I then looked up on the device manager for the com or usb ports, but for my surprise i couldnt find any (the device manager is different then on the other PC), I'm not an expert on informatics, and I couldnt find the Arduino there.
And since, apearently, the PC couldnt 'detect' the Arduino, I couldnt try to upload the driver.

I'm frustraded as I can't get it work for a week now.
Any help is appreciated, Thanks already.


Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!


Look at device manager.

Plug in the board.

Manually refresh device manager.

Did anything change?  (It may not initially show up as a com port.  Maybe it'll just show up as an unknown device.)

If not, suspect the cable.  If another cable doesn't cause a change there may be an issue with the FTDI chip on the Arduino.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com


The board is an USB Arduino Duemilanove with ATmega328.

While on windows 7, nothing changes on the device manager..  Even with the leds on the board going on the same way they do on the other PC. Absolutely nothing seems to happen on the pc, at all, when I plug the board. It seems hidden somehow..

On my PC with win XP a "unknown device" shows up on the device manager imediatelly after I plug the board (with the very same cable). Althought, when I try to update the driver with the softwares I listed above, I only got the message that no compatible driver was found..

I will look for another cable to try it out with the notebook and windows7, but since the connection seems to work with the xp, I dont know if thats the real issue..

As I said on another section of the forum, I'm not a informatics expert at all, but I tend to think my two problems are:
a) On the computer with windows XP, I couldnt install the driver because every single one I tried says to be incompatible.
b) On the notebook with windows 7, the board connection seems to be hidden somehow, maybe it is a view option, or a config for plug'n'play devices. Just because no icon next to the clock, nor driver request message, nor device ready, nor nothing pops up when i plug Arduino.


I am facing the exact same problem. Please get this sorted!


Also, i was wondering if i could use the ISCP port to connect to the serial port of my computer and bypass the FTDI chip. If so, where would i find the cable?

Go Up