Go Down

Topic: I bought a counterfeit! (Read 1 time) previous topic - next topic

Isaac96

I just bought a Arduino on Amazon. The seller called it a "CuteDuino" and used a picture of a official Arduino. As it wasn't being sold as a official Arduino, I decided to take the deal. $6.00 USD for a Uno and free Prime shipping! Anyway, it just arrived and turned out to be a counterfeit. It has the bootloader installed already and has a 16u2. What gave it away was the green polyfuse and the red LEDs. The diodes near the two ISP headers are also different. But the Arduino writing was removed. They left the UNO marking on and also "Made in Italy" and "Impatto Zero". Anyway, it is running pre-installed Blink right now. It came in a LinkSprite box. The L led is acting strangely too. I think it is a problem with the circuit that the Uno has to switch it. It is fading on and off. AnalogReadSerial works great, as does DFU.
Do not PM me for help. I will delete immediately.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

Paul__B

So it is running a blink sketch, which should turn the "L" LED on and off.  Is it doing this or what?

Isaac96

It is not running Blink. The LED is randomly fading and flashing. I suspect a problem with the MOSFET that I believe now controls the LED on the Uno boards. But it is fine now.  :)
Do not PM me for help. I will delete immediately.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

Paul__B

#3
Jul 01, 2015, 03:50 pm Last Edit: Jul 01, 2015, 03:56 pm by Paul__B Reason: Always more.
It is not running Blink. The LED is randomly fading and flashing. I suspect a problem with the MOSFET that I believe now controls the LED on the Uno boards. But it is fine now.  :)
I don't follow.  Why is it "fine now"?

Oh, wait on!

Do you mean to say if you load "blink", it works, but if you load a sketch which does not use pin 13, the LED fades randomly?

That is perfectly normal and correct behaviour - if pin 13 is not connected or defined as an output, it wanders about at random since it is high-impedance, and the LED (which is deliberately buffered by the op-amp) follows that random voltage.

Isaac96

I thought there was a pullup resistor or something. Well, I am using UnoJoy on it and it works great!
Do not PM me for help. I will delete immediately.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

Go Up