Go Down

Topic: Yun Network set up Issues (Read 5715 times) previous topic - next topic

muzamil110

Hi

@jessemonroy650 my yun is not showing ip in IDE where it is connected to network do you have any solution

jessemonroy650

Hi
@jessemonroy650 my yun is not showing ip in IDE where it is connected to network do you have any solution
Yes, please start a new thread.
Jesse

jessemonroy650

Jesse, yes, sorry about the confusion, I was trying to help the OP
@mikeruss,
okay no problems, just want to make sure you get connected.

I'm sorry that I had not said this before, have you upgrade your Yun?
There is a sticky at the top of the forum have you follow the upgrade instructions?
There are wifi connection problems with the older software.

Also, the Bonjour software is for your computers so you can type http://arduino.local. The software is already part of the Yun. I just want to be clear on that part.

If you have upgraded then:
* Connect the microUSB to your Yun and the other end of the USB on your computer.
* Start up the YunSerialTerminal (File->Examples->Bridge->YunSerialTerminal)
* Reboot your Yun
* After some time, you should see something like this
Code: [Select]
[   38.080000] Backport generated by backports.git backports-20140320-37-g5c33da0
[   38.250000] cfg80211: Calling CRDA to update world regulatory domain
[   38.260000] cfg80211: World regulatory domain updated:
[   38.260000] cfg80211:  DFS Master region: unset
[   38.260000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   38.260000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   38.270000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   38.270000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   38.280000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   38.280000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   38.280000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   39.240000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
[   39.250000] cfg80211: Calling CRDA for country: US
[   39.250000] cfg80211: Regulatory domain changed to country: US
[   39.250000] cfg80211:  DFS Master region: FCC
[   39.250000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   39.260000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   39.260000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[   39.270000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[   39.270000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   39.270000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   39.700000] NTFS driver 2.1.30 [Flags: R/O MODULE].

* Next type in to the ''YunSerialTerminal'' '''ifconfig'''
* You should see something like this.
Code: [Select]
root@Arduino:/# ifconfig
eth1      Link encap:Ethernet  HWaddr 90:A2:DA:F8:0A:22  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:336 errors:0 dropped:0 overruns:0 frame:0
          TX packets:336 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:22848 (22.3 KiB)  TX bytes:22848 (22.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 90:A2:DA:F8:0A:22  
          inet addr:192.168.240.1  Bcast:192.168.240.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:3263 (3.1 KiB)

* NOTE, the IP number for wlan0 is just what you expect 192.168.240.1, and your Yun should respond to http://arudino.local/ in the web browser

NOW you are going to try to connect to your home network.
* Now go to web control panel and switch to your local home network (copy and paste the password just to be sure it is the correct password)
* In the YunSerialTerminal, type reboot
* After sometime, you should see something like this
Code: [Select]

[   50.420000] cfg80211: Calling CRDA to update world regulatory domain
[   50.430000] cfg80211: Invalid regulatory domain detected:
[   50.430000] cfg80211: Regulatory domain: 00
[   50.430000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   50.430000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   50.440000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   50.440000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   50.450000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   50.450000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   50.450000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   50.460000] cfg80211: Calling CRDA to update world regulatory domain
[   50.460000] cfg80211: World regulatory domain updated:
[   50.460000] cfg80211:  DFS Master region: unset
[   50.460000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   50.470000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   50.470000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   50.480000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   50.480000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   50.480000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   50.490000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   53.590000] cfg80211: Calling CRDA to update world regulatory domain
[   53.590000] cfg80211: World regulatory domain updated:
[   53.590000] cfg80211:  DFS Master region: unset
[   53.590000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   53.600000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   53.600000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   53.600000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   53.610000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   53.610000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   53.610000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   54.330000] wlan0: authenticate with 94:62:69:d7:10:00
[   54.330000] wlan0: send auth to 94:62:69:d7:10:00 (try 1/3)
[   54.340000] wlan0: authenticated
[   54.380000] wlan0: associate with 94:62:69:d7:10:00 (try 1/3)
[   54.380000] wlan0: RX AssocResp from 94:62:69:d7:10:00 (capab=0x411 status=0 aid=5)
[   54.380000] wlan0: associated

* NOTE: it says [   54.340000] wlan0: authenticated
* and [   54.380000] wlan0: associated

NOTE: the authenticate should take from 2 seconds to 2 minutes.
If it continues to authenticate, but never associated,
then the problem is definitely your home router.

Now, it may be a change in the protocol, and OpenWrt and Arduino have not caught up. Or it may be some other problem. However, as you have connected before and you say you see a strong signal from the AP I'm baffled.

If hope, I've been clear as this is the last thing we can try over the message board.

Jesse


nickgammon

Hi
i am facing same problem #mikeruss would you please share solution
Please start a new thread and describe in detail what the problem is.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics

zimme272

Sorry for the long delay hobbies take a back seat to life...

Three Updates:

I can change the password of my Yun only through the advanced configuration.  If I use the front page it does not keep the password and the default password remains.

I have no problem watching the start up procedure with YunSerialTerminal but I have no idea how to do anything with it after that!  I don't know how to "press Enter" as is requested in the Serial Monitor.

I have updated the Yun (I cant remember what version is on there now though - what ever was current a couple weeks ago)

Thank you!

Angelo9999

I can change the password of my Yun only through the advanced configuration.  If I use the front page it does not keep the password and the default password remains.
Did you changed anything on the board before trying to change password or has it a fresh updated version? After changing the password did you clicked on "Configure&Restart"?
https://github.com/sngl

zimme272

I have tried to push the configure and reset in the past and none of the settings save: Not password, not time zone, not WiFi settings.

Could I have screwed up what configure and restart does?  Does it for some reason reset the board?

Angelo9999

Could I have screwed up what configure and restart does?
Did you modify any file on the board (webpanel, config files, etc..) ?
https://github.com/sngl

Go Up